Bug 72811 - FILESAVE: Documents saved in ODF 1.0/1.1 still throw corruption error when opening in Word 2010 because the package is actually ODF 1.2
Summary: FILESAVE: Documents saved in ODF 1.0/1.1 still throw corruption error when op...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
4.1.0.4 release
Hardware: All All
: highest major
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: BSA odf target:4.4.0.0.beta3 target:4...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-12-17 20:41 UTC by Steve Riley
Modified: 2014-12-18 12:59 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
Freshly created document that exhibits the problem described. (8.29 KB, application/vnd.oasis.opendocument.text)
2013-12-17 20:41 UTC, Steve Riley
Details
ODT 1.0/1.1 file that properly opens in Word 2010 without error (41.41 KB, application/vnd.oasis.opendocument.text)
2013-12-31 19:09 UTC, Steve Riley
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Steve Riley 2013-12-17 20:41:37 UTC
Created attachment 90898 [details]
Freshly created document that exhibits the problem described.

Problem description: 

Previously, one could save Writer files in ODT 1.0/1.1 format so that they could be opened in Word 2010 without throwing the "document is corrupted" error. This appears not to be working now. Even when configured to save in ODT 1.0/1.1, documents opened in Word throw the error. Choosing to recover the text works, but this a less than useful experience for people who need to share files.

Steps to reproduce:
1. Change Writer save settings to use ODT 1.0/1.1
2. Create and save a document
3. Open the document in Word 2010
4. Observe error

Current behavior:
As described above.

Expected behavior:
Document opens in Word without error.
Operating System: Ubuntu
Version: 4.1.3.2 release
Comment 1 retired 2013-12-21 20:19:26 UTC
A (maybe stupid?) question: why not use ODT 1.2 Extended? What happens if you use that?

Could you please also test if this is maybe already fixed in 4.2.0.1: http://www.libreoffice.org/download/pre-releases/

Also in your repro steps #2: "Create and save a document" are you referring to saving as doc or docx?

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 2 Steve Riley 2013-12-21 21:06:50 UTC
I can't use ODT 1.2 because Word 2010 _definitely_ is unable to open these files. In the past, Word 2010 has been able to open ODT 1.0/1.1 files, as reported in various places on the Internet. I personally haven't had to do this until just recently, so I can't provide any clues as to when this change in behavior first appeared.

Step #2 refers to creating an ODT document after changing the settings to save the document as 1.0/1.1.

As you requested, I installed the 4.2.0.1 pre-release; the problem persists in this version.
Comment 3 retired 2013-12-21 21:20:27 UTC
Steve, thanks for the update.

I cannot reproduce this problem. I use ODT 1.2. Open your test file save to a) doc b) docx and both files open fine with Word 2010. Could you try that? Also if you say word cannot open those files, this is not a Linux bug because Word does not exist on Linux.

I tend to say NOTOURBUG or WORKSFORME. Could you please set LO to odt 1.2 extended. Export to docx and attach that exported file. I'll then try to open that file. If that file opens for me with Word on OSX this is definitely not a LO issue, I'd say.

So another round of the NeedInfo game ;)
Comment 4 Steve Riley 2013-12-21 21:59:27 UTC
Yes, if I save a file in Writer using DOC or DOCX format, it opens just fine in Word.

According to http://ask.libreoffice.org/en/question/13054/which-is-the-best-file-format-to-exhange-with-microsoft-office/, there is a link to an ODT 1.0/1.1 test file (see first answer). That file opens correctly in Word 2010.

But something has changed in LibreOffice Writer's ability to create ODT files that open in Word. Perhaps something has changed in more recent versions of LibreOffice Writer, and it creates ODT 1.0/1.1 files differently than before?
Comment 5 retired 2013-12-23 14:49:14 UTC
Steve, does that mean it works with for you with newer LO versions? If 1.2 works ok, I'd say let's use that and be done? But maybe I'm missing something.
Comment 6 Steve Riley 2013-12-23 18:59:28 UTC
I think I'm not clearly communicating the issue. Let me try again.

Using LibreOffice Writer, I want to create a document that someone else can edit in Word 2010. The person needs to be able to open the document, edit it, and save it. At some point in the past, this was possible. In Writer, you could create a document, save it as ODT 1.0/1.1, and send it to the other person. That person could open the document in Word 2010 and no error message would appear.

This behavior seems to have changed. I can still create ODT 1.0/1.1 documents in the current (and pre-release) versions of Writer. However, when opening these documents in Word, Word throws a "file is corrupt" error message. Thus, something has changed in the way Writer creates ODT 1.0/1.1 documents.

ODT 1.2 documents have _never_ interoperated, so I'm not asking about that. And I don't want to create DOC/DOCX files in Writer, because I don't want to use Microsoft proprietary formats.

I hope this more clearly explains the problem I'm seeing.
Comment 7 Thomas van der Meulen 2013-12-31 09:31:40 UTC
Yes I can reproduce that if I save the test file in 1.0/1.1 .odt format that Microsoft word 2007 will say that the file is corrupt and tries to repair it. with succes the file opens the text then but it is not the way it is supposed to be. 

I am setting this bug to NEW and Steve what was the version that it was still working so I can test and set it as a Recression. 


Versie: 4.2.0.1 
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a
Microsoft office 2007
OS: Windows 7
Comment 8 Steve Riley 2013-12-31 19:09:56 UTC
Created attachment 91376 [details]
ODT 1.0/1.1 file that properly opens in Word 2010 without error
Comment 9 Steve Riley 2013-12-31 19:14:02 UTC
Unfortunately, I can't say for sure when this regression entered, as I've not had to use Open Office for document sharing until very recently.

I've attached an ODT 1.0/1.1 file that opens in Word 2010 without error. Most likely, this file was created with an earlier version of Writer. Is there a way you can examine the document's properties to determine whether this is indeed the case?
Comment 10 Steve Riley 2013-12-31 19:16:12 UTC
Uh, I mean Libre Office. Sorry! :)
Comment 11 Fabrizio Foschi 2014-09-09 07:40:54 UTC
Hi,
I want to stress with the highest priority to the resolution of this bug.

Because it affect significantly the interoperability between LibreOffice and Microsoft Office, this in view of the possible cooperation between these two great systems.

It seems to me that this very grave error, seemingly simple and dismissive (it is December 2013), has not yet been corrected.

This bug affect greatly the reputation of LibreOffice.

Instead of adding "big" feature, you must first correct the easier errors.

Thanks for kind attention.
Comment 12 Phil 2014-10-15 08:45:26 UTC
Hi,
I'll add that I've tried this with LO 4.3.2 (Linux).
The interoperability problem persists: MS Word 2007 rejects the resulting ODT 1.0/1.1 files as corrupt; MS Word 2010 reports the same error but can "fix" the file.
Comment 13 Fabrizio Foschi 2014-10-28 10:43:47 UTC
(In reply to Phil from comment #12)
> Hi,
> I'll add that I've tried this with LO 4.3.2 (Linux).
> The interoperability problem persists: MS Word 2007 rejects the resulting
> ODT 1.0/1.1 files as corrupt; MS Word 2010 reports the same error but can
> "fix" the file.

Hi Phil,
Thank You for the intervention.

It's a shame that this interoperability issue was not taken into account at all.
I see many great scaffolding are carried out, and instead base left behind.
Comment 14 Björn Michaelsen 2014-11-16 16:36:52 UTC
(In reply to Steve Riley from comment #8)
> Created attachment 91376 [details]
> ODT 1.0/1.1 file that properly opens in Word 2010 without error

About the file that still worked with MSWord: Which version was is generated with? (aka what is the last _known_ version were LibreOffice still produced a file that was still opened by MSWord?) I we know about this having to worked in a specific version this can be marked as a regression.

Also this can profit greatly from being bibisected: http://wiki.documentfoundation.org/Bibisect
Comment 15 Steve Riley 2014-11-17 01:24:10 UTC
(In reply to Björn Michaelsen from comment #14)
> 
> About the file that still worked with MSWord: Which version was is generated
> with? (aka what is the last _known_ version were LibreOffice still produced
> a file that was still opened by MSWord?) I we know about this having to
> worked in a specific version this can be marked as a regression.

I don't know the answer to that. I thought it might be useful to find some ODT document someplace that didn't exhibit any problems with Word. Then I was hoping that it might be possible to compare that document to the other, not working, document that I included in the original bug description. Possibly some difference in file format between the working and the not-working document would help to determine the cause of the problem.
Comment 16 Buovjaga 2014-11-26 15:47:39 UTC
attachment 90898 [details] gives no error message when opened in Word 2013 (Win 8.1).
Comment 17 Steve Riley 2014-11-26 17:57:48 UTC
(In reply to Beluga from comment #16)
> attachment 90898 [details] gives no error message when opened in Word 2013
> (Win 8.1).

I can confirm this, same setup: Word 2013 on Windows 8.1. However, Word 2010 on Windows 7 still throws the error.
Comment 18 Michael Stahl (CIB) 2014-12-05 23:10:09 UTC
oh noes, we write manifest:version="1.2" into ODF 1.1 files now?

the document itself is apparently version 1.1 but the package is version 1.2

regression in LO 4.1 from:

commit 06b918053fb9cf455cf431ca001a63030092d018
Author:     Muthu Subramanian <sumuthu@suse.com>
AuthorDate: Thu Apr 25 11:47:56 2013 +0530

    Broken security/password when saving to older odf (sx?) formats.
    

well we removed the OOoXML (sx?) format export anyway so we can just revert that.

fixed on master.
Comment 19 Michael Stahl (CIB) 2014-12-05 23:11:12 UTC
oops, forgot to add the bug id, master commit is ebfec3517d001f8aa8baaabde7c4af6b01347b95
Comment 20 Commit Notification 2014-12-05 23:17:58 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-4":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5ca70e202e1568547c2eab4fb0f12176f295117f&h=libreoffice-4-4

fdo#72811: Revert "Broken security/password when saving to older odf (sx?)

It will be available in 4.4.0.0.beta3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 21 Commit Notification 2014-12-07 19:42:34 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5faedcab93d2f987f91e2750119198b18891f4d1&h=libreoffice-4-3

fdo#72811: Revert "Broken security/password when saving to older odf (sx?)

It will be available in 4.3.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 22 Commit Notification 2014-12-10 20:16:29 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-3-5":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ee9d871254b0c3befa86cb7a2209bac7355e6da&h=libreoffice-4-3-5

fdo#72811: Revert "Broken security/password when saving to older odf (sx?)

It will be available in 4.3.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.