Bug Hunting Session
Bug 72892 - UI: OLE objects should be able to be edited out place
Summary: UI: OLE objects should be able to be edited out place
Status: RESOLVED DUPLICATE of bug 52055
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.5.2 release
Hardware: All All
: low enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-19 23:38 UTC by Cyril
Modified: 2014-04-30 20:37 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Cyril 2013-12-19 23:38:27 UTC
When an OLE Draw object is in a Writer document, it should be appreciated to be able to edit this drawing in a full Draw window.

Keep actual in place editing on double-click.
Rename "Edit" context menu to "Edit here".
Add an "Edit out place" in context menu.
Comment 1 Joel Madero 2013-12-22 16:01:14 UTC
Thank you for reporting this enhancement request! I can confirm that this is a valid enhancement request on:
Version: 4.3.0.0.alpha0+Build ID: daa57a101a20e0b37db7090796ad002b8d192b9b
Date:   Sun Dec 15 23:07:57 2013 +0100 
Platform: Ubuntu Linux 13.10 x64
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
As I've been able to confirm the enhancement request I am marking as:

New (confirmed)
Enhancement
Low -- lots of workarounds, doing edits inside is not difficult, or just open the OLE object in draw, do your edits, then re insert them into the writer document. Because workarounds are easy and clean no reason to make this a high priority.


As for the wording, I prefer:
Edit
Edit in COMPONENT (so "edit in draw" or "edit in spreadsheet")

something to the affect
+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 2 tommy27 2014-04-30 20:37:33 UTC
it looks to me that this enhancement has already been requested.

see Bug 52055

*** This bug has been marked as a duplicate of bug 52055 ***