Bug Hunting Session
Bug 72914 - automatic date recognition does not work as set in options
Summary: automatic date recognition does not work as set in options
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Base (show other bugs)
Version:
(earliest affected)
3.6.0.0.beta1
Hardware: x86 (IA32) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-20 14:52 UTC by joerg_schwarze
Modified: 2016-01-31 15:25 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description joerg_schwarze 2013-12-20 14:52:19 UTC
Hello,

since this is the first time i'm using this bugzilla, I apologize for anything I may do wrong here.

OK, I have a Libreoffice BASE Database on an i5 Laptop running Win7pro-64. LO is Version 4.1.4.2.

I have noticed the following behaviour maybe since I switched from Version 3 and it did not work correctly since then, but it did before (Can't remember the exact version, but it has been a year or so since it last worked).

In the database there is a Form where I can enter Date+Time in the following Format: DD.MM.YY HH:MM.

When just entering DD.MM (e.g. "31.12" (no dot after month!) for Dec. 31st of the running year) it used to work and Base would fill in the Date to "31.12.13 00:00" (in this year 2013).

But it does convert "31.12" to "02.01.31 00:00" !  "31.12." (with the dot) works as it should.

The Language setting for date recognition is set correctly to "D.M.Y;D.M.;D.M" (German Version), so as I understand it it should work, but it doesn't.

Thanks for any help!
Comment 1 Robert Großkopf 2013-12-20 15:43:48 UTC
Could confirm, that this is working up to the first Version of LO 3.6 I could test here, LO 3.6.0.0beta1. So I set this to the first version, which doesn't accept the changed value "M.D" in the locale settings.
Comment 2 Alex Thurgood 2015-01-03 17:39:46 UTC
Adding self to CC if not already on
Comment 3 QA Administrators 2016-01-17 20:05:40 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.4 or later)  https://www.libreoffice.org/download/

If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT:

- Update the version field
- Reply via email (please reply directly on the bug tracker)
- Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)

If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2016-01-17
Comment 4 Robert Großkopf 2016-01-31 15:25:52 UTC
Seems the bug has been gone. If I add in locale settings for a date "D.M" I could use this inside a form, also inside a tablecontrol of a form.
Only for input directly in a table this would be ignored.

I will set this one to RESOLVED and WORKFORME. Feel free to reopen if it doesen't work for you with LO 5.1.0.3. Tested this with OpenSUSE 42.1 64bit rpm Linux.