Bug 72932 - Dialog with ListBox where "multiple selection" has been checked doesn't work
Summary: Dialog with ListBox where "multiple selection" has been checked doesn't work
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: BASIC (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-20 19:33 UTC by Jan Rheinländer
Modified: 2018-10-11 11:52 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document with form button, macro and dialog (10.46 KB, application/vnd.oasis.opendocument.text)
2013-12-20 19:33 UTC, Jan Rheinländer
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jan Rheinländer 2013-12-20 19:33:48 UTC
Created attachment 91057 [details]
Writer document with form button, macro and dialog

See the attached document. I created a dialog with a list box with three items. It works fine until I add the option for multiple selections. Then it doesn't open up any more.

Note: The attached document has a button to which a macro has been assigned that opens up the dialog.
Comment 1 Jan Rheinländer 2013-12-20 19:35:01 UTC
This bug has been confirmed by users of my ooo-imath extension, and on other OS than Linux, too.
Comment 2 Joel Madero 2013-12-21 01:59:43 UTC
Please provide clearer steps on exactly what we need to do to confirm this bug. Enumerated helps:

1. Open document
2. Etc . . .

Don't assume that we know everything just because we're contributors :) Marking as NEEDINFO - once you provide the needed steps mark as UNCONFIRMED and we will test. Also updating to ALL for OS since you said others confirmed on different operating systems.

Thanks for helping - clear instructions make our jobs 1000x easier and we have thousands of bugs to triage. Thanks again!
Comment 3 Jan Rheinländer 2013-12-21 09:33:04 UTC
1. Open attached document
2. Confirm that you want to allow macros
3. Click on the button on the empty page
4. In the dialog, open the list box and confirm that you can select an entry
5. Close dialog again
6. Get edit permissions on the document
7. Go to Extras - Macros - Manage dialogs - Dialog.odt/Standard/Dialog1 - Edit
8. Choose the listbox and allow multiple selections in the properties
9. Go back to the empty page with  the button
10. Exit form editing mode
11. Click on the button again and confirm that the list box doesn't open any more
Comment 4 pierre-yves samyn 2014-06-20 16:59:45 UTC
Hi

I confirm on windows 7/64 & Version: 4.2.5.1
Build ID: 881bb88abfe2992c6cede97c23e64a9885de87de
and with Version: 4.3.0.1
Build ID: 67f5430184326974072b65403ef1d9d934fc4481

Regards
Pierre-Yves
Comment 5 QA Administrators 2015-07-18 17:42:34 UTC Comment hidden (obsolete)
Comment 6 Jan Rheinländer 2015-07-21 17:41:41 UTC
Bug is still present in LO 4.4.3.2 on Windows 7
Comment 7 Cor Nouws 2015-09-01 10:15:05 UTC
It does work for me on 32 bits Linux in 4.4.5.2 and 5.0.0.5..
Comment 8 Cor Nouws 2015-09-01 10:15:59 UTC
Was it OK in earlier versions, Jan?
Then it should be marked as regression and a bibisectrequest added to the whiteboard.
Thanks!
Cor
Comment 9 Jan Rheinländer 2015-09-05 06:23:17 UTC
(In reply to Cor Nouws from comment #8)
> Was it OK in earlier versions, Jan?
> 
I never used this functionality in earlier versions so I'm afraid I can't say.

The bug persists on 5.0.1 in Windows 7 / 32 bit

Jan
Comment 10 Julien Nabet 2015-10-10 06:07:39 UTC
Jan: could you give an updated step by step process to reproduce this?
Indeed, some steps don't work:
3) When I click on the empty button, no dialog displays
6) What's "Get Edit permissions", how do you retrieve this?
8) Where to enable "Multiple selection" property? Right click show "Properties" options enabled and that's all
Comment 11 Jan Rheinländer 2015-10-13 17:05:18 UTC
1. Download attached document and save it somewhere
2. Open the document
3. Confirm that you want to allow macros (you must set your macro security to medium for that to work)
4. Turn off the form design mode if it isn't already (there is an icon on a toolbar for this - I haven't found the menu entry yet)
5. Click on the button on the empty page
6. In the dialog that opens, open the list box and confirm that you can select an entry
7. Close dialog again
8. Go to Extras - Macros - Manage dialogs - Dialog.odt/Standard/Dialog1 - Edit
9. Choose the listbox in the dialog editor and allow multiple selections in its properties (on the General tab)
10. Save
11. Go back to the empty page with  the button
12. Click on the button again and confirm that the list box doesn't open any more
Comment 12 Julien Nabet 2015-10-13 19:37:40 UTC
(In reply to Jan Rheinländer from comment #11)
> 1. Download attached document and save it somewhere
> 2. Open the document
> 3. Confirm that you want to allow macros (you must set your macro security
> to medium for that to work)
> 4. Turn off the form design mode if it isn't already (there is an icon on a
> toolbar for this - I haven't found the menu entry yet)
> 5. Click on the button on the empty page
> 6. In the dialog that opens, open the list box and confirm that you can
> select an entry
> 7. Close dialog again
> 8. Go to Extras - Macros - Manage dialogs - Dialog.odt/Standard/Dialog1 -
> Edit
> 9. Choose the listbox in the dialog editor and allow multiple selections in
> its properties (on the General tab)
> 10. Save
> 11. Go back to the empty page with  the button
> 12. Click on the button again and confirm that the list box doesn't open any
> more

Ok for 1, 2, 3, 4, 5, 6
7: why close dialog Again (first time we close dialog) but just nitpicking
8: there's no menu "Extras".
I tried Tools/macros/Organize dialog, then selected Dialog1, then clicked "Edit".
Finally, I right click on the listbox, selected "Properties" but it does nothing.
Comment 13 Jan Rheinländer 2015-10-13 19:51:03 UTC
1. Download attached document and save it somewhere
2. Open the document
3. Confirm that you want to allow macros (you must set your macro security to medium for that to work)
4. Turn off the form design mode if it isn't already (there is an icon on a toolbar for this - I haven't found the menu entry yet)
5. Click on the button on the empty page
6. In the dialog that opens, open the list box and confirm that you can select an entry
7. Close dialog
8. Go to Tools - Macros - Manage dialogs - Dialog.odt/Standard/Dialog1 - Edit
9. Left click on the listbox in the dialog editor. In the properties field that shows up (on the left of the screen for me) turn on multiple selections 
10. Save
11. Go back to the empty page with  the button
12. Click on the button again and confirm that the list box doesn't open any more

Sorry I was assuming that whoever looks at this bug is somewhat familiar with LO dialogs! Also my UI is German so I am only guessing at the English names of things.
Comment 14 Julien Nabet 2015-10-13 19:59:37 UTC
Thank you for your feedback but sorry, I don't find the right option to reproduce this, so I give up.
Certainly someone may help you here.
Comment 15 Julien Nabet 2015-10-13 20:59:37 UTC
Ok after some tests, I found I missed Multiple selection because property window didn't open.
Indeed with gtk3, I got the bug described in tdf#95021 (in See Also)

With gtk (SAL_USE_VCLPLUGIN=gtk), I can see properties and multiple selection property now.

I gave a try with master sources updated today and with LO Debian package 5.0.2.2, I enabled multiselection and could indeed select several values with "Ctrl" key
But, if I close the odt doc after having saved and opened again, I see multiselection isn't enabled.

=>bug reproduced.

Sorry for the confusion!
Comment 16 Julien Nabet 2015-10-13 21:09:18 UTC
Argh! I just tested again and it works now with LO Debian package 5.0.2.2 and with master sources updated today, "Heisenbug"?
Except, give a try with LO 5.0.2 with a brand new LO profile by rename your LO directory profile (see https://wiki.documentfoundation.org/UserProfile#Windows), no idea.

Put it back to UNCONFIRMED :-(
Comment 17 Buovjaga 2015-10-14 16:15:24 UTC
For me, there was no button to click.
I could run the macro, however.
After I edited the dialog to enable multi-selection, the listbox did not work anymore.

Hence setting to NEW.

I also got a crash when exiting the dialog editor, even after having changed nothing. Maybe it is the same as bug 95021

Win 7 Pro 64-bit, Version: 5.0.2.2 (x64)
Build ID: 37b43f919e4de5eeaca9b9755ed688758a8251fe
Locale: fi-FI (fi_FI)
Comment 18 Mauricio Baeza 2016-07-06 05:03:23 UTC
This bug persists on LibO 5.0.6 in Windows 7 / 64 bit and LibO 5.1

En Linux work fine
Comment 19 QA Administrators 2017-09-01 11:15:01 UTC Comment hidden (obsolete)
Comment 20 ThierryT 2017-09-02 19:20:47 UTC
Bug still exist on this version ;

Version: 5.4.1.2 (x64)
Build ID: ea7cb86e6eeb2bf3a5af73a8f7777ac570321527
Threads CPU : 4; OS : Windows 6.29; UI Render : par défaut; 
Locale : fr-FR (fr_FR); Calc: group
Comment 21 QA Administrators 2018-09-03 02:42:34 UTC Comment hidden (obsolete)
Comment 22 Andreas Säger 2018-09-26 06:01:24 UTC
Multiselection implies no drop down. You can't perform multiple selections on a drop down box.
Multiple selection = yes
Drop down = no
Drag the box a bit taller.
Works.
Comment 23 Buovjaga 2018-09-26 07:11:58 UTC
(In reply to Andreas Säger from comment #22)
> Multiselection implies no drop down. You can't perform multiple selections
> on a drop down box.
> Multiple selection = yes
> Drop down = no
> Drag the box a bit taller.
> Works.

Very good point. If we change Dropdown to "No" in the dialog editor, multiselection works.
I wonder, if the dialog editor should disable the multiselection option, if Dropdown is set to "Yes"? I could discuss it and perhaps open a new report.
Comment 24 Buovjaga 2018-10-03 11:45:43 UTC
(In reply to Buovjaga from comment #23)
> I wonder, if the dialog editor should disable the multiselection option, if
> Dropdown is set to "Yes"? I could discuss it and perhaps open a new report.

bug 120282