Bug 72947 - StartCenter mouseover file URL is not escaped, thus it’s unreadable
Summary: StartCenter mouseover file URL is not escaped, thus it’s unreadable
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: target:4.3.0 target:4.2.0
Keywords:
: 71872 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-12-21 11:50 UTC by Miro
Modified: 2015-01-24 12:07 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
screenshot of dialog (120.36 KB, image/jpeg)
2013-12-21 11:50 UTC, Miro
Details
screenshot of obscure file URL (120.36 KB, image/jpeg)
2013-12-21 11:56 UTC, Miro
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Miro 2013-12-21 11:50:26 UTC
Created attachment 91079 [details]
screenshot of dialog

New start screen in 4.2 shows recent files, I very like it,
but file names are cut.
I think it is very important to see full name,
the is plenty empty space for it.

Thanks
Comment 1 Miro 2013-12-21 11:56:43 UTC
Created attachment 91080 [details]
screenshot of obscure file URL
Comment 2 retired 2013-12-21 15:30:47 UTC
Do I understand you want to show the entire File name? Not sure what purpose that would serve. The shortened file name should be enough to enable you to choose which file to open. If you need more info there's always the mouse over with the full file URL.

Imo NOTABUG. If other QA members disagree, please re-open and state your opinion. Also Miro if I misunderstood you, please re-open and elaborate and what you would like to see.
Comment 3 Miro 2013-12-21 15:43:51 UTC
OK, then,
but as i have shown in my screenshot
file name under mouse over is broken and not understandable.

Thanks
Comment 4 retired 2013-12-21 18:15:09 UTC
Agreed. That is another bug then and I've adjusted the title accordingly. Setting to NEW.
Comment 5 Adolfo Jayme 2013-12-22 12:32:27 UTC
Hi, Kendy: I was wondering if you’re interested in tackling this bug :-)
Comment 6 Commit Notification 2014-01-10 13:13:55 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=60c7ed80643a6c397feebdd1492d6c3ef4d810be

fdo#72947 Startcenter: display more userfriendly file urls in tooltips



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-01-10 14:04:46 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=943dd8bfd8695f11773b90fbfebd4179eee9f492&h=libreoffice-4-2

fdo#72947 Startcenter: display more userfriendly file urls in tooltips


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-01-10 16:20:30 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=340e70e248824a3a4959fa1dee90c5650f257ae8

fdo#72947 Startcenter: handle file urls and non-file urls on a different way



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2014-01-10 18:17:28 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7ebac02b35700b7ca96e636d5729b65115c2c708&h=libreoffice-4-2

fdo#72947 Startcenter: handle file urls and non-file urls on a different way


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Jean-Baptiste Faure 2014-01-11 16:27:17 UTC
*** Bug 71872 has been marked as a duplicate of this bug. ***
Comment 11 Commit Notification 2014-01-13 10:57:13 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a23979349e7cf6d9d40577a37815d480c88d4c40&h=libreoffice-4-2-0

fdo#72947 Startcenter: display more userfriendly file urls in tooltips


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.