Bug 72953 - Graph Legends disappeared
Summary: Graph Legends disappeared
Status: RESOLVED DUPLICATE of bug 72005
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
(earliest affected) rc
Hardware: All Linux (All)
: highest critical
Assignee: Not Assigned
Keywords: regression
Depends on:
Blocks: mab4.2
  Show dependency treegraph
Reported: 2013-12-21 16:15 UTC by tim
Modified: 2015-12-15 22:19 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:

Spreadsheet demonstrating the problem (72.52 KB, application/vnd.oasis.opendocument.spreadsheet)
2013-12-21 17:25 UTC, tim

Note You need to log in before you can comment on or make changes to this bug.
Description tim 2013-12-21 16:15:10 UTC
I have a complex set of many tens of sheets, with many containing graphs of data in other sheets.  In all the graph legends are empty.  They are OK in

I have tried to replicate the problem with a simple pair of sheets, one with a simple graph of the data in the other, but am so far unable to do so.  I will keep trying and attach one later if I can.

I cannot attach the file that shows the problem, or even send it by pm, because it contains highly personal financial data.  I may be able to cut it down to just one non-sensitive example.
Comment 1 tim 2013-12-21 17:25:27 UTC
Created attachment 91098 [details]
Spreadsheet demonstrating the problem

The attached has 2 sheets - a graph and some data.  In the legend is blank.  In and previous is it not.

This was created by deleting all non-relevant parts of a rather complex set of sheets.  I'm hoping none of that data remains - I have looked.  There are some empty macro modules (one per sheet) but that seems to be all.  I'd be grateful if someone could inform me if I have left something other than the 2 sheets.
Comment 2 Joel Madero 2013-12-21 18:26:11 UTC
Hey Tim -

You are correct - and this looks quite nasty. Good catch.

Verified on
Ubuntu 13.10
LibreOffice works fine
LibreOffice rc & 4.3 master built just a few days ago are both broken.

Marking as:
Critical - loss of data (or at least a reading error that makes users think the data is lost), main component (chart legends are very common)
Highest - regression


CC'ing Markus - think this one might be yours (or kohei's perhaps)
Comment 3 Mihkel Tõnnov 2013-12-21 18:57:58 UTC
I tried with some of my documents and the charts showed fine there. Looking further into it, I found that the legend disappears only if it has background colour set (in the sample provided here, it has white background). That problem is tracked at bug 72005 - resolving this one as duplicate.

*** This bug has been marked as a duplicate of bug 72005 ***
Comment 4 tim 2013-12-21 19:58:17 UTC
OK - thanks.  I can see that if I change the transparency the legend appears.

When I tried creating a simple graph from scratch in I couldn't reproduce the problem.  I can't say I have ever set the background deliberately, but most of my graphs originally come from an Excel 2003 workbook, and that may be the source of the background colour.

I'll wait for #72005 (and others) to get fixed before migrating to 4.2.
Comment 5 Robinson Tryon (qubit) 2015-12-15 22:19:01 UTC
Migrating Whiteboard tags to Keywords: ()
Remove redundant 'ConfirmedRegression'