Bug Hunting Session
Bug 73006 - EDITING: Results filled in wrong cells after Text to Columns
Summary: EDITING: Results filled in wrong cells after Text to Columns
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
3.5.7.2 release
Hardware: Other All
: high normal
Assignee: Dennis Francis
URL:
Whiteboard: BSA target:5.2.0 target:5.1.0.1 targe...
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2013-12-24 06:25 UTC by boythere
Modified: 2018-05-07 04:28 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Text to Columns (278.55 KB, image/png)
2013-12-24 06:25 UTC, boythere
Details

Note You need to log in before you can comment on or make changes to this bug.
Description boythere 2013-12-24 06:25:33 UTC
Created attachment 91172 [details]
Text to Columns

Problem description: 
Results filled in wrong cells after Text to Columns

Steps to reproduce:
1. Type "A B" in cell A2
2. Select Column A
3. Execute Text to Columns

Current behavior:
Separated A and B filled in A1 and B1

Expected behavior:
Separated A and B filled in A2 and B2
              
Operating System: Windows XP
Version: 4.1.4.2 release
Comment 1 Kevin Suo 2013-12-24 06:59:23 UTC
Confirmed in LibreOffice 4.1.4.2 and 4.2.0.1. Ubuntu 13.10 X86. Really terrible!
Comment 2 ign_christian 2014-08-10 10:53:13 UTC
(In reply to comment #0)
> 3. Execute Text to Columns
Separated by "Space" must be ticked

Reproduced in LO 4.3.1.1, 4.2.6.2, 4.0.6.2, 3.6.7.2, 3.5.7.2 - Ubuntu 12.04 x86

Not reproduced in 3.3.0.4
Comment 3 Rostislav 'R.Yu.' Okulov 2015-01-13 07:37:50 UTC
git bisect start
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
git bisect bad 423a84c4f7068853974887d98442bc2a2d0cc91b
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect good 65fd30f5cb4cdd37995a33420ed8273c0a29bf00
# bad: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect bad e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [8f4aeaad2f65d656328a451154142bb82efa4327] source-hash-1885266f274575327cdeee9852945a3e91f32f15
git bisect bad 8f4aeaad2f65d656328a451154142bb82efa4327
# bad: [369369915d3582924b3d01c9b01167268ed38f3b] source-hash-45295f3cdceb4c289553791071b5d7f4962d2ec4
git bisect bad 369369915d3582924b3d01c9b01167268ed38f3b
# good: [351622aec2dff3cc3bbbb020ad0097c4322d2a21] source-hash-2c4537471c932b65e6f72e41881b505c4bbad12c
git bisect good 351622aec2dff3cc3bbbb020ad0097c4322d2a21
# good: [378efb6e51212a05d1bd4b85c916eec5753c1744] source-hash-d453788ac0476cc02b929b0907718ca771d6d956
git bisect good 378efb6e51212a05d1bd4b85c916eec5753c1744
# good: [6fb876793ee949d0a22a542f7782be301d67ebb4] source-hash-4171bfefa788f539cf1f1ef327586e4319722b02
git bisect good 6fb876793ee949d0a22a542f7782be301d67ebb4
# bad: [07963512e1ce0b4d7f3a9baab88fc00036df2903] source-hash-cf1e9315aae7c1c67f795aa9e4f0ea724303cd9a
git bisect bad 07963512e1ce0b4d7f3a9baab88fc00036df2903
# bad: [fdf09fd3e4e5ffb7e578ac1d16eba608c58848b5] source-hash-9e6b086c62b4144058eb52ca40b562ff61e26a68
git bisect bad fdf09fd3e4e5ffb7e578ac1d16eba608c58848b5
# good: [9eb3d13fd2ebe213dfdbd22cae8fe6c7f2998959] source-hash-53f661b3140fe728fe3b8f421841dcb8e6f716ab
git bisect good 9eb3d13fd2ebe213dfdbd22cae8fe6c7f2998959
# first bad commit: [fdf09fd3e4e5ffb7e578ac1d16eba608c58848b5] source-hash-9e6b086c62b4144058eb52ca40b562ff61e26a68

fdf09fd3e4e5ffb7e578ac1d16eba608c58848b5 is the first bad commit
commit fdf09fd3e4e5ffb7e578ac1d16eba608c58848b5
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Thu Apr 26 13:23:48 2012 +0200

    source-hash-9e6b086c62b4144058eb52ca40b562ff61e26a68
    
    commit 9e6b086c62b4144058eb52ca40b562ff61e26a68
    Author:     Luboš Luňák <l.lunak@suse.cz>
    AuthorDate: Tue Mar 13 17:01:10 2012 +0100
    Commit:     Luboš Luňák <l.lunak@suse.cz>
    CommitDate: Tue Mar 13 17:08:59 2012 +0100
    
        string literals in ?: don't get automatically converted to OUString
    
        Technically these two are both const char[8], so gcc/clang keep
        the resulting type the same, but msvc always converts to const char*,
        even if the same sizes mean this is not required.

:100644 100644 993cbfbf9e49d8bd9a0bb5d331fb817f26f2b81f 738bb5e64d6433d95f92a29b1067b17acb62f01b M      autogen.log
:100644 100644 f178947712dcaf7c6f6a1af096b037d9fc29cd11 64abee03e0937b8eccc8f89eb66b7a848fe021b3 M      ccache.log
:100644 100644 2c3ee4067bdeae4da80ee6639e7c92087e43448c 9d9533c05e2a6e2de989ec5cdcc3084f3a6d204b M      commitmsg
:100644 100644 e6adcb9ef9028a1349498b7e76799a2e622fa04e 2c7d9c8b35d335865ca89e91232dab614d2d372c M      dev-install.log
:100644 100644 530de9e3aff1a69fef1199116c00b27de8e61bf4 169a7cfc9cbf1115f8fecc8fe74b06c64455e06b M      make.log
:040000 040000 150f0a0204156287d642070fde5841b76638db37 dfa8c6ab461b1cbb6bd7e7d66297db337f464132 M      opt
Comment 4 Dennis Francis 2015-11-28 17:45:09 UTC
Submitted a patch for review at https://gerrit.libreoffice.org/#/c/20258/
Comment 5 Commit Notification 2015-12-12 21:11:49 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d4c22dbb1c9d71bb83c218d339df83e8727e469c

tdf#73006 : Put results in correct cells after Text to Columns

It will be available in 5.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2015-12-12 21:20:09 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-5-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ca24070a7b765daaea46a88a500f1b6cb78cb1a1&h=libreoffice-5-1

tdf#73006 : Put results in correct cells after Text to Columns

It will be available in 5.1.0.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2015-12-12 21:32:45 UTC
Dennis Francis committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5816c47a65d95629d34d6d40fd040e7bc44ea589&h=libreoffice-5-0

tdf#73006 : Put results in correct cells after Text to Columns

It will be available in 5.0.5.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.
Comment 8 Robinson Tryon (qubit) 2015-12-14 05:20:54 UTC Comment hidden (obsolete)
Comment 9 Markus Mohrhard 2016-04-15 08:30:51 UTC
Seems to be fixed.
Comment 10 Commit Notification 2018-05-07 04:28:24 UTC
Zdeněk Crhonek committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=36c1fab26f767894943203a88082ed50d3fd23f5

uitest for bug tdf#73006

It will be available in 6.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.