Bug 73036 - English spell checker not working
Summary: English spell checker not working
Status: RESOLVED DUPLICATE of bug 75734
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-26 06:44 UTC by rakesh
Modified: 2016-08-18 06:14 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Languages installed on Linux Mint (69.65 KB, image/png)
2016-08-17 21:51 UTC, Óvári
Details

Note You need to log in before you can comment on or make changes to this bug.
Description rakesh 2013-12-26 06:44:02 UTC
the spell check does not work. In fact it does nothing. 
The red lines do not appear below the misspelt words. i just installed the latest version of Ubuntu yesterday. 

What should i do to enale the spell check to work.
Comment 1 David H. Gutteridge 2014-03-02 20:03:45 UTC
Which English variant dictionary are you looking to use? English (USA), or something else? I've found on Fedora 20 that LibreOffice offers the option of non-US variants, e.g. English (Canada), but if I change to that, spell checking stops working. That is, it reports no spelling errors were found, when in fact it really wasn't able to find an English (Canada) dictionary, I suspect (as I tested with typos that are glaringly obvious).

From looking at forums, the first thing to try would be this:

In the LibreOffice menu bar, select: Tools -> Language -> For All Text -> English (USA)

(That's taken from here: http://en.libreofficeforum.org/node/3068 )

If that works, and you want American English spellings, you're done. If that works, but you want another English dictionary, it's likely that that particular dictionary isn't installed. I don't know offhand how dictionaries are bundled for LibreOffice on Linux distros.

Anyway, I hope this helps.
Comment 2 David H. Gutteridge 2014-03-02 20:09:30 UTC
Here are Ubuntu-specific details:

http://askubuntu.com/questions/203727/libreoffice-spell-checker-doesnt-work
Comment 3 Joel Madero 2014-03-03 01:22:54 UTC
Please head over to to our ask site to ask how to use dictionaries as they do currently work so this is a user question on how to correctly use the dictionaries. 

Head here: http://ask.libreoffice.org/ and someone will happily help you out :)

Marking as WORKSFORME as dictionaries do work (they are currently broken in 4.3 but that's another issue ;) )

Thanks for reporting
Comment 4 Óvári 2016-08-17 12:54:12 UTC
1. "English, Australia UTF-8" is 'Fully installed' in Linux Mint's 'Language Settings'.

2. Paragraphs are set to 'English (Australia)' and showing in the status bar of LibreOffice Writer.

3. The 'Spelling' dialog only shows "English (USA)", even though "English Australia UTF-8" is 'Fully installed' (see point 1)

4. Hence, English does not work for variant of English (USA) spelling with Linux Mint 18.

5. Hence, marking status as NEW as description reproducible with:
Version: 5.1.4.2
Build ID: 1:5.1.4-0ubuntu1
CPU Threads: 2; OS Version: Linux 4.4; UI Render: default; 
Locale: en-AU (en_AU.UTF-8)
Comment 5 David H. Gutteridge 2016-08-17 17:26:44 UTC
Óvári: do you have the package myspell-en-au installed on your system? (I believe that's the relevant package for Mint, though I don't use that distro.) If not, it won't matter what your regional settings are, the actual dictionary file LibreOffice requires isn't present. (Another way you can tell is by going to Tools->Language->For Selection and pulling down the Language menu. It will list various languages and their regional variants. If English (Australia) doesn't have a tick mark beside it, it means the dictionary isn't installed on your system.)

In any case, a missing dictionary isn't a LibreOffice bug, at most it's an issue with the Linux distribution packaging it. Well, I would argue there may be a bug involved, namely that if LibreOffice can't find a dictionary for the language settings of a document, it doesn't warn the user. That's already reported separately as bug 75734.
Comment 6 Óvári 2016-08-17 21:51:45 UTC
Created attachment 126883 [details]
Languages installed on Linux Mint

(In reply to David H. Gutteridge from comment #5)
> Óvári: do you have the package myspell-en-au installed on your system? (I
> believe that's the relevant package for Mint, though I don't use that
> distro.) If not, it won't matter what your regional settings are, the actual
> dictionary file LibreOffice requires isn't present. (Another way you can
> tell is by going to Tools->Language->For Selection and pulling down the
> Language menu. It will list various languages and their regional variants.
> If English (Australia) doesn't have a tick mark beside it, it means the
> dictionary isn't installed on your system.)

See attached screenshot from Linux Mint. The language files are ‘Fully installed’.

> In any case, a missing dictionary isn't a LibreOffice bug, at most it's an
> issue with the Linux distribution packaging it. Well, I would argue there
> may be a bug involved, namely that if LibreOffice can't find a dictionary
> for the language settings of a document, it doesn't warn the user. That's
> already reported separately as bug 75734.

Thank you for indicating this bug report.
Comment 7 Óvári 2016-08-17 21:52:31 UTC

*** This bug has been marked as a duplicate of bug 75734 ***
Comment 8 David H. Gutteridge 2016-08-17 22:08:02 UTC
Regarding the screenshot attached, that's not germane to LibreOffice. The real question is whether LibreOffice has what it needs dictionary-wise, which I've already mentioned how to check in this bug report. A language pack for a desktop environment being "fully installed" does not necessarily correlate to LibreOffice having what it requires. If it's expected that Mint does provide a dictionary for LibreOffice (or anything else using Hunspell) when it claims a language pack is "fully installed", that would be a bug with their distribution, not with the Document Foundation.
Comment 9 Óvári 2016-08-18 06:14:16 UTC
(In reply to David H. Gutteridge from comment #8)
Thank you for your comment. The English (Australia) spell checker now works. Here is a list of what was done if someone else also needs the instructions:
1. Linux Mint Menu → Package Manager
2. Search: myspell-en-au
3. Right click on package: myspell-en-au
4. Click: Mark for installation
5. Click: Apply
6. Click: Apply
7. Click: Close

As you mentioned this is a bug with the Linux Mint distributions, a message was placed at:
http://blog.linuxmint.com/?p=3083
Hopefully the bug in the Linux Mint distributions will be fixed so that the above points will not be required.

Thank you