Download it now!
Bug 73091 - EDITING: No sucess in editing Custom Animation Path
Summary: EDITING: No sucess in editing Custom Animation Path
Status: RESOLVED DUPLICATE of bug 53993
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-28 07:50 UTC by Gregor
Modified: 2015-11-30 13:39 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
.ODP Test of Custom animation freeform path. (11.74 KB, application/vnd.oasis.opendocument.presentation)
2013-12-28 07:50 UTC, Gregor
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Gregor 2013-12-28 07:50:45 UTC
Created attachment 91248 [details]
.ODP Test of Custom animation freeform path.

Problem description: I cannot seem to be able to edit a custom animation freeform path.

Steps to reproduce:
1. Select an object (I used a default "diamond"). On the Custom animation pane select Add > Motion Path > select Freeform line.
2. Draw the freeform line for the path.
3. Check the path by playing the Slideshow [F5]
4. Save the presentation
5. Select the path and click the< Edit points> button
6. Move some points check the path (note that the <Save> item in the icon bar does not become available!)
7. Play the animation with the <Play> button or [F5]

Current behavior:
 The new shape of the path is not used.

Expected behavior:
 The new shape of the freeform path is used.

I did notice that dragging handles to reshape the freeform path did change the path and such a presentation could be Saved As... an new presentation. This could be a "workaround" that may be added to some documentation somewhere?

              
Operating System: Ubuntu
Version: 4.1.4.2 release
Comment 1 A (Andy) 2013-12-28 09:58:13 UTC
Thanks for your detailed report:
reproducible with LO 4.1.4.2 (Win8)
Comment 2 Dominik Kopp 2014-07-25 07:19:33 UTC
duplicate of https://bugs.freedesktop.org/show_bug.cgi?id=53993

workaround is to the move the entire path e.g. up and down with cursor keys. Then the modification of the points are taken over.
Comment 3 QA Administrators 2015-09-04 02:49:33 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

Test to see if the bug is still present on a currently supported version of LibreOffice (5.0.0.5 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

Update the version field
Reply via email (please reply directly on the bug tracker)
Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 

1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 
3. Leave a comment with your results. 

4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 
4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-09-03
Comment 4 Buovjaga 2015-11-30 13:39:56 UTC

*** This bug has been marked as a duplicate of bug 53993 ***