Bug 73103 - Selecting part of a file name does not work when using "LibreOffice file dialogs" and KDE
Summary: Selecting part of a file name does not work when using "LibreOffice file dial...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
3.5.2 release
Hardware: x86-64 (AMD64) Linux (All)
: medium normal
Assignee: Maxim Monastirsky
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords:
Depends on:
Blocks:
 
Reported: 2013-12-28 15:57 UTC by Joachim Breuer
Modified: 2014-01-16 15:31 UTC (History)
0 users

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Joachim Breuer 2013-12-28 15:57:42 UTC
When LibreOffice is configured to use its own file dialog implementations with KDE (4.x) (on gentoo Linux x86-64), text within the file name cannot be selected with the mouse.

The problem has been present since at least LibreOffice 3.5.2.2, and is unchanged up to at least 4.1.2.3.


To reproduce:

1. In Tools -> Options, LibreOffice -> General, enable "Open/Save dialogs": "Use LibreOffice dialogs"
2. Open a file dialog, i.e. File -> Open... or File -> Save as...
3. Select a file in the upper pane
4. Try to select text in the "File name:" field below, using the mouse

Actual Results:  
No selection paradigms work (drag, double-/triple click). Instead, any click in this field will drop down the field's history list.
Selecting text using the keyboard (arrow keys, hold Shift to select) works correctly.

Expected Result:
Selecting parts of the file name by dragging or multiple-clicking with the mouse should work as in any other editable text field. The drop down should only open when clicking the drop hint at the far right of the text field.


The related gentoo bug is https://bugs.gentoo.org/show_bug.cgi?id=415367

The first comment of this gentoo bug also has a screencapture of the UI in question.


I'll be happy to provide additional information, or try things out.
Comment 1 Joachim Breuer 2013-12-29 07:43:34 UTC
The issue is still unchanged with LibreOffice 4.1.3.2, with KDE 4.11.2 / Qt 4.8.5.
Comment 2 Maxim Monastirsky 2013-12-29 12:35:09 UTC
Reproducible with a master build (Build ID: 8102d45911bf3c47ce7ee15d3db89b0024c3bff8) with '--enable-kde4'.