Bug 73120 - Cannot Find & Replace for a range, this function works for the entire sheet
Summary: Cannot Find & Replace for a range, this function works for the entire sheet
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.2.3 release
Hardware: All Windows (All)
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Find-Search
  Show dependency treegraph
 
Reported: 2013-12-29 13:02 UTC by sh.yaron@gmail.com
Modified: 2021-12-06 18:32 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description sh.yaron@gmail.com 2013-12-29 13:02:06 UTC
Problem description: 
I can't find and replace in a preselected set of cells, If I'm searching or replacing it will occur for the entire sheet (or all sheets if selected)


Steps to reproduce:
1. Select a range of cells
2. Search for some text not shown in this range
3. The focus will move to unselected cells

Current behavior:
Search cannot be focused to the current range of selected cells

Expected behavior:
Having a selection box that allows me to configure whether I want this search of replacement to take place in the current selected range or in the entire sheet.
Comment 1 m.a.riosv 2013-12-29 13:35:42 UTC
Hi sh, thanks for reporting.

Confirmed with:
Win7x64Ultimate
Versión 3.6.7.2 (ID de compilación: e183d5b)
Version 4.0.6.2 (Build ID: 2e2573268451a50806fcd60ae2d9fe01dd0ce24)
Version: 4.1.5.0.0+ Build ID: 56381a9b28dbe4caf6e3d0a92dfddcddcebe349
Version: 4.2.0.1.0+ Build ID: 241eef7ca9b863ceb1f7f457a4bb2931b5d37f17
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-28_23:19:40

In Find&Replace box, works fine marking Current Selection only, but going again to Find toolbar this options doesn't work.
Comment 2 QA Administrators 2015-04-19 03:23:19 UTC Comment hidden (obsolete)
Comment 3 Zangune 2015-05-23 15:39:10 UTC
If I use the function "Find and replace..." (Ctrl + H) I cannot reproduce.
If I use the function "Find..." (Ctrl + F), Calc ignores the selected range and it searches the whole sheet, is this intended?
LibreOffice 4.4.3.2
Comment 4 QA Administrators 2016-09-20 09:42:31 UTC Comment hidden (obsolete)
Comment 5 m.a.riosv 2016-09-21 22:32:36 UTC
Still there.
Win10x64
Version: 5.2.2.1 (x64)
Build ID: 3c2231d4aa4c68281f28ad35a100c092cff84f5d
CPU Threads: 4; OS Version: Windows 6.19; UI Render: default; 
Locale: es-ES (es_ES); Calc: group
Comment 6 QA Administrators 2017-10-23 14:10:27 UTC Comment hidden (obsolete)
Comment 7 QA Administrators 2019-12-03 14:14:08 UTC Comment hidden (obsolete)
Comment 8 m.a.riosv 2019-12-06 01:05:59 UTC
Still
Version: 6.5.0.0.alpha0+ (x64)
Build ID: 60e8941fd581bb06cbf6be62edb8c387e7c07812
CPU threads: 4; OS: Windows 10.0 Build 19035; UI render: default; VCL: win; 
Locale: es-ES (es_ES); UI-Language: en-US
Calc: CL
Comment 9 QA Administrators 2021-12-06 04:06:17 UTC Comment hidden (obsolete)
Comment 10 m.a.riosv 2021-12-06 18:32:35 UTC
Works for me.
Version: 7.2.4.1 (x64) / LibreOffice Community
Build ID: 27d75539669ac387bb498e35313b970b7fe9c4f9
CPU threads: 4; OS: Windows 10.0 Build 21390; UI render: Skia/Raster; VCL: win
Locale: es-ES (es_ES); UI: en-US
Calc: CL