Bug 73187 - FILEOPEN: Opening .odt file from Windows Share starts LO Math instead of Writer
Summary: FILEOPEN: Opening .odt file from Windows Share starts LO Math instead of Writer
Status: RESOLVED DUPLICATE of bug 67527
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86-64 (AMD64) Linux (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: possibleRegression
Depends on:
Blocks:
 
Reported: 2013-12-31 12:55 UTC by Ulrich Moser
Modified: 2015-12-15 10:53 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Ulrich Moser 2013-12-31 12:55:09 UTC
I use a NAS-Server that exports its directories as Windows Shares and I access them using the smbclient. When trying to open a text file directly from the share LO 4.1.4.2 always invokes Math instead of Writer. This did not happen in LO 4.1.3.2. Copying the file to a local directory and trying to open it works as expected.         
Operating System: Ubuntu
Version: 4.1.4.2 release
Last worked in: 4.1.3.2 release
Comment 1 Ulrich Moser 2013-12-31 13:06:23 UTC
Using the LibreOffice dialogs and accessing the file on .gvfs/<share-name> works.
Comment 2 Ulrich Moser 2013-12-31 13:10:00 UTC
Seems to be related to bug 72460

*** This bug has been marked as a duplicate of bug 72460 ***
Comment 3 Maxim Monastirsky 2013-12-31 13:31:05 UTC
(In reply to comment #2)
> Seems to be related to bug 72460

Hi Ulrich,

I'm sure that it has nothing to do with bug 72460, since accessing FTP and SMB involves completely different code. Instead there are some known problems with SMB, and in order to identify what exactly problem do you have, please answer the following questions:

- What version of Ubuntu do you use?
- Which file manager do you use?
- What the source of LibreOffice packages that you use? Ubuntu repositories, PPA, or downloaded from http://www.libreoffice.org/download?
- And do both 4.1.3 and 4.1.4 are from the same source?
- In case the packages are from Ubuntu repositories or PPA, please open the package manager (like Synaptic) and check if you have 'libreoffice-gnome' package installed.
- In case the packages are from http://www.libreoffice.org/download, check if you have 'libgnomevfs2-extra' and 'liborbit2' packages installed.

Thanks.
Comment 4 Ulrich Moser 2014-01-01 12:44:22 UTC
- What version of Ubuntu do you use?
I am using ubuntu 12.04 LTS on my business notebook and xubuntu 12.04 LTS on my netbook both with actual patches and updates.

- Which file manager do you use?
On my business notebook I am using Nautilus and Thunar on the netbook.

- What the source of LibreOffice packages that you use? Ubuntu repositories, PPA, or downloaded from http://www.libreoffice.org/download?
On the notebook I have installed 1:4.1.4~rc2-0ubuntu1~precise1~ppa1 and the same on the netbook.

- And do both 4.1.3 and 4.1.4 are from the same source?
Yes!

- In case the packages are from Ubuntu repositories or PPA, please open the package manager (like Synaptic) and check if you have 'libreoffice-gnome' package installed.
It is.

- In case the packages are from http://www.libreoffice.org/download, check if you have 'libgnomevfs2-extra' and 'liborbit2' packages installed.

If you have nny further questions don't hesitate to post them.
Comment 5 Maxim Monastirsky 2014-01-01 13:50:21 UTC
OK, so it's a duplicate of Bug 67527. In fact it's not a bug of LO, but a bug in glib package that shipped with Ubuntu 12.04, and tracked at https://bugs.launchpad.net/ubuntu/+source/glib2.0/+bug/1214352.

As a workaround please run the following commands in the terminal:

mkdir -p ~/.local/share/applications

cp /usr/share/applications/libreoffice-* ~/.local/share/applications/

sed -i 's/X-GIO-NoFuse=true/#X-GIO-NoFuse=true/' ~/.local/share/applications/libreoffice-*

These commands will copy LibreOffice .desktop files to your user profile and apply the workaround on them. That way you won't lose the workaround after future LibreOffice updates.

*** This bug has been marked as a duplicate of bug 67527 ***
Comment 6 Ulrich Moser 2014-01-01 21:49:37 UTC
Hi Maxim,

thanks for the hint. I will try when I am at the office again on Saturday.

Kind regards

Ulrich
Comment 7 Robinson Tryon (qubit) 2015-12-15 10:53:38 UTC
Migrating Whiteboard tags to Keywords: (possibleRegression)
[NinjaEdit]