Bug 73229 - StartCenter LO4.2 : Weird text in Extended tooltips
Summary: StartCenter LO4.2 : Weird text in Extended tooltips
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Documentation (show other bugs)
Version:
(earliest affected)
4.2.0.0.beta2
Hardware: All All
: medium normal
Assignee: Gabor Kelemen
URL:
Whiteboard: target:6.0.0
Keywords:
Depends on:
Blocks: Start-Center
  Show dependency treegraph
 
Reported: 2014-01-02 15:20 UTC by Milos Sramek
Modified: 2017-07-16 20:48 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Screnshots illustrating the problem of Start Center extended tooltips (536.35 KB, application/vnd.oasis.opendocument.graphics)
2014-01-05 09:37 UTC, Milos Sramek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Milos Sramek 2014-01-02 15:20:04 UTC
The text in the green button tooltips in the new Start Center of LO 4.2 probably needs rewording. It looks like these were taken from the toolbar icon tooltips without any modification:

All of the tips say "Icon" although these are Buttons. However there are also other problems.

Start Center with Extended tips is something, which perhaps many new users will often see. So I think this needs to be as good as possible.

The tooltips:

Open File
Now:
The Open a Document Icon presents a file open dialog
Suggested text:
The Open file Button opens a file open dialog

Templates
The Templates Icon opens the Templates and Documents dialog 
Suggested text:
The Templates Button opens the Template Manager dialog 

Writer Document
Calc Spreadsheet
Impress Presentation
Draw Drawing
Math Formula
Base Database

The Document Icons each open...
Suggested text:
The Document Buttons each open...

Currently, the Extended tooltips are not displayed in English. See https://www.libreoffice.org/bugzilla/show_bug.cgi?id=73228 for more

--
Milos
Comment 1 retired 2014-01-03 12:14:59 UTC
Hi Milos, could you recheck with 4.2.0.1? Maybe I'm "holding it wrong"(TM) but I can't seem to reproduce.

Maybe I cannot reproduce because a) I've set language to german and there are no translated tooltips? b) OSX specific?

Strange thing is, I also tried 4.3.0.0a0+ (no localization there) and als ono tooltips showup.
Comment 2 retired 2014-01-03 12:16:15 UTC
Please re-check with 4.2.0.1 and set back to unconfirmed if this perists.
Comment 3 Milos Sramek 2014-01-04 16:01:32 UTC
(In reply to comment #2)
> Please re-check with 4.2.0.1 and set back to unconfirmed if this perists.

Hi,

I've tested it in 4.2.0.1 (64 bit ubuntu). Meanwhile, I've installed also the Czech and German version and tested them too. They behave exactly the same.

For example, in German, if Extended tips is checked, all document thumbnails and the also the Hilfe and Extensions buttons show this tooltip:
Klicken Sie ein Symbol ein, um ein Neues Dokument...", which is nonsense - this text does not have anything to do with those buttons.

In English, no tooltips show at all (which I find to be a bug, too), but those, which are displayed in other languages, are translation of "Click an icon to open a new document..."

I guess that the mechanism which assigns the extended tooltips does not work well, since they display differently in English vs. other languages:

Button tooltips:
English: none
Other languages: incorrect tooltips

File thumbnails:
English: file path (perhaps this is the right thing)
Other languages: meaningless tooltip text


__
Milos
Comment 4 retired 2014-01-04 23:11:53 UTC
"if Extended tips is checked"

If you tell me where that option is, I'll happily set it to active and test and most likely will be able to confirm this bug.

Maybe all this seems obvious to you, but the more details the repro steps are the faster we can get this bugs in to NEW status.
Comment 5 tommy27 2014-01-04 23:43:13 UTC
a screenshot would be helpful as well
Comment 6 Milos Sramek 2014-01-05 09:37:58 UTC
Created attachment 91513 [details]
Screnshots illustrating the problem of Start Center extended tooltips

Sorry, I should have been more specific. See the attached drawing.
--
Milos
Comment 7 Milos Sramek 2014-01-05 09:39:24 UTC
Sorry, I should have been more specific. See the attached drawing. I've also chanve version to 4.2.0.1 rc
--
Milos
Comment 8 tommy27 2014-01-05 13:15:12 UTC
(In reply to comment #7)
> Sorry, I should have been more specific. See the attached drawing. I've also
> chanve version to 4.2.0.1 rc
> --
> Milos

you did not read the alert when changing version field.
I'm reverting it now.

you should have seen it saying: "You are changing the version of the bug to a later version. As the version field of the bug should show the earliest version manifesting the bug, please reconsider, if you really want to do this. Please do not change a version, because it also manifests in a later version. for details, please see the guidelines"

version should ALWAYS indicate the FIRST version where the bug is present, not the last.
Comment 9 Jean-Baptiste Faure 2014-01-11 16:20:10 UTC
Reproducible for me in branch 4.2 (tested in 4.2.1.0+) under Ubuntu 13.10 x86-64
Extended tooltips are not correctly managed in the new StartCenter:
1/ in green area: icon instead of button
2/ more important : in the recent files area, extended tooltips do not show the minimal information given by the tooltip. In this case these "extended tooltips" do extend nothing but give only a general information which is not related to recent files.

Best regards. JBF
Comment 10 Alex Thurgood 2015-01-03 17:41:14 UTC Comment hidden (no-value)
Comment 11 QA Administrators 2016-01-17 20:04:50 UTC Comment hidden (obsolete)
Comment 12 Jean-Baptiste Faure 2016-01-22 05:56:02 UTC
Nothing changed since commit #9. Tested in LO 5.1.1.0.0+ and master.

Best regards. JBF
Comment 13 Gabor Kelemen 2017-03-06 10:48:34 UTC
These come from the - somewhat outdated - Start Center help page: http://opengrok.libreoffice.org/xref/help/source/text/shared/guide/startcenter.xhp
moving to Documentation component.
Comment 14 Commit Notification 2017-07-13 18:38:12 UTC
Gabor Kelemen committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/help/commit/?id=8f80dbc1121b3d95df2b2f74501a1657f5cecd5b

tdf#73229 Update Start Center page