Bug 73254 - FILEOPEN: Calc crashes when opening xls document (win only)
Summary: FILEOPEN: Calc crashes when opening xls document (win only)
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA NoRepro:4.2.0.1:OSX Repro:4.2.0.1...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-03 10:59 UTC by draganb
Modified: 2015-06-30 13:15 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
Failing document (223.88 KB, application/vnd.ms-excel)
2014-01-03 10:59 UTC, draganb
Details

Note You need to log in before you can comment on or make changes to this bug.
Description draganb 2014-01-03 10:59:55 UTC
Created attachment 91456 [details]
Failing document

Problem description: 
Cannot open XLS document. LibreOffice 4.1 just crashes. LO 4.2 gives error : Bad allocation.

The XLS document is exported using the Microsoft Reporting Services built-in XLS export. Not all documents exported from ReportingServices fail, but some do.


Steps to reproduce:
1. Try to open the document


Current behavior:

Expected behavior:

              
Operating System: Windows 7
Version: 4.2.0.1 rc
Comment 1 draganb 2014-01-03 11:23:15 UTC
We concluded that the reason it fails to open is because it contains an image. When we removed the image from the report, it opens without problems.


Also, if the original xls file (with image) is opened in excel, not changed at all, and just saved again as xls file, it opens in LO without problems.
Comment 2 retired 2014-01-03 11:49:37 UTC
NoRepro:4.2.0.1:OSX

I open attached test file and it opens fine without any issues. The image at the top left does not load but since that is not the issue at hand and this bug is about LO crashing when opening the test file might be win only.
Comment 3 Thomas van der Meulen 2014-01-03 12:01:09 UTC
I can reproduce this bug on windows 4.2.0.1 
The file opens with out a problem in excel and it opens with out a problem on mac and 4.2.0.1
Comment 4 Joel Madero 2015-05-02 15:42:53 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 5 MM 2015-06-14 02:41:11 UTC
No crash with v4.4.4.1 under window 7 x64.

Indeed the image in the topleft doesn't load, but thats's not the issue here.
Comment 6 Timur 2015-06-30 13:15:47 UTC
Since no crash with LO 4.3.7., I close as WFM.
Image should be searched for in the existing bugs, and reported only if not found.