Download it now!
Bug 73283 - Crashes during manual spellcheck
Summary: Crashes during manual spellcheck
Status: RESOLVED DUPLICATE of bug 73021
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other Mac OS X (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-04 18:24 UTC by Jeff Muizelaar
Modified: 2014-01-05 07:30 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Jeff Muizelaar 2014-01-04 18:24:03 UTC
Steps to reproduce:
1. Click the spell check button on the toolbar.
2. Click ignore for mispelling of 'favorite'
3. Accept the next spelling suggestion for 'holidya'

0   libsclo.dylib                 	0x1601ba9b ScPostIt::CreateCaptionFromInitData(ScAddress const&) const + 27
1   libsclo.dylib                 	0x1601bf0e ScPostIt::UpdateCaptionPos(ScAddress const&) + 30
2   libsclo.dylib                 	0x15ea6a96 ScColumn::CopyCellToDocument(long, long, ScColumn&) + 646
3   libsclo.dylib                 	0x15f63047 ScDocument::CopyCellToDocument(ScAddress const&, ScAddress const&, ScDocument&) + 151
4   libsclo.dylib                 	0x1663d7d2 ScConversionEngineBase::FindNextConversionCell() + 1378
5   libsclo.dylib                 	0x1663da01 ScSpellingEngine::SpellNextDocument() + 17
6   libsclo.dylib                 	0x1663c74c ScSpellDialogChildWindow::GetNextWrongSentence(bool) + 172
7   libcuilo.dylib                	0x1bd8f829 svx::SpellDialog::GetNextSentence_Impl(bool, bool) + 3961
8   libcuilo.dylib                	0x1bd8fec8 svx::SpellDialog::SpellContinue_Impl(bool, bool) + 88
9   libcuilo.dylib                	0x1bd9103b svx::SpellDialog::ChangeHdl(void*) + 187
10  libvcllo.dylib                	0x0177905a Control::ImplCallEventListenersAndHandler(unsigned long, Link const&, void*) + 122
11  libvcllo.dylib                	0x01767ad7 Button::Click() + 39
12  libvcllo.dylib                	0x01a6365a Window::EndTracking(unsigned short) + 266
13  libvcllo.dylib                	0x01a87141 ImplHandleMouseEvent(Window*, unsigned short, unsigned char, long, long, unsigned long, unsigned short, unsigned short) + 3873
14  libvcllo.dylib                	0x01a87dbd ImplWindowFrameProc(Window*, SalFrame*, unsigned short, void const*) + 1277
15  libvcllo.dylib                	0x01ae0ab9 -[SalFrameView sendMouseEventToFrame:button:eventtype:] + 489
16  libvcllo.dylib                	0x01add7f2 -[SalFrameView mouseUp:] + 66
17  com.apple.AppKit              	0x979a926b -[NSWindow sendEvent:] + 719
18  com.apple.AppKit              	0x97947cad -[NSApplication sendEvent:] + 4034
19  libvcllo.dylib                	0x01ad0a32 -[VCL_NSApplication sendEvent:] + 98
20  libvcllo.dylib                	0x01a96035 AquaSalInstance::Yield(bool, bool) + 517
21  libvcllo.dylib                	0x017566e9 Application::Yield() + 73
22  libvcllo.dylib                	0x01756795 Application::Execute() + 53
23  libsofficeapp.dylib           	0x0006f97b desktop::Desktop::Main() + 7403
24  libvcllo.dylib                	0x0175cb82 ImplSVMain() + 226
25  libvcllo.dylib                	0x01a94fc1 AquaSalInstance::handleAppDefinedEvent(NSEvent*) + 129
26  libvcllo.dylib                	0x01ad0a4b -[VCL_NSApplication sendEvent:] + 123
27  com.apple.AppKit              	0x9778c3bc -[NSApplication run] + 823
28  com.apple.AppKit              	0x977751f8 NSApplicationMain + 1165
29  libvcllo.dylib                	0x01a958d6 ImplSVMainHook(int*) + 422
30  libvcllo.dylib                	0x0175cbba SVMain() + 26
31  libsofficeapp.dylib           	0x0009bca5 soffice_main + 277
32  org.libreoffice.script        	0x00001f4e main + 30
33  org.libreoffice.script        	0x00001f25 start + 53


Operating System: Mac OS X
Version: 4.2.0.1 rc
Comment 1 tommy27 2014-01-04 23:31:40 UTC
does this happens just with Calc or with Writer too?
Comment 2 Maxim Monastirsky 2014-01-05 07:30:08 UTC

*** This bug has been marked as a duplicate of bug 73021 ***