Bug 73293 - FORMCONTROLS: "Design Mode" is always ON after opening spreadsheet
Summary: FORMCONTROLS: "Design Mode" is always ON after opening spreadsheet
Status: RESOLVED INVALID
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-05 02:03 UTC by Jim Avera
Modified: 2014-01-06 19:37 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
OptionTickers.ods -- exhibits the problem (341.04 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-05 02:03 UTC, Jim Avera
Details
screenshot of design mode (45.26 KB, image/png)
2014-01-06 18:03 UTC, GerardF
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jim Avera 2014-01-05 02:03:42 UTC
Created attachment 91504 [details]
OptionTickers.ods -- exhibits the problem

Problem description:
 
The form control "Design Mode" seems to always be ON immediately
after opening the attached .ods spreadsheet, even though design-mode was OFF when the spreadsheet was previously saved.

It is necessary to click the design-mode-ON/OFF icon to exit "Design Mode" before any buttons or other controls work.

Steps to reproduce:
1. Open the attached OptionTickers.ods
   (it is not necessary to enable macros)
2. Click on the yellow "Reload tickers.csv" button. 

Current behavior:
Some controls (a group of buttons) is selected for editing

Expected behavior:
The button should be pressed.

              
Operating System: Ubuntu
Version: 4.2.0.1 rc
Comment 1 sophie 2014-01-06 17:24:05 UTC
Hi can reproduce with your document, but not with a document newly created containing controls. So I mark the bug as New, and let developers decide if it's really a bug or a problem with this document. Sophie
Comment 2 GerardF 2014-01-06 18:03:45 UTC
Created attachment 91547 [details]
screenshot of design mode

Hi,

The spreadsheet forms are in "design mode".
Menu View > Toolbars, open the "Form design" toolbar.
Turn Design on (2nd icon, if necessary)
Open the Form navigator (6th icon)
Right-Click on "Forms"
"Open in design mode" is checked. Uncheck.
Save the file.

At reload, all is OK for me.

I don't think this is a bug. If this works for you and if you don't encounter this problem on a new file, this bug can be closed (IMHO, I'm not a dev)
Comment 3 Jim Avera 2014-01-06 19:35:44 UTC
Agreed, this report can be closed.

Dunno how that option got set - it's in a dialog I never knew existed.