Bug 73329 - StartCenter does not display Personas font colours
Summary: StartCenter does not display Personas font colours
Status: RESOLVED DUPLICATE of bug 68546
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: x86 (IA32) Linux (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-06 17:40 UTC by Peter Maunder
Modified: 2014-04-03 09:48 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer 4.2 with City Green Personas showing White font (197.19 KB, image/png)
2014-01-11 17:10 UTC, Peter Maunder
Details
City Green Personas, Writer accessed via Start Center Black on Black (163.05 KB, image/png)
2014-01-11 17:13 UTC, Peter Maunder
Details
description of the link between Personas header and foreground text colour (42.23 KB, application/vnd.oasis.opendocument.text)
2014-02-04 16:30 UTC, Peter Maunder
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Peter Maunder 2014-01-06 17:40:48 UTC
Start Center does not display the Personas font colour, defaults to black. Individual components Writer Calc etc displ;ay the colour.

Expected behaviour. Start Center should pick up the font colour from the Personas settings. For example: the settings in the registrymodifications.xcu file.

<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="Persona" oor:op="fuse"><value>own</value></prop></item>
<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="PersonaSettings" oor:op="fuse"><value>Header.jpg;Footer.jpg;#ff0000;#f5f5f5</value></prop></item> 

The colour setting is #rrbbgg. #ff0000 should display in red. Instead the Start Center appears to default to #ffffff.

Bypass is to avoid the Start Center, and go directly to the component required. This is a pity for me as I like the new Center.  Peter
Comment 1 Jean-Baptiste Faure 2014-01-10 05:31:26 UTC
AFAIK, font color for Persona was not yet implemented in LO.
Please could you attach a screenshot showing the font color in the menus for a module
Which persona do you use? Does it come from Firefox themes repository?

Best regards. JBF
Comment 2 Peter Maunder 2014-01-11 17:10:40 UTC
Created attachment 91867 [details]
Writer 4.2 with City Green Personas showing White font

I normally create our own personas for use on FireFox, Thunderbird, and LibO. I Keep the Personas in the /Gallery/Personas folder using a standard name Header.jpg;footerJpg; for the Personas and #ff0000 for the font colour (red), #000000 for the accent. Footer and accent are not yet supported by LibO.

to illustrate the problem, I have downloaded a Personas City Green from Firefox using the LibO personalization, own theme menu. City Green has a black background and hence uses the font colour #ffcfcf (very white). The white font is displayed when accessing Writer, Calc etc. by opening a file directly. If you open the same file by accessing the Start Center the font shows as black. Black on Black is not possible to read. Shut the system, reopen file directly, the font shows again. 

Personas have to support the font colour function to allow a good colour to be chosen. I attach below the settings from the registrymodifications.xcu file created when LibO dowloaded the City Green personas.

<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="Persona" oor:op="fuse"><value>own</value></prop></item>
<item oor:path="/org.openoffice.Office.Common/Misc"><prop oor:name="PersonaSettings" oor:op="fuse"><value>header.png;footer.png;#fffcfc;#000000</value></prop></item>

I realise now that this is not new to 4.2, but also exists as a problem with 4.1.4 but I never used the Strart Center with that version either.

Expected Behaviour. Start Center should support Personas Font Colour.
Found behaviour only supports black font.

I hope this helps... Peter
Comment 3 Peter Maunder 2014-01-11 17:13:43 UTC
Created attachment 91868 [details]
City Green Personas, Writer accessed via Start Center Black on Black
Comment 4 Peter Maunder 2014-01-12 16:22:01 UTC
On further testing, I found that although the Start Center does not initially display the font colour, and any subsequent screen invoked by the Start Center, for example Writer or Calc, you can force the display of colour for the current Start Center session.

Remove the current Personas:  Tools > options > personalization > Plain look do not use themes, > OK and then
Tool > options > Personalization > Own theme > OK. This will restore the font colour to that set in the registrymodifications.xcu file.

Restarting LibO with Start Center one needs to repeat the process to display the Font Colour.  Writer, Calc etc. invoked directly always displays the Personas font colour directly. 

Hope this helps .. Peter
Comment 5 Peter Maunder 2014-01-25 17:17:54 UTC
Testing with LibreOffice_4.2.0.3_Win_x86.msi and _helppack_en-GB.msi running Win-XP shows that it has the same problem as my linux system with the Start Center font colours.

60542	Color of menu items does not update to match personas  fixed in 4.0.03 refers to the problem in general. However as I never used the Start Center, I am unable to say whether this particular problem has always been there and not a regression, just that nobody noticed. Cheers Peter
Comment 6 Peter Maunder 2014-02-04 16:30:14 UTC
Created attachment 93372 [details]
description of the link between Personas header and foreground text colour

I have been looking around this problem and I thought it might help if I described it in more detail and why I think it is important to fix. I realise the start center has higher priorities at the moment.

I am not certain what further details I can add to define the issue further.
Peter
Comment 7 Peter Maunder 2014-03-25 15:44:11 UTC
According to a patch by Jan Holesovsky ( https://gerrit.libreoffice.org/3482)
The four Personas fields are held in pHeaderURL, pFooterURL, pTextColor and pAccentColor.  So, when the Start Center code picks up the HeaderURL, if it exists to display the Personas Header, it should also pick up the pTextColor, if it exists, to display the text color. 

If you deselect the Personas and then Reselect it, the pTextColor is correctly chosen.

Unfortunately coding was never my strength, although I did help debug the odd S/360 assembler macro before some of you were born. So I am aware I am commenting, not fixing the problem. Hope this helps Peter
Comment 8 Adolfo Jayme 2014-04-03 09:48:47 UTC

*** This bug has been marked as a duplicate of bug 68546 ***