Bug Hunting Session
Bug 73357 - Release plan page reference most of the versions to 7th and 8th of January
Summary: Release plan page reference most of the versions to 7th and 8th of January
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: WWW (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other All
: medium normal
Assignee: Dennis Roczek
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-07 13:27 UTC by grofaty
Modified: 2014-01-24 12:56 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description grofaty 2014-01-07 13:27:47 UTC
Look at the web page: https://wiki.documentfoundation.org/ReleasePlan
Most of the dates are 7 or 8 January but clearly the week number defers, so it is illogical.

P.S. See the same dates on the same web page also on other tables for older releases.
Comment 1 Volker Merschmann 2014-01-07 13:42:17 UTC
Might be a problem with the last cleanup run.

@Dennis: Please have a look!
Comment 2 Dennis Roczek 2014-01-07 13:56:31 UTC
Wow good catch. The template magic of [[Template:Release-plan-one-line-interval]] is borked. So I undone the bot edit and will check what I have to do so that the template works as intended. 

So, the bot worked correctly, but the template didn't. Thanks. I didn't saw that. :-(
Comment 3 Volker Merschmann 2014-01-07 14:00:59 UTC
Can't see it corrected, even after forced reload. ???
Comment 4 Dennis Roczek 2014-01-07 14:29:36 UTC
I believe it is a server problem. All changes (well the ReleasePlan edit) were reverted and actually the dates for 3.5 and 3.4 and 3.3 are correct. the templates weren't changed (except one edit for testing now, but undone again). Manually purging the server cache (and browser cache) wasn't successful on my side, too. :-(

@Floeff any problems with the (MEM) cache on the wiki server? Too many edits today? I don't see any server issues at the moment, but also no statistics on any Special page...
Comment 5 Dennis Roczek 2014-01-07 14:30:37 UTC
(err "edit conflict" causes that my CC wasn't included)

@Floeff any problems with the (MEM) cache on the wiki server? Too many edits today? I don't see any server issues at the moment, but also no statistics on any Special page.
Comment 6 Volker Merschmann 2014-01-07 15:49:21 UTC
Added cloph because of work overload @floeff
Comment 7 Florian Effenberger 2014-01-07 16:47:51 UTC
The server load is as always, and no updates have been installed recently that could cause the issue. Looking at older revisions of the page, the same problem persists, so that indeed indicates a template problem.

The first old version where it seems to work again is https://wiki.documentfoundation.org/index.php?title=ReleasePlan&oldid=73855

Looking at the differences on https://wiki.documentfoundation.org/index.php?title=ReleasePlan&diff=74000&oldid=73855 it indeed seems to be related to the template used from then on.

Manually purging the cache as admin didn't help either, neither for the template, nor for the release plan website.

Can anyone test the template on a local wiki setup, to see if it is actually working as expected? I begin to doubt it's a caching problem...
Comment 8 Florian Effenberger 2014-01-07 16:51:32 UTC
Comparing the template revision at https://wiki.documentfoundation.org/index.php?title=Template%3ARelease-plan-one-line-interval&diff=83255&oldid=74015 also tells me it should be in the proper state.

A restart of Apache and MySQL was done to no avail, and a local file cache does not exist.

Anyone recalls when the page was in proper state the last time?
Comment 9 Volker Merschmann 2014-01-07 16:59:38 UTC
I can remember the template working, as I once was under way to move a release date by a day or so, but letting the page as it was when I saw it was made with templates.
Sorry can't remember the date...

CCing Petr Mladek, who has created the templates.
Comment 10 Florian Effenberger 2014-01-07 17:01:01 UTC
I tried to reproduce it on an internal wiki, but I am a bit lost, as there seem to be quite some heavy interdependencies with regards to all templates.

If someone with a clue on how all that works can try it out, that'd be appreciated. Chances are some other required templates were modified, causing the problem.

At least right now I see no indication of a caching problem.
Comment 11 Volker Merschmann 2014-01-07 20:00:27 UTC
Works again.

For information: There was a hardly visible glitch in https://wiki.documentfoundation.org/Template:Evalp when excluding the documentation part.
Comment 12 grofaty 2014-01-08 06:11:42 UTC
It does not work for me. I cleared browser cache and tried again, but got the same error bellow. I am reopening the bug.

===================
Documentation
This documentation is transcluded from Template:Evalp/doc. (view | edit | history)

{{{{{subst|}}}#expr:{{{1}}}}}

Error handling:

    {{evalp|2*{{evalp|1234567890*1234567890|(inner expression)}}|(outer expression)}} gives 3.0483157500382E+18.

    {{evalp|2*{{evalp|12*1234567890|(inner expression)}}|(outer expression)}} gives 29629629360.

    {{subst:evalp|2*14814814680|(outer expression)|subst=subst:}} gives the wikitext 29629629360.

Debug mode:

    {{evalp|12/1234567890|(inner expression)|d=d}} gives [expression "12/1234567890" (inner expression) gives the result "9.720000088452E-9"].

    {{evalp|2*{{evalp|1234567890*1234567890|(inner expression)|d=d}}|(outer expression)|d=d}} gives [expression "2*[expression "1234567890*1234567890" (inner expression) gives the result "1.5241578750191E+18"]" (outer expression) gives system message "Expression error: Unrecognized punctuation character "["."].
===================
Comment 13 grofaty 2014-01-08 07:11:02 UTC
Now it is working fine... Strange. Maybe some cache somewhere. I am closing the bug now. Thanks for fixing the problem.
Comment 14 Dennis Roczek 2014-01-24 12:56:22 UTC
Just for the reference: while moving documentation stuff to a sub page a new line, it was sadly added a new line which causes a breakage of the "template magic" (as the return parameter was two lines "long").