Bug 73389 - Writer does not show a docx-document with nested table correctly
Summary: Writer does not show a docx-document with nested table correctly
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: Other All
: medium normal
Assignee: Tamás Zolnai
QA Contact:
URL:
Whiteboard: NoRepro:4.2.0.2:OSX target:4.3.0 targ...
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-01-08 10:03 UTC by ulkitz
Modified: 2014-01-22 15:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
docx-Document with nested table (10.81 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-01-08 10:03 UTC, ulkitz
Details
The document shown fine. (9.45 KB, image/png)
2014-01-08 10:05 UTC, ulkitz
Details
The document without the nested table (7.66 KB, image/png)
2014-01-08 10:06 UTC, ulkitz
Details
Bug on master: just the first column is visible, the two others are missing (88.72 KB, image/jpeg)
2014-01-18 20:14 UTC, Tamás Zolnai
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ulkitz 2014-01-08 10:03:07 UTC
Created attachment 91647 [details]
docx-Document with nested table

Open the attached document Ausgangsdokument_TableNested.docx. 
With lo before commit c433a482cf249485e7fa3e71362b107f0eafa705 it is shown fine.
With this commit the nested table is not shown.
Comment 1 ulkitz 2014-01-08 10:05:41 UTC
Created attachment 91649 [details]
The document shown fine.
Comment 2 ulkitz 2014-01-08 10:06:30 UTC
Created attachment 91650 [details]
The document without the nested table
Comment 3 retired 2014-01-18 14:06:51 UTC
WORKSFORME NoRepro:4.2.0.2:OSX

ulkitz: Is this bug still valid / reproducible with the latest pre-release 4.2.0.2: http://www.libreoffice.org/download/pre-releases/

Please also try resetting your user profile and let us know if that helps: https://wiki.documentfoundation.org/UserProfile

Should this be still reproducible for you with the latest LO release please set this bug back to UNCONFIRMED.
Comment 4 Tamás Zolnai 2014-01-18 20:12:11 UTC
I tested it on current master and import still doesn't work. When opening the attached docx file (attached by ulkitz) only the first column of the nested table is visible other two are missing.
I also tested it on LibreOffice-4-0 branch at the point of the commit mentioned by ulkitz and I can reproduce the bug and I can verify that this commit cause the regression.
I'm working on this, so hopefully it will be fixes soon. Until that I reopen it.
Comment 5 Tamás Zolnai 2014-01-18 20:14:32 UTC
Created attachment 92354 [details]
Bug on master: just the first column is visible, the two others are missing
Comment 6 Tamás Zolnai 2014-01-20 12:01:11 UTC
Ok, I found that:
First, commit c433a482cf249485e7fa3e71362b107f0eafa705 made the nested table disappear.
The commit 173d24a7316fccf0e838f71b92c10a772b19298d fixed this regression and nested table imported correctly.
Later, the commit 74c5ed19f430327988194cdcd6bdff09591a93fa caused a new regression: the nested table's imported width is too large and so just the first column is visible others are cut of by the outer table.
So by now the problem is that: the imported nested table's width is incorrect.
Comment 7 Commit Notification 2014-01-20 12:48:26 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d0c383256ef72d5212d8e2db77582d0ebe417209

fdo#73389 Writer does not show a docx-document with nested table correctly



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 8 Commit Notification 2014-01-21 09:02:20 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7e31667cd6d83d76b641462118ae05ec3c19f4b5&h=libreoffice-4-2

fdo#73389 Writer does not show a docx-document with nested table correctly


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 ulkitz 2014-01-21 15:03:10 UTC
I integrated the fix in a 4.1-build and the document is shown correctly.
Thanks for fixing it.
Comment 10 Commit Notification 2014-01-21 15:21:12 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f18d3a8f842713de10ecda161b74ef25e21aa14f&h=libreoffice-4-2-0

fdo#73389 Writer does not show a docx-document with nested table correctly


It will be available already in LibreOffice 4.2.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 Commit Notification 2014-01-22 15:35:20 UTC
Zolnai Tamas committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=7a0eec199901962b03f04371e9474caf8c408c01&h=libreoffice-4-1

fdo#73389 Writer does not show a docx-document with nested table correctly


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.