Bug 73414 - "Increase Font" only increases font to 72pt, also reduces larger fonts down to 72pt
Summary: "Increase Font" only increases font to 72pt, also reduces larger fonts down t...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Maxim Monastirsky
QA Contact:
URL:
Whiteboard: target:4.3.0
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-08 22:17 UTC by tmacalp
Modified: 2014-01-16 20:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description tmacalp 2014-01-08 22:17:01 UTC
Description:
Sometimes, using "Increase Font" can be very helpful for setting the font size to some arbitrary size, especially before wrapping.  Unfortunately, it caps out at the arbitrary size of 72pt.  Even the drop-down menu goes until 96pt.  I don't see a reason for a cap at all, and think it should scale all the way up to the maximum font size, like Draw does.

Worse, if you start with a larger font size and press "Increase Font," it will reduce the font size down to 72pt.

Steps to reproduce:
1. Type some text
2. Highlight text
3. Use "Increase Font" function (ctrl ]) or by enabling the toolbar button (right click->visible buttons->Increase Font.
4. Keep clicking until it maxes out at 72pt
5. Manually type in a font size of 150pt and press enter
6. Use "Increase Font" function (ctrl ]) or by enabling the toolbar button (right click->visible buttons->Increase Font.
7. Notice that the font has been reduced back down to 72pt. 

More:
I guess this is half enhancement request and half trivial bug report.  I'm setting to trivial because it behaves in an obviously wrong manner by reducing larger fonts to 72pt. Obviously, this is not that big of a deal and is quite easy to work around.

I tested this on versions of Libreoffice 4.2.x, 4.1.x, 4.0.x, 3.5.7, but ultimately saw the same behavior in OpenOffice 3.2.1.  Since this predates the LibreOffice project, I'll set the version to 3.3.0.
Comment 1 tommy27 2014-01-09 13:01:29 UTC
(In reply to comment #0)
> ....

issue confirmed with 4.1.4.2 under Win7 64bit --> status NEW
please specify your O/S. 

issue still there in Version: 4.2.0.0.beta2+
Build ID: 039dadf3b48484ba5d1fc71de5561288e6b7c5cb
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2013-12-06_22:54:58

> I tested this on versions of Libreoffice 4.2.x, 4.1.x, 4.0.x, 3.5.7, but
> ultimately saw the same behavior in OpenOffice 3.2.1.  Since this predates
> the LibreOffice project, I'll set the version to 3.3.0.

correct version in this case is "inherited from OOo"

I add Writer expert to CC list
Comment 2 tmacalp 2014-01-09 14:09:49 UTC
> please specify your O/S.

Sorry about that not mentioning OSs.  I tested and can confirm this behavior under the following versions/os's:

LibreOffice 4.0.6.2 under 32bit Fedora 17
LibreOffice 4.1.3.2 under 32bit Fedora 17
LibreOffice 4.2.0.1 under 32bit Fedora 17

LibreOffice 4.1.4.2 under 64bit RHEL6
OpenOffice 3.2.1 under 64bit RHEL6

Libreoffice 4.2.0.1 under 64bit MS Windows Vista

From these tests, it seems likely that it at least affects all MS Windows/Linux versions.


> correct version in this case is "inherited from OOo"

Wow, I never knew there was an "Inherited from OOo" version!  I'll be sure to use that in the future.
Comment 3 Maxim Monastirsky 2014-01-12 17:53:22 UTC
Not really a bug, but a feature request, since the limit is simply hard-coded in the code. What really odd is that the toolbar has the limit of 72pt, but the text sidebar panel has 96pt.
Comment 4 Jorendc 2014-01-14 17:23:35 UTC
This is a dupe of fdo#35862
It's marked as EasyHack over there, a lot of people in CC. 
Just nitpicking, but lets mark this one as duplicate, and Maxim, I'll assign you to that one. In this case we don't have that many bugs referring to each other etc etc.

Sorry for the noise.

Kind regards,
Joren

*** This bug has been marked as a duplicate of bug 35862 ***
Comment 5 Jorendc 2014-01-14 17:28:33 UTC
Aah, maybe I was to fast for this one. Slightly other details (limitation of 72pt, not only the odd behavior when selecting different font sizes). My bad.
Comment 6 Commit Notification 2014-01-16 20:37:50 UTC
Maxim Monastirsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=75043c23c7d08fcc9b22a38fe08014d1381e2f90

fdo#73414 Remove Increase Font limits for Writer



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Commit Notification 2014-01-16 20:40:10 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=a0fdc73984d0eb89eacbcd858db938ad5cf1157d

Related: fdo#73414 use frame::XDispatch::dispatch directly



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.