Bug 73416 - FILESAVE: Dots are added before section titles
Summary: FILESAVE: Dots are added before section titles
Status: RESOLVED DUPLICATE of bug 104805
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86 (IA32) All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: filter:doc
Depends on:
Blocks: DOC
  Show dependency treegraph
 
Reported: 2014-01-08 23:47 UTC by Victor Porton
Modified: 2017-09-04 19:34 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
My Word 97 file which triggers the bug (78.50 KB, application/msword)
2014-01-08 23:47 UTC, Victor Porton
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Victor Porton 2014-01-08 23:47:52 UTC
Created attachment 91719 [details]
My Word 97 file which triggers the bug

Open the attached file. You see superfluous dots before some section numbers:

.7.1 RDF describing a namespace

Every time when this file is saved in Word 97 format, the number of superfluous dots increases:

..7.1 RDF describing a namespace
...7.1 RDF describing a namespace
Operating System: Debian
Version: 4.1.4.2 release
Comment 1 Victor Porton 2014-01-09 03:01:21 UTC
Maybe I was not quite clear: Superfluous dots appear when I save in Word 97 format and then open the .doc file again.
Comment 2 Dominique Boutry 2014-01-14 14:02:17 UTC
Please open "Tools/Outline numbering/numbering", and you will see that you asked for :
- 0 initial dot for your heading 2,
- 1 initial dot for your headings 3 and 4.

And that's what I see in your document. I don't see any bug. Nor did I see the number of dots increasing after an go/return to Word 97.

Feel free to come back if I misunderstood something.
Comment 3 Victor Porton 2014-01-15 02:12:40 UTC
In "Tools/Outline numbering/numbering" I see multiple superfluous dots.
Comment 4 Dominique Boutry 2014-01-15 09:42:20 UTC
Thank you for your answer.

To my knowledge and experience, WORD is known buggy on numbering issues (I stayed with W97 too). Specifically on your document, I'm able to reproduce errors in your "heading 4" : by clicking in the header then :
- Format/Puces et numéros.../Hiérarchisation (sorry for the French, I have only Word in French)
- in the popup, select the lower-righter one, then "Personnaliser..."
- try playing with the "Précédent numéro de numérotation" field : you can get quite strange results.

Morover in your document, some headings have "direct formatting" (some headings 2 for instance : with W98, selecting them then Ctrl-blank followed by Ctrl-Q cleared them), while other got their format from the styles. This make debugging harder.

I suspect a weak area in this domain in your document (years ago, I used to make a go to OOo then return to .DOC to fix such issues in my documents...). So we can't expect a clean doc under LibO if it isn't under Word : LibO is the right place to fix errors.
Comment 5 sophie 2014-03-28 15:29:48 UTC
Well I can confirm that there is an extra dot added each time you save as .doc and reopen the file under LibreOffice. 
To reproduce, open the file, modify it, save it, reopen: there will be 2 dots now before. 
Verified with Version: 4.2.3.2
Build ID: 7c5c769e412afd32da4d946d2cb0c8b0674e95e0 Ubuntu 13.10 - Set as New - Sophie
Comment 6 Joel Madero 2015-05-02 15:41:07 UTC Comment hidden (obsolete)
Comment 7 Buovjaga 2015-06-20 11:20:39 UTC
Confirmed extra dots appearing on save & reload.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 8 QA Administrators 2016-09-20 10:10:06 UTC Comment hidden (obsolete)
Comment 9 Justin L 2017-09-04 19:34:52 UTC
fixed in LO 5.3 for bug 104805  by Miklos Vajna in commit 19d08bbf704332d727cfbe8e101e7d14c62326a0
tdf#104805 DOC import: fix non-0-starting LVL.xst with none-type prev level

*** This bug has been marked as a duplicate of bug 104805 ***