Bug 73463 - Provide "break links" command in customize GUI
Summary: Provide "break links" command in customize GUI
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.1 rc
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Customize-Dialog
  Show dependency treegraph
 
Reported: 2014-01-10 07:24 UTC by narayanaras
Modified: 2018-10-10 13:34 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description narayanaras 2014-01-10 07:24:45 UTC
BACKGROUND INFO:

When we copy-and-paste an internet article into a odt file, we NEVER want to link the images. However, the default behavior of Writer is to link the images, and then the user has to break the links manually, using the Edit>Links... command, and selecting the links and pressing the [Break Links] button.

This approach has four problems:
1. The task is very tedious. 
2. If the user forgets to break the links, the images will not appear when the user is offline.
3. When the user breaks the links, Writer goes back to internet and downloads all images once again! Thus the same images are downloaded TWICE! (double the cost of downloading)
4. With large images over slow networks, Writer takes a very long time to break the links. 

Because of these issues, it is best to embed the image rather than to link them.
I have filed a bug long ago, but nothing has happened so far.
******
Coming to the present request:

If we cannot have embedded images by default, then at least let the user put the "break links" command in an easily accessible place.

But the current design does not provide even this facility: The "break links" command is not listed in keyboard or toolbar customization at all.

To reproduce the problem, follow these steps:

Part-1: Check the Keyboard shortcuts:
1. Right-click on any toolbar and select "Customize toolbar..." option.
2. In the window that pops up, select the "Keyboard" tab.
3. In the bottom part of the window, go to the Functions>Category list and select "Edit" node.
4. Check the "Function" list. There is no "break links" function.

Part-2: Check the Toolbar button section:
5. Now switch to the "Toolbars" tab. 
6. Select any toolbar (say, "Standard"). Press the [Add...] button.
7. In the window that pops up, select the "Edit" Category.
8. Check out the "Commands" list. There is no provision to break links.

Conclusion: We need a direct access to the "break links" command.
Comment 1 sophie 2014-01-10 08:03:38 UTC
Set to New and Enhancement - As a workaround, if I remember well, drag and drop the image does embed it instead of linking it in Writer - Sophie
Comment 2 narayanaras 2014-01-10 09:24:46 UTC
I checked this out, and even drag-n-drop also produces a linked image (not an embedded image).
Comment 3 narayanaras 2014-01-10 09:34:09 UTC
Correction: 

If I drag-n-drop text+image together, the image is linked.
If I drag-n-drop each image only, it is embedded!

I am sure this is not the intended behavior (or a clever hidden trick). 
I will raise a separate bug for that...

Anyway dragging each image separately is a tremendous task; especially if the article has multiple images, or if it is formatted as a table (text in one column, images in the other column).

Rather than dragging each image separately, it would be far easier to break all links.
Comment 4 Jean-Baptiste Faure 2014-01-25 11:50:42 UTC
(In reply to comment #0)
[...]
> Conclusion: We need a direct access to the "break links" command.

There is no command "break links". You only have a dialog in which you need to select the links to be disconnected. You can do multiple selection but you can't, at the moment, break all links in only one click. It could be confusing if you want paste a copy of a webpage in a document in which you want keep the link to another external resource.

I think it may be better to have a new option "paste without links" in paste special.

Best regards. JBF
Comment 5 Muhammet Kara 2018-10-08 12:42:26 UTC
Couldn't reproduce with

Version: 6.2.0.0.alpha0+
Build ID: 6c97feec872e82711f58cce61b7796ed594e552c
CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; 
Locale: en-US (en_US.UTF-8); Calc: threaded


It looks like all images are embedded now.

Could you please check if your problem has been solved?
Comment 6 Xisco Faulí 2018-10-10 13:34:13 UTC
(In reply to Muhammet Kara from comment #5)
> Couldn't reproduce with
> 
> Version: 6.2.0.0.alpha0+
> Build ID: 6c97feec872e82711f58cce61b7796ed594e552c
> CPU threads: 8; OS: Linux 4.18; UI render: default; VCL: gtk3; 
> Locale: en-US (en_US.UTF-8); Calc: threaded
> 
> 
> It looks like all images are embedded now.
> 
> Could you please check if your problem has been solved?

Closing as RESOLVED WORKSFORME for the time being.
@narayanaras put it back to NEW if you still reproduce the issue...