Download it now!
Bug 73498 - CRASH: Fatal Python error: Py_Initialize: can't initialize sys standard streams via Tools Customize Events causes a crash when clicking on the "macro" button
Summary: CRASH: Fatal Python error: Py_Initialize: can't initialize sys standard strea...
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.3.0.0.alpha0+ Master
Hardware: Other Windows (All)
: high normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-11 11:59 UTC by pierre-yves samyn
Modified: 2015-04-09 06:28 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
Screenshot tools customize crash (17.10 KB, image/png)
2014-01-11 11:59 UTC, pierre-yves samyn
Details
Windbg_ToolsCustomizeEventsMacro.txt (16.63 KB, text/plain)
2014-01-11 12:01 UTC, pierre-yves samyn
Details

Note You need to log in before you can comment on or make changes to this bug.
Description pierre-yves samyn 2014-01-11 11:59:27 UTC
Created attachment 91857 [details]
Screenshot tools customize crash

Hello

Platform : windows 7/64 Version: 4.3.0.0.alpha0+
Build ID: ae8e579515fff84cbef1ccc2da78fa769fb079ec
TinderBox: Win-x86@39, Branch:master, Time: 2014-01-10_11:16:31

Steps to reproduce:

1. Start LibreOffice
2. Tools> Customize> Events tab 
3. Click the Macro button

the system shows "LibreOfficeDev has stopped working"
("LibreOfficeDev a cessé de fonctionner" in french)
See attached screenshot

Windbg !analyze -v produces nothing but two lines before there is an error:
Fatal Python error: Py_Initialize: can't initialize sys standard streams

See attached Windbg_ToolsCustomizeEventsMacro.txt

Regards
Pierre-Yves
Comment 1 pierre-yves samyn 2014-01-11 12:01:00 UTC
Created attachment 91858 [details]
Windbg_ToolsCustomizeEventsMacro.txt
Comment 2 Julien Nabet 2014-01-12 08:35:49 UTC
I put it at New since there's a bt.

Michael: could it be related to Python 3.3.3 upgrade?
Comment 3 Julien Nabet 2015-04-07 21:15:06 UTC
On pc Debian x86-64 with master sources updated today, I don't reproduce this.

On Win8 with no JRE+LO 4.3.6, I don't reproduce this. I must recognize I thought it would hang after the warning about the fact there was no JRE but finally, LO opened Macro selection dialog.

Pierre-Yves: Could you give a new try with a recent LO version (4.3.6 or 4.4.2) + a brand new profile if needed?
Comment 4 pierre-yves samyn 2015-04-08 06:57:40 UTC
Hi Julien 

Thank's for testing

I can not reproduce the bug on windows 7 pro & Version: 4.4.1.1
Build ID: b5ac74bf8683a92078a2bc8aff97d4b436af63cb
Locale : fr_FR

I will try also with 4.4.2

Regards
Pierre-Yves
Comment 5 Julien Nabet 2015-04-08 21:11:32 UTC
I put it as WFM but don't hesitate to reopen this tracker if you can reproduce it on 4.4.2.
In this case it would be a regression but with just a range of 1 minor version (kindda of pre bibisect! :-))
Comment 6 pierre-yves samyn 2015-04-09 06:28:08 UTC
(In reply to Julien Nabet from comment #5)
> I put it as WFM but don't hesitate to reopen this tracker if you can
> reproduce it on 4.4.2.
> In this case it would be a regression but with just a range of 1 minor
> version (kindda of pre bibisect! :-))


No crash with Version: 4.4.2.2
Build ID: c4c7d32d0d49397cad38d62472b0bc8acff48dd6
Locale: fr_FR

WFM too :)

Regards
Pierre-Yves