Bug 73674 - FORMATTING: numbering menu issues
Summary: FORMATTING: numbering menu issues
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
: 75832 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-15 20:23 UTC by Marcin
Modified: 2015-05-02 16:29 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Screenshot (67.22 KB, image/jpeg)
2014-01-15 20:23 UTC, Marcin
Details
screenshot of "Outline" tab (61.74 KB, image/png)
2014-01-16 10:48 UTC, Dominique Boutry
Details
Menu after reinstalling (79.28 KB, image/jpeg)
2014-01-16 11:59 UTC, Marcin
Details
v.4.2.0.2 - Screenshot (118.66 KB, image/jpeg)
2014-01-16 12:33 UTC, Marcin
Details
Text (35.44 KB, application/vnd.oasis.opendocument.text)
2014-01-22 22:39 UTC, Marcin
Details
Text document (35.44 KB, application/vnd.oasis.opendocument.text)
2014-01-22 22:44 UTC, Marcin
Details
text document (9.46 KB, application/vnd.oasis.opendocument.text)
2014-01-24 20:39 UTC, Marcin
Details
Screenshot (103.76 KB, image/jpeg)
2014-01-24 20:45 UTC, Marcin
Details
Screenshot of the dialog once numbering is applied to the document (41.95 KB, image/png)
2014-03-19 14:26 UTC, sophie
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Marcin 2014-01-15 20:23:10 UTC
Created attachment 92179 [details]
Screenshot

Problem description: 

Few versions ago (not sure exactly which one) there were an option to punctuate like this:
1. *******
 1.1. ******
 1.2. ******
  1.2.1. *******

Instead of this, now it is only possible to punctuate like this:

1. *******
 1. ******
  1. ******
   1.1.1. *******

Steps to reproduce:
1. Open Punctuation Menu (which is showed in attachment)

              
Operating System: Windows 7
Version: 4.1.4.2 release
Comment 1 Dominique Boutry 2014-01-16 10:48:10 UTC
Created attachment 92218 [details]
screenshot of "Outline" tab

In a freshly downloaded LibO 4.2.0.2 (Win7), the command "Format/Bullets and numbering" shows as in attached screenshot. It's OK.
Comment 2 Marcin 2014-01-16 11:58:09 UTC
After reinstalling it looks a little bit better, but still doesn't work properly.

More details in Screenshot-2.
Comment 3 Marcin 2014-01-16 11:59:27 UTC
Created attachment 92221 [details]
Menu after reinstalling

Menu after reinstalling
Comment 4 Marcin 2014-01-16 12:33:38 UTC
Created attachment 92222 [details]
v.4.2.0.2 - Screenshot

In version 4.2.0.2 Menu looks properly, but it still doesn't work in document.

More details in screenshot.

Sorry for multiple posts.
Comment 5 Dominique Boutry 2014-01-17 11:01:06 UTC
I admit being puzzled by the outline/list layout. I try to analyse deeper then I'll come back to you.

Regards
Comment 6 Jean-Baptiste Faure 2014-01-19 19:40:12 UTC
Please, could you attach your test document?

Best regards. JBF
Comment 7 Marcin 2014-01-22 18:39:44 UTC
(In reply to comment #6)
> Please, could you attach your test document?
> 
> Best regards. JBF


Here it is: http://www75.zippyshare.com/v/97908268/file.html
Comment 8 Jean-Baptiste Faure 2014-01-22 19:13:31 UTC
(In reply to comment #7)
> (In reply to comment #6)
> > Please, could you attach your test document?
> > 
> > Best regards. JBF
> 
> 
> Here it is: http://www75.zippyshare.com/v/97908268/file.html

Don't work, please attach it here.

Best regards. JBF
Comment 9 Marcin 2014-01-22 22:39:05 UTC
Created attachment 92623 [details]
Text
Comment 10 Marcin 2014-01-22 22:44:40 UTC
Created attachment 92624 [details]
Text document
Comment 11 Marcin 2014-01-22 22:48:03 UTC
I had some issues with adding this attachment, but if you add extension .odt it should work just fine.

Sorry for the caused problems.
Comment 12 Jean-Baptiste Faure 2014-01-24 05:37:54 UTC
Your test document is strangely designed. You can do what you want by using the Option tab in the numbering dialog, you need to choose the number of sublevels to be shown.

If my understanding of your problem is wrong, please describe step by step (mouse click by mouse click) how to reproduce the problem.

Best regards. JBF
Comment 13 Marcin 2014-01-24 20:39:14 UTC
Created attachment 92738 [details]
text document

The problem is that it isn't working even with the simplest documents. Example is in attachment. I've just opened LibreOffice->f12->outline->(4th at the top option of formating.
Comment 14 Marcin 2014-01-24 20:45:13 UTC
Created attachment 92740 [details]
Screenshot

I don't know if it can help you, but it is the way that Libreoffice looks like at my computer.
Comment 15 Dominique Boutry 2014-02-07 10:52:07 UTC
I can't manage to exhibit a "mouse click by mouse click" on how to reproduce the problem, because the "bullet&numbering/Outline tab" is incoherent:
- once the dialog box is opened, this tab is immutable, it acts as a palet; however, it isn't populated the same way at each opening of the dialog box; it doesn't seem to depend on the selection at this time, I can't figure what it depends on ; it looks ERRATIC,
- more severe, as a palet (like "Bullets", "Numbering type" and "Image" tabs) it is supposed to populate the ten positions manageable in the "Position" and "Options" tabs (explicitely for the five first; the five last being logically the fifth whis growing indentation); however it is not always the case. Here too I can't figure what it depends on ; it looks ERRATIC.

Once the behaviour of this tab will be fixed, I propose you to have a glance at the monograph I wrote on this subject, at "http://www.odfauthors.org/libreoffice/english/how-tos-tutorials/monograph-1-en-lists-and-titles/view".

To make a wall brilliant, it is not sufficient to repaint it again and again, one sometimes need to scour it. I'm a little bit angry, it will blow over...
Comment 16 sophie 2014-03-19 14:25:25 UTC
Hi, I can confirm that the numbering doesn't reflect the choice in the dialog box, the numbering shows :
1. First level
  1. Sublevel
when it should be
1. First level
  1.1 Sublevel
Using version 4.1.5.3 (Debian) and 4.2.3.1 (Ubuntu). 
Also the dialog changes once you've selected a numbering, to reproduce:
- open a new Writer document
- do not add anything and select Format > Bullet and numbering > Outline have a look at the last view in the first row (it's identical to Marcin's joined screenshot dialog after reinstalling)
- click ok, add two or three numbered lines
- click on the bullet properties icon, you'll see that the display is now different (I'll join a screenshot).
Set as new, change OS, Sophie
Comment 17 sophie 2014-03-19 14:26:56 UTC
Created attachment 96049 [details]
Screenshot of the dialog once numbering is applied to the document
Comment 18 sophie 2014-03-19 14:28:43 UTC
*** Bug 75832 has been marked as a duplicate of this bug. ***
Comment 19 Gordo 2015-05-02 16:29:39 UTC
Could not reproduce.

Bullets and Numbering -> Outline tab
Top row, last:
1.
 1.
  1.
results in
1.
 1.
2.
 1.

Bottom row, second from right
1
 1.1
  1.1.1
results in
1.
 1.1
2.
 2.1
  2.1.1

Version: 4.4.3.2
Build ID: 88805f81e9fe61362df02b9941de8e38a9b5fd16

Also could not reproduce in 4.2.8.2.

Changed to RESOLVED WORKSFORME.