Download it now!
Bug 73709 - URL hyperlinks damaged when clicked in rapid sequence in a table
Summary: URL hyperlinks damaged when clicked in rapid sequence in a table
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.1.2 release
Hardware: x86-64 (AMD64) Mac OS X (All)
: high major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-16 17:58 UTC by Joop Lanting
Modified: 2016-08-03 15:05 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments
Writer document (18.51 KB, application/vnd.oasis.opendocument.text)
2014-01-17 13:52 UTC, Joop Lanting
Details
Screenshot showing the damage done. (35.09 KB, image/png)
2014-05-11 11:04 UTC, Joop Lanting
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Joop Lanting 2014-01-16 17:58:49 UTC
Hello.

Have: several URL's in a Table, one per cel.
Note:
this does NOT happen on MSWindowsXP but on OSX Mavericks (same 4.1.4.2 release)
::
Clicking one URL starts the browser.
Clicking a second URL (directly after the first one) clears the first URL
and moves it OVER the second URL (still starts a second tab in the browser).
Have to close Writer, discarding the damaged file.
;JOOP!
Comment 1 retired 2014-01-16 18:56:01 UTC
Can you please provide a test document so this can be tested against and subsequently be confirmed. If your document contains sensitive data, please clear that or replace it with random information.

Setting to NEEDINFO until more detail is provided.

After providing the requested info, please reset this bug to UNCONFIRMED. Thanks :)
Comment 2 Joop Lanting 2014-01-17 13:52:42 UTC
Created attachment 92286 [details]
Writer document

Hello,
attached is the first document in which I encountered the problem.
I stripped it as far as I could.
The problem shows when you click somewhere in the document to bring it to front,
then click all the URL's up or down in sequence.
The standard web browser will show up (Safari) and all URL's will give rise
to a tabbed web page.
When you're finished you'll see that one or more URL's have vanished or even moved.
The problem does NOT show when you click in the empty space of the document between any 2 URL clicks.
The problem does NOT happen on MSWindowsXP.

Further info: iMAC-27 (2013)/ 32Gb memory, Mavericks,
APPLE JAVA 1.6.0-65 (latest) and ORACLE JAVA 7u51.
LibO 4.1.4.2 UK version.
;JOOP!
Comment 3 Joop Lanting 2014-02-28 14:08:28 UTC
I installed 4.1.5.3 (LibreOffice_4.1.5_MacOS_x86.dmg)
Same problem.
;JOOP!
Comment 4 Joop Lanting 2014-02-28 14:29:57 UTC
I installed 4.2.0.1 (LibreOffice_4.2.0_MacOS_x86-64.dmg)
Same story.

Just got 4.2.1.1 (LibreOffice_4.2.1_MacOS_x86-64.dmg)
Again ....
;JOOP!
Comment 5 Joop Lanting 2014-03-10 11:05:36 UTC
Foss, do you need more info?
;JOOP!
Comment 6 Joop Lanting 2014-03-14 14:43:46 UTC
At first sight, it looks like this bug has been cured in 4.2.2
Unfortunately I can only test it on WindowsXP as the language pack
for 4.2.2 OSX is not visible on the download site, so I have to delay upgrade.
;JOOP!
Comment 7 Joop Lanting 2014-03-27 13:59:56 UTC
Well, on second sight the bug is now:
clicking some URL's in the same document intermittently works as cut and paste
spoiling your whole document.
This is true for 4.2.2 on XP, W7 and OSX Mavericks.
Anyone for tennis?
;JOOP!
Comment 8 Joop Lanting 2014-04-14 08:17:55 UTC
And yes, 4.2.3 has the same bug.
Could you please confirm?
;JOOP!
Comment 9 Jean-Baptiste Faure 2014-05-01 15:07:58 UTC
Not reproducible for me with LibreOffice 4.2.5.0.0+ under Linux / Ubuntu 14.04 x86-64

Please reinitialize your LibreOffice user profile and try again.
https://wiki.documentfoundation.org/Faq/General/110

Best regards. JBF
Comment 10 Joop Lanting 2014-05-01 16:33:03 UTC
Thanks JB, but what happened to Foss? Did you use the document I gave him/her?
Btw.: could my user profile go corrupt on 4 different systems at the same time?
(WindowsXP, Windows7 laptop, iMac, MacBook).

I'll come back to you.
;JOOP!
Comment 11 Joop Lanting 2014-05-01 17:09:53 UTC
You are working with 4.2.5??? I can't get any newer version than 4.2.3

Well I did as you instructed on my main system, an iMac/Mavericks with 4.2.3.
To no use: a brand new profile has the same problem.

I'll specify the problem again:
I enabled direct URL clicking in Options/Security/Options
because I have some documents with lots of URL's to websites etc.
When I click a few URL's in sequence, while the browser collects those links
suddenly it appears that LO MOVES these URL's from where I clicked them to
the next place where I click.
NB>: all these URL's appear in a table.
So may be the bug is related:  URL-Table-clicks.

Every time I have to reopen my document in order not to lose info.
This bug has appeared to me for all releases from 4.1.4
Please remember that 4.2.3 on Windows had serious problems with table lines.
Thanks for reading.
;JOOP!
Comment 12 Jean-Baptiste Faure 2014-05-01 17:47:42 UTC
Not reproducible for me with LibO 4.1.6 (generic Linux version) two days ago.
Additionally, you can try the first RC for version 4.2.4 : https://www.libreoffice.org/download/pre-releases/

Best regards. JBF
Comment 13 Joop Lanting 2014-05-01 19:19:53 UTC
For your information: I found that over time there were differences
between LO releases for different platforms.
Example: Bug 77579 appeared in 4.2.3 for MSWindows XP and 7,
but NOT in 4.2.3 for OSX Mavericks.

Most likely that bug 73709 does not appear in LINUX releases.
This might seem strange, but we know that the underlying software
is different for different OS's.
Unfortunately I don't have any UNIX or LINUX system left
so I can't check anything.
As I'm retired I don't have a company behind me too.
Could you pass this bug to someone with OSX?
Thanks.
;JOOP!
Comment 14 Joop Lanting 2014-05-05 09:34:25 UTC
JBF,
I installed the 4.2.4RC1 on Mavericks (64 bits) and on Windows XP (32).
The XP version seems to have been cured from the problem,
the Mavericks version looks even WORSE: it damages my documents directly.
As iMac is my future direction, you'll understand my priorities.
Please help.
;JOOP!
Comment 15 Joop Lanting 2014-05-05 09:36:07 UTC
Some more info: I don't have to click URL's in sequence now, I just have
to click an URL and then another cell, and LO performs a cut+paste automatically.
;JOOP!
Comment 16 Joop Lanting 2014-05-09 09:01:21 UTC
Hello,
I installed the now released 4.2.4, both on OSX and XP.
XP works fine.
On OSX the problem is worse than ever.
How can this bug exist only on OSX when it does not exist on XP
and (reportedly) not on LINUX.

In general, why installs LO quite different on OSX: there is no choice
between express install and custom install.

From the above, one might conclude that the OSX version and the rest are
two different programs. Is that true?
;JOOP!
Comment 17 Joop Lanting 2014-05-10 16:36:10 UTC
Hi,
I just verified that the 32-bit version of 4.2.4 has the same bug as the 64-bit version.
So, the matter is a bug in the OSX release; is that a Cocoa problem?

Please respond.
;JOOP!
Comment 18 retired 2014-05-11 10:02:17 UTC
I don't understand the bug description. You write "clicking one URL starts the browser". Clicking a URL in LO does nothing except move your cursor to that position.

The browser will only open if you cmd + left click a URL.

I tried clicking furiously at the URL in your test file and was unable to reproduce any problem with that. Also tried clicking even more furiously cmd + left click and all URL opened in my browser as expected with LO 4.2.4.2.

Please either provide very detailed repro steps or a screencast incl. a description of what keys / mouse buttons exactly you press in which order, so we can try reproducing the issue.

So far I was unable to do that. After providing that info, please set the bug back to UNCONFIRMED.
Comment 19 Joop Lanting 2014-05-11 11:04:18 UTC
Created attachment 98839 [details]
Screenshot showing the damage done.

Hi,
>>> Clicking a URL in LO does nothing except move your cursor to that position.
Obviously you did not unmark the checkbox:

Preferences > Security > Options > [ ] Ctrl-click required to follow hyperlinks

But even then the bug shows (ONLY on Mavericks!), refer to the new attachment:
clicking the hyperlinks in sequence moved some to the lower cells.
To avoid misunderstandings, I run OSX 10.9.2 on an iMac with 32Gb memory
and all thinkable updates installed.

Again, 4.2.4 on both WindowsXP and Windows7 don't show this bug (any more).
;JOOP!
Comment 20 Joop Lanting 2014-05-11 11:04:58 UTC
Changed status.
;JOOP!
Comment 21 Joop Lanting 2014-05-28 13:07:44 UTC
Hello,
I just installed (and uninstalled) the "LibreOfficeDev_4.3.0.0.beta1_MacOS_x86-64.dmg"
only to find out that the bug is still there.

While this bug is only present on OSX (Mavericks, fully updated),
I found a (kludgy) workaround:

Every time you click an URL (to start a new web page),
first click the title bar of the Writer window, before you click another URL.
Smells of MSWindow solutions .....

Any reaction?
;JOOP!
Comment 22 Joop Lanting 2014-08-01 10:35:53 UTC
I just installed the released 4.3.0.4 LibO for OSX.
The problem still exists.
I wonder why, after half a year, any reaction came from people who did not
test the bug on the proper platform.
Is there some resistance within The Document Foundation against Apple?
I can't believe that.
;JOOP!
Comment 23 sophie 2014-08-05 14:29:56 UTC
Hi Joop, it's not a question of resistance but whether volunteers working on QA own a MAC, very few of us in fact (and I don't). Sophie
Comment 24 Joop Lanting 2014-08-05 18:17:18 UTC
Well, as you release on Mac you can expect Mac users to install it, don't you.
All I ask is that someone takes the time to confirm the problem.
I'll be patient till it has been fixed.
;JOOP!
Comment 25 sophie 2014-08-05 18:27:39 UTC
Hi, thanks for your patience, may be you can try to bring Mac users around you to test and confirm the issue? we are all volunteers here so they are very welcomed :) Sophie
Comment 26 Joop Lanting 2014-08-05 18:56:59 UTC
I'd love to do that, but I'm nearly 67 and I don't know any Mac users who can
program. All friends that remained are some old co-workers who 'must' be devoted
to MicroSoft to keep their job.
Instead I tell all my relations what a wonderful product LibO is.
Of course I am silent about bugs.
;JOOP!
Comment 27 Joop Lanting 2014-08-09 15:57:40 UTC
I noticed something very strange on OSX since 4.3.0:
when I click a URL in a table most of the time the cursor changes
from the "North West" arrow to a small vertical arrow.
I never saw that happen on Windows.
Is that cursor a standard cursor or is it embedded into Eclipse?
;JOOP!
Comment 28 Joop Lanting 2014-08-23 16:07:36 UTC
Does 'foss' still work for you and does he have some Mac somewhere?
;JOOP!
Comment 29 Jean-Baptiste Faure 2014-08-23 17:42:18 UTC
Please do not set status to NEW for your own bug report. Each bug report must be independently confirmed.

Best regards. JBF
Comment 30 Joop Lanting 2014-08-23 19:22:22 UTC
If you have the time to correct me, you will have time to get this bug confirmed as well.
Why do you release OSX versions when no one can confirm bugs on OSX.
I do my best to promote LibO among my relations, but this is contra productive.
;JOOP!
Comment 31 Joop Lanting 2014-09-09 05:21:02 UTC
4.3.1 .... and the bug is still there, ruining my documents.
;JOOP!
Comment 32 Jean-Baptiste Faure 2014-09-12 04:39:18 UTC
Please, do not change the version number, it shows the first version in which the bug has been seen, not the most recent.

Best regards. JBF
Comment 33 Joop Lanting 2014-09-12 12:00:01 UTC
Thanks for your information.
I dug in my archive and could go back to 4.0.1.2
And the bug is already there.
I wish I could test some 3.* releases as well.
;JOOP!
Comment 34 Joop Lanting 2014-09-25 16:18:20 UTC
............ and 4.3.2.2 still has the bug and destroys my documents.
Thanks.
;JOOP!
Comment 35 Alex Thurgood 2014-10-06 15:28:17 UTC
(In reply to Joop Lanting from comment #27)
> I noticed something very strange on OSX since 4.3.0:
> when I click a URL in a table most of the time the cursor changes
> from the "North West" arrow to a small vertical arrow.
> I never saw that happen on Windows.
> Is that cursor a standard cursor or is it embedded into Eclipse?


No, it is the column selection cursor. I too have noticed this displaying at unpredictable moments, but usually it just freezes LO for me momentarily, and the reverts to correct cursor.
Comment 36 Alex Thurgood 2014-10-06 15:42:03 UTC
Confirming, I can reproduce the problem.

For some reason, LO interprets rapid successive clicks as a Move instruction (equivalent to DnD) and moves the content to the next cell clicked. This is possibly indicative of poor event timimg between releasing the fire URL open event and freeing up the cursor, which ends up in LO thinking that a double-click and move object event is fired (wrongly, as it turns out).

@Joop : just click more slowly on the links, whilst waiting to see if this can be fixed, it is definitely a poor performance problem.
Comment 37 Alex Thurgood 2014-10-06 15:42:32 UTC
I iested on Version: 4.4.0.0.alpha0+
Build ID: 9bcd96a36e323a1c70eeefa81f2c8ea595f59444
Comment 38 Alex Thurgood 2014-10-06 15:44:09 UTC
I would be inclined to change the title on this
Comment 39 Alex Thurgood 2014-10-06 15:47:36 UTC
Also reproducible in Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 40 Alex Thurgood 2014-10-06 15:50:23 UTC
Hmm, it requires the user to be particularly slow when clicking the links to avoid triggering the bug
Comment 41 Alex Thurgood 2014-10-06 15:52:34 UTC
I take that last comment back, it just happens at random (or seemingly) no matter how long one waits - problem with interpreting focus of mouse pointer and associated event action that needs to be fired, this is quite bad.
Comment 42 Joop Lanting 2014-10-06 16:04:09 UTC
To Alex:
1) thanks, finally who confirmed the bug.
2) NO the column selector arrow points down, this one points UP.
3) you found out: slow clicking is not a solution; the only (temporary) solution
is to click the top bar every time (crazy solution).
4) even worse: it even happens without a TABLE around.
I wish you luck finding out why this does NOT happen on WindowsXP and Windows7.
;JOOP!
Comment 43 Joop Lanting 2014-10-29 06:16:56 UTC
New fact: on my iMac (2013, 32Gb),
I noticed "dead" start times for documents of 2-4 pages:

for normal documents: 2 seconds

for documents with URL's in a table:  11 seconds on average!

Is that an indication of a faulty release?

;JOOP!
Comment 44 Joop Lanting 2014-10-31 07:08:34 UTC
Just installed 4.3.3 : same old song.

Why does LibO let Mac users down?
Why is the status of this bug after 10 months still NEW ?
;JOOP!
Comment 45 Joop Lanting 2014-11-16 21:46:33 UTC
4.3.4 ....... stil that bug.
;JOOP!
Comment 46 Joop Lanting 2014-12-28 15:34:22 UTC
Happy new year.
My wishes? 
Please investigate that (confirmed!) bug, which still exists in 4.3.5.2
;JOOP!
Comment 47 Joop Lanting 2015-01-31 11:52:36 UTC
Let's start all over again.

It's 2015 and I just installed 4.4.0.3 on Yosemite 10.10.2

When an Internet URL is clicked in a .odt document, the next click anywhere
in that document moves the URL entry to the position of the new click
damaging the document.
This happens only on OSX (any version), never on any MSWindows version.
This bug has been confirmed already contrary to the status of this bug.

Well ....

;JOOP!
Comment 48 Alex Thurgood 2015-01-31 14:33:39 UTC
@Joop : thanks for testing, but no developer has found the time / inclination to look at this bug yet, so rather unsurprisingly, it is still present.

Without more OSX developers in the project, OSX specific bugs are unlikely to get fixed any time soon, other than by accident or if they happen to affect other OSes too.
Comment 49 Joop Lanting 2015-01-31 18:24:35 UTC
Alex, I can live with that, but then, please, change the status to confirmed,
because the bug looks rather raw to someone who finds time in the future.
I would like to help myself, but I'm too old and it's too long ago.
;JOOP!
Comment 50 Alex Thurgood 2015-01-31 18:32:25 UTC
(In reply to Joop Lanting from comment #49)
> Alex, I can live with that, but then, please, change the status to confirmed,
> because the bug looks rather raw to someone who finds time in the future.
> I would like to help myself, but I'm too old and it's too long ago.
> ;JOOP!

The NEW status does exactly that. The bug has been reported NEW since I confirmed it in comment 36
Comment 51 Joop Lanting 2015-04-06 20:55:38 UTC
And in 4.4.2.2 too
;JOOP!
Comment 52 Joop Lanting 2015-05-12 14:21:32 UTC
I just downloaded and installed 4.4.3 both on OSX 10.10.3 and WindowsXP.
The table problem has now extended and spread to Windows:

several cells can no longer be copied within a table,
that is: even a single cell selected and marked for COPY
creates several vertical cells when pasted to another single cell.
That is about the simplest example.

What is wrong with tables in LibreOffice?

;JOOP!
Comment 53 Joop Lanting 2015-08-29 14:27:11 UTC
Just installed 5.0.1.2 on 10.10.5 and I can reassure you that the problem is still there.
In case you worried about it.
;JOOP!
Comment 54 Joop Lanting 2016-02-23 10:09:05 UTC
And in 2016, with release 5.1.0.3 the problem is STILL there.
;JOOP!
Comment 55 Joop Lanting 2016-03-13 16:04:16 UTC
5.1.1.3 : still there.
;JOOP!
Comment 56 Joop Lanting 2016-06-23 16:38:33 UTC
5.1.4, 2.5 years later and still the same old song .....
;JOOP!
Comment 57 Joop Lanting 2016-08-03 12:29:56 UTC
5.2.0 and the issue seems to be solved. 
If so, then you may change the status to SOLVED.

If not, then to "MAY COME BACK ONE DAY".
;JOOP!
Comment 58 Alex Thurgood 2016-08-03 15:05:54 UTC
Per comment 57, wfm