Download it now!
Bug 73713 - FILESAVE: when saving as .XLS cell formatting of blank cells is not remembered
Summary: FILESAVE: when saving as .XLS cell formatting of blank cells is not remembered
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: x86 (IA32) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:xls
Depends on:
Blocks: Number-Format XLS
  Show dependency treegraph
 
Reported: 2014-01-16 20:27 UTC by lenardd
Modified: 2019-02-05 14:10 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Test file to duplicate issue. (7.00 KB, application/vnd.ms-excel)
2014-01-19 05:08 UTC, lenardd
Details

Note You need to log in before you can comment on or make changes to this bug.
Description lenardd 2014-01-16 20:27:04 UTC
To duplicate the problem, set a blank cell with a custom date format. (I used D-MMM-YYYY) Save as XLS. Close out of the application.  Then load the test file again and you will see that the cell formatting is reset back to its default.

I also tried setting the blank cell to an existing currency format and it has the same problem.

No problems working with native file format (ODS).
Comment 1 lenardd 2014-01-17 00:52:10 UTC
I should also note that on the latest build of Apache's Openoffice (4.01), it works fine.
Comment 2 Ken Biondi 2014-01-17 04:13:07 UTC
I followed the steps to recreate this bug, but I could not recreate it.  I'm changing the status to WORKSFORME.  If this is still a bug for you, please change the status back to UNCONFIRMED and provide more details if possible.
Comment 3 Ken Biondi 2014-01-17 04:14:36 UTC
Forgot to mention that I tested using:
WIN 8
AMD64
Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72
Comment 4 lenardd 2014-01-17 09:32:06 UTC
Ken,

I don't what else to say, but it doesn't work for me. I'm not sure what else to add except that I'm on Windows 7.

Would attaching a short video be of any help?
Comment 5 Ken Biondi 2014-01-18 20:46:38 UTC
Attaching a sample file might help.
(In reply to comment #4)
> Ken,
> 
> I don't what else to say, but it doesn't work for me. I'm not sure what else
> to add except that I'm on Windows 7.
> 
> Would attaching a short video be of any help?
Comment 6 lenardd 2014-01-19 05:08:46 UTC
Created attachment 92374 [details]
Test file to duplicate issue.
Comment 7 lenardd 2014-01-19 05:16:11 UTC
(In reply to comment #6)
> Created attachment 92374 [details]
> Test file to duplicate issue.

Ken,

Open the file and under the "Amount" column set the cell formatting to currency and save the file. Then exit the application and load the file again. You should see the formatting was reset back to default.

Another issue that I noticed is in the row height. Note how in the first row, its height cuts off the top of the text.  If you open the same file in Apache's Open Office, the problem does not happen.  

--Lenard
Comment 8 lenardd 2014-01-19 05:16:11 UTC Comment hidden (obsolete)
Comment 9 Ken Biondi 2014-01-19 18:23:05 UTC
I tried again using your test file, but cannot recreate the formatting bug.  Since I'm testing on WIN 8, this may be a bug specific to WIN 7.

However, I was able to recreate the row height bug.  You might consider creating a separate bug for this issue.
Comment 10 Joel Madero 2014-04-26 05:55:20 UTC
Please try with a fresh profile - it doesn't make sense that it wouldn't work with W7 but would work with W8. 

https://wiki.documentfoundation.org/UserProfile

Also please try with current release
http://www.libreoffice.org/download/libreoffice-fresh/
Comment 11 tommy27 2014-07-01 04:44:07 UTC
(In reply to comment #8)
> (In reply to comment #6)
> > Created attachment 92374 [details]
> > Test file to duplicate issue.
> 
> Ken,
> 
> Open the file and under the "Amount" column set the cell formatting to
> currency and save the file. Then exit the application and load the file
> again. You should see the formatting was reset back to default.
> 
> ....


tested under Win7x64 using LibO 4.2.4.2 and 4.4.0.0.alpha0+
Build ID: 95272e7e5b7e38753ab07dbd6503b7cfa2974842
TinderBox: Win-x86@42, Branch:master, Time: 2014-06-26_23:01:43

I can reproduce issue only if I change the formatting into an blank cell.

I mean, right click on empty cell, format cell, select "currency", save and reopen and I see the format is set back as "number".

if instead I do a "format cell" in a cell with numbers, the format currency is kept after save and reload.

if you save as .ODS there's no problem... blank cells formats are remembered.

set status NEW. edited summary notes. added Calc expert to CC list.
Comment 12 tommy27 2014-07-01 05:09:55 UTC
(In reply to comment #9)
> ...
> However, I was able to recreate the row height bug.  You might consider
> creating a separate bug for this issue.

I did it. See Bug 80744
Comment 13 QA Administrators 2016-02-21 08:36:15 UTC Comment hidden (obsolete)
Comment 14 QA Administrators 2017-03-06 15:27:35 UTC Comment hidden (obsolete)
Comment 15 Roman Kuznetsov 2019-02-05 14:09:59 UTC
don't repro in

Version: 6.3.0.0.alpha0+
Build ID: ed707a4806a489467c6d9be7d1b787dab94b5f78
CPU threads: 4; OS: Windows 6.1; UI render: default; VCL: win; 
Locale: ru-RU (ru_RU); UI-Language: en-US
Calc: threaded

Status->WFM