Download it now!
Bug 73721 - clicking Advanced Configuration button freezes and crashes LibO
Summary: clicking Advanced Configuration button freezes and crashes LibO
Status: RESOLVED DUPLICATE of bug 70465
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-17 01:03 UTC by Carlo Strata
Modified: 2014-04-18 00:16 UTC (History)
5 users (show)

See Also:
Crash report or crash signature:


Attachments
Windows with Involved button (21.46 KB, image/png)
2014-01-17 13:11 UTC, Carlo Strata
Details
Windows with Involved button, first click effect (20.90 KB, image/png)
2014-01-17 13:16 UTC, Carlo Strata
Details
Advanced Option Window. The second final fatal click effect. (71.28 KB, image/png)
2014-01-17 13:30 UTC, Carlo Strata
Details
4.1.4.2 italian gui options (17.95 KB, image/png)
2014-01-19 17:47 UTC, tommy27
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Carlo Strata 2014-01-17 01:03:04 UTC
Selecting Tools menu -> Options -> LibreOffice -> Advanced -> Advanced Configuration button freezes (after a second click anywere in the window) and then crashes LibreOffice.

The tested Environments with the above behaviour are the following:
- Microsoft Windows 8.1, AMD64, updated, LibreOffice, win32, 4.2.0.1 (RC1) and then win32, 4.2.0.2 (RC2);
- Microsoft Windows 7, AMD64, Ultimate, SP1, updated, LibreOffice, win32, 4.2.0.2 (RC2).

In both cases java 1.7.0 update 45 (win32 and win64/AMD64) were installed and the first one (win32) well configured in LibreOffice Advanced key (and already restarted to consolidate the configuration).

Have a nice weekend,

Carlo
Comment 1 Ken Biondi 2014-01-17 03:20:29 UTC
Hello Carlo,

Did you mean Selecting Tools menu -> Options -> LibreOffice -> Advanced -> "Expert" Configuration?

Anyway, I tried to recreate this bug but was unsuccessful.  I changed the status to WORKSFORME. If this is still a bug for you please change the status back to unconfirmed and provide more details if possible.

I tested using:
WIN 8.0
AMD64
Version: 4.2.0.1
Build ID: 7bf567613a536ded11709b952950c9e8f7181a4a
Comment 2 Cor Nouws 2014-01-17 08:20:10 UTC
also fine in 4.2.0.2 on Ubuntu.
Comment 3 Carlo Strata 2014-01-17 13:11:08 UTC
Created attachment 92283 [details]
Windows with Involved button
Comment 4 Carlo Strata 2014-01-17 13:14:47 UTC
Comment on attachment 92283 [details]
Windows with Involved button

This is the italian gui (but isn't so important because you could understand where it is) involved button.

Now I will post:
- the first click effect;
- and the second final fatal click effect.

Than I hope to be clearer than ever! ;-)
Comment 5 Carlo Strata 2014-01-17 13:16:42 UTC
Created attachment 92284 [details]
Windows with Involved button, first click effect

The effect was only the usual dotted selection sign on button.
Comment 6 Carlo Strata 2014-01-17 13:30:29 UTC
Created attachment 92285 [details]
Advanced Option Window. The second final fatal click effect.

To get this one after the first click, you could either:
- click once again not only over the involved button, but also wherever in the screen (!);
- press any key on the keyboard (shift keys or mod keys included!).
Comment 7 Carlo Strata 2014-01-17 13:36:24 UTC
I test again also renaming the "4" folder/directory here:
C:\Users\Carlo\AppData\Roaming\LibreOffice
in "4.old" and let LibreOffice to create an clean new user directory structure, but I see the same problem.

It seems to be a windows only problem.

I hope to be clear and more useful!

Carlo
Comment 8 tommy27 2014-01-18 08:08:20 UTC
@Carlo
no problem with 4.1.4.2 under Win7 64bit
Comment 9 Carlo Strata 2014-01-19 15:50:02 UTC
@tommy27

I tested in one pc (Microsoft Windows Vista, win64/AMD64, SP2, updated, ita GUI) with LibreOffice 4.1.3.2, win32, installed and I see that there wasn't at all that button. I suppose that's the same on LibreOffice 4.1.4.2 (I have no more 4.1.4 pc at my hands because the already good 4.2.0.x stability!!!).

@All

So that I think to be misunderstood: I ask to all of you to take a simple look to attachment 92283 [details]: it's an italian gui window, as already said, but it's clear from it which button I mean!

Make us to know your correct test...

Have All a nice Sunday!

Carlo
Comment 10 tommy27 2014-01-19 17:47:55 UTC
Created attachment 92408 [details]
4.1.4.2 italian gui options

strange... my option panel is different... tested with 4.1.4.2 italian GUI under Win7 64bit.

@Carlo
maybe a user profile corruption? did you try resetting it?
moreover you could download a portable 4.1.4.2 from here ( http://sourceforge.net/projects/winpenpack/files/X-LibreOffice/releases/ ) and see if the GUI is different.
Comment 11 tommy27 2014-01-19 17:53:03 UTC
@Carlo
Ok. now I see that the options panel in 4.2.x is different from 4.1.x and has the button you were talking about

anyway, if I click that "Advanced Configuration" button I see no freeze or crash.

an option table opens up instead but has giant size and is not resizable, but this is a separate problem.

the version I tested is 4.2.1.0.0+
Build ID: 88cd9632e081f5839cf9fddf60cbff0c099e2968
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-09_22:46:56

I don't have 4.2.0.2 RC to test at the moment
Comment 12 tommy27 2014-01-19 17:56:49 UTC
as an additional difference from screenshot in Comment 9 
in 4.2.1.0+  I see oly java version 1.7.0_25
Comment 13 tommy27 2014-01-19 18:48:55 UTC
tested under Win7 64bit

Version: 4.2.1.0.0+
Build ID: 88cd9632e081f5839cf9fddf60cbff0c099e2968
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-09_22:46:56

Select Tools menu -> Options -> LibreOffice -> Advanced
click the "Advanced Configuration"

current behaviour: a huge options table with options shows up and has no resizable margins. the width is too large to be managed.

expected behaviour: the table should be resizable to fit the screen.
Comment 14 tommy27 2014-01-19 18:50:17 UTC
oooppsss.... sorry that was meant to be a separate report see Bug 73806
Comment 15 Carlo Strata 2014-01-19 21:12:05 UTC
@tommy27

Thank you for testing, you can find 4.2.0.x either here:
http://www.libreoffice.org/download/pre-releases/
or here:
http://download.documentfoundation.org/libreoffice/testing/

Is RC3 (4.0.2.3 version) code already frozen?

@All

I want to specify that I used to install LibreOffice including all (!) the "Optional Component" in the "custom install" and leaving the "Additional User Interface Languages" in the default state.

In this way I have installed the previous crashed 4.2.0.x LibreOffice.

Carlo
Comment 16 Carlo Strata 2014-01-19 21:13:11 UTC
p.s. I mean this custom install option:
https://wiki.documentfoundation.org/ReleaseNotes/4.2#Installer
Comment 17 Jean-Baptiste Faure 2014-01-26 16:24:57 UTC
Probably a duplicate of bug 72125.
You should disable assistive technologies (accessibility functions) if you want to test Advanced Configuration in 4.2.0.

Best regards. JBF
Comment 18 Jean-Baptiste Faure 2014-02-02 07:47:15 UTC
(In reply to comment #17)
> Probably a duplicate of bug 72125.
> You should disable assistive technologies (accessibility functions) if you
> want to test Advanced Configuration in 4.2.0.

Better duplicate : bug 70465
Please, feel free to reopen if you are sure that assistive technologies (accessibility / a11y) are not activated during your tests.

Best regards. JBF

*** This bug has been marked as a duplicate of bug 70465 ***