Bug 73738 - MS Word and LibreOffice writer formatting incompatibility [Hard to reproduce]
Summary: MS Word and LibreOffice writer formatting incompatibility [Hard to reproduce]
Status: RESOLVED DUPLICATE of bug 86468
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: NoRepro:4.2.0.2:OSX NoRepro:4.2.0.1:Win7
Keywords: filter:doc
Depends on:
Blocks:
 
Reported: 2014-01-17 11:39 UTC by erik
Modified: 2015-12-17 05:51 UTC (History)
7 users (show)

See Also:
Crash report or crash signature:


Attachments
Example doc document that displays the problem. (256.00 KB, application/msword)
2014-01-17 11:39 UTC, erik
Details

Note You need to log in before you can comment on or make changes to this bug.
Description erik 2014-01-17 11:39:22 UTC
Created attachment 92280 [details]
Example doc document that displays the problem.

We have a series of MS word files in .doc format that we use as templates (they are still in the .doc format even though we use them as templates). We have worked hard to remove any fancy formatting, fonts etc., since 2/3 of the company run Linux and LibreOffice.

To reproduce the erroneous behaviour:

1 - The file is OK in MS Word (2011 for Mac, 2010 for Windows).

2 - Open in Writer, version 4.1.x, 4.1.4.2, 4.2.0.2

3 - Make any change, save. I type asdf in a Body Text field and save.

4 - Open in MS Office.

The following (at least) has now happened.

1 - The logo in the two headers (page 1, subsequent pages) is no longer visible.
2 - The Title font has changed from 32 to 10 points. Still Times New Roman though.
3 - The footer has changed from Arial 8 points to Times New Roman 10 points.
4 - The style Important_header is rendered as Times New Roman 10 points. It was Arial 14 points.

With Writer version 4.2.0.2, opening the document again preserves all of these. But MS Office cannot see them. With Writer 4.1.4, the Title was simply gone when reopened in Writer.
I believe some of the other issues were also still present in Writer 4.1.4, but I concentrate on what is not working in 4.2.0.2 for now.
Comment 1 Alexandr 2014-01-19 16:29:34 UTC
I tried to save the file with LibreOffice Writer 4.1.4.2 from Debian Wheezy backports, 4.2.0.1 on Debian Jessie, 4.2.0.2 on Windows 7 and  4.3.0.0.alpha0+ (Build ID: 602c87b4259d118e5db6d8a990c4695103f916dd
TinderBox: Linux-rpm_deb-x86_64@46-TDF, Branch:master, Time: 2014-01-18_00:02:21 

I can not reproduce the problems described in the start message, but I meet another similar problem: in “1 My First Heading” title the font of “1” is changing from Arial to Symbol and in “1.1.1 Something else” title the font of “1.1.1”  is changing from Arial to Courier New.
Comment 2 Jean-Baptiste Faure 2014-01-19 17:29:47 UTC
Comment on attachment 92280 [details]
Example doc document that displays the problem.

fixing mime type
Comment 3 erik 2014-01-19 18:25:35 UTC
We have experienced similar issues as well. I will try saving on Kubuntu tomorrow to see if I can get your behaviour once I reopen in MS Word on Windows and Mac.
Comment 4 Thomas van der Meulen 2014-01-20 15:26:14 UTC
I can not reproduce this bug running LibreOffice 4.2.0.2 on mac osx 10.9.1 or 4.2.0.1 on windows 7

I have opend the file in Micro Soft office 2007 and the file from LibreOffice is the same as the unedited one.
Comment 5 erik 2014-01-31 13:21:05 UTC
From your comments, it works for some people and not for others. It does not work for us. We will have to create separate templates and document chains for LibreOffice and MS Word.

Our fear is that the powers that be will make us "standardise" on MS Word. That will cause a lot of aggravation for the developers.
Comment 6 Joel Madero 2014-07-10 01:38:27 UTC
Not a major bug - lowering to:

Normal: Can prevent high quality/professional work
Medium: Default seems appropriate here

For reference please see: 

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 7 raal 2014-12-30 09:02:41 UTC
I can not confirm with LO 4.3.5, win7. After editing the file old and new file looks identical in MSO 2010.
Comment 8 Buovjaga 2015-01-13 18:14:30 UTC
None of the issues mentioned by Erik and Alexandr were present.

Third page had changes:
Under "1.1.1 Something else", the sentence "Maybe a useful table with bold side headings:" had dropped under the table.
The text "A section with figures" had duplicated itself on the same line immediately next to "More interesting things..."

Win 8.1 32-bit
MSO 2013

LibO Version: 4.5.0.0.alpha0+
Build ID: b3b4bbaf6cbd2226b659fea7d6ae473ccf84e9dd
TinderBox: Win-x86@39, Branch:master, Time: 2015-01-12_06:13:44
Comment 9 Robinson Tryon (qubit) 2015-01-14 12:26:34 UTC
Summary -> [Hard to repro]

Erik: Are you still experiencing problems with the latest versions of LibreOffice?
https://www.libreoffice.org/download/

It would also be helpful to know what versions of linux distros you've been using for testing (e.g. you mentioned Kubuntu).

Status -> NEEDINFO

(Please change status back to UNCONFIRMED after you provide the requested information. Thanks!)
Comment 10 QA Administrators 2015-07-18 17:35:00 UTC
Dear Bug Submitter,

This bug has been in NEEDINFO status with no change for at least 6 months. Please provide the requested information as soon as possible and mark the bug as UNCONFIRMED. Due to regular bug tracker maintenance, if the bug is still in NEEDINFO status with no change in 30 days the QA team will close the bug as INVALID due to lack of needed information.

For more information about our NEEDINFO policy please read the wiki located here: 
https://wiki.documentfoundation.org/QA/FDO/NEEDINFO

If you have already provided the requested information, please mark the bug as UNCONFIRMED so that the QA team knows that the bug is ready to be confirmed.


Thank you for helping us make LibreOffice even better for everyone!


Warm Regards,
QA Team

This NEEDINFO message was generated on: 2015-07-18
Comment 11 Alexandr 2015-08-09 14:52:24 UTC
I tried the document with LibreOffice 5.0.0 on Debian Jessie. I open the document and save it. 
If I open the resulting document with MS Word Viewer I see that the table from page 3 and all under it is in page 4.
If I open it in LibreOffice Writer 5.0.0 I see that "Zenterio Technical Doc Template" title from the first page disappear and "More interesting things..." has "Heading 2" style.

I set the bug status to unconfirmed to let other peole check the document.
Comment 12 Timur 2015-08-28 15:02:36 UTC
Even if there are problems with rendering of a file:
- it's highly UNLIKELY that any bugs of type "multiple problems/some issues/bad rendering", will be fixed
- each issue (section break, paragraph break, text box, picture, font...) should be reported separately, AFTER a search for already reported bugs
- if bugs don't exist, they should be reported SEPARATELY, even if they happen with the same file

But, looks like it's rather close to MS with LO 4.4.5, except the new page. It's probably the annoying section break problem, Bug 86468.
Please open a new bug properly, after a search, if there are any remaining issues.

*** This bug has been marked as a duplicate of bug 86468 ***
Comment 13 Timur 2015-08-28 15:12:59 UTC
(In reply to Alexandr from comment #11)
> I tried the document with LibreOffice 5.0.0 on Debian Jessie. I open the
> document and save it. 
The bug started as FILEOPEN. What you tested is FILESAVE.

> If I open the resulting document with MS Word Viewer I see that the table
> from page 3 and all under it is in page 4.
Probably related to Bug 86468.
> If I open it in LibreOffice Writer 5.0.0 I see that "Zenterio Technical Doc
> Template" title from the first page disappear and "More interesting
> things..." has "Heading 2" style.
Yeah, please search and check whether is't reported already.
Comment 14 Robinson Tryon (qubit) 2015-12-17 05:51:41 UTC
Migrating Whiteboard tags to Keywords: (filter:doc)
[NinjaEdit]