Download it now!
Bug 73800 - UI: Error in function description "ZÄHLENWENNS" (, instead of ;) in calc
Summary: UI: Error in function description "ZÄHLENWENNS" (, instead of ;) in calc
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Localization (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other Linux (All)
: medium normal
Assignee: Winfried Donkers (retired)
URL:
Whiteboard: BSA target:4.3.0 target:4.2.2 target:...
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-19 16:03 UTC by reinhard.zwirnmann
Modified: 2014-02-21 10:56 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description reinhard.zwirnmann 2014-01-19 16:03:25 UTC
Problem description: 
In the german description of the function ZÄHLENWENNS in the function-assistent (?) of calc the function header is described as ZÄHLENWENNS(Bereich 1, Kriterien 1; Bereich 2, Kriterien 2; ...)
The two commas have to be exchanged by semicolons.
Operating System: openSUSE
Version: 4.1.3.2 release
Comment 1 Julien Nabet 2014-01-19 20:37:06 UTC
On pc Debian x86-64 with master sources updated today + default English UI language, I can reproduce this.
Comment 2 Winfried Donkers (retired) 2014-02-14 15:34:57 UTC
I confirm behaviour.
It is because functions with PAIRED_VAR_ARGS ( like
COUNTIFS, SUMIFS, AVERAGEIFS) used in /core/sc/source/ui/src/scfuncs.src are not correctly converted to descriptions (in hint when typing in the cell directly, and in function wizard when selecting a function).

If I can find what goes wrong where, I will try to fix it.
Comment 3 Winfried Donkers (retired) 2014-02-14 17:00:02 UTC
Found the culprit.
Submitted a fix for review.
Comment 4 Commit Notification 2014-02-14 21:31:42 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f38aa72c1d8f9e535d2b5cefbb2af7f6f37b81a8

fdo#73800 fix incorrect separator in function description in Calc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-02-14 21:39:12 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=50a2ddc88f7b9f48fecd562ca0f4bd76c79f0cc3&h=libreoffice-4-2

fdo#73800 fix incorrect separator in function description in Calc


It will be available in LibreOffice 4.2.2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Commit Notification 2014-02-14 21:49:55 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-4-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=4b0ce4aa1d87c9f65fd7d46be53eef5a5669b88f&h=libreoffice-4-1

fdo#73800 fix incorrect separator in function description in Calc


It will be available in LibreOffice 4.1.6.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Kohei Yoshida 2014-02-14 22:49:53 UTC
Assign to Winfried to get the correct bug fixer statistics.
Comment 8 Kohei Yoshida 2014-02-14 22:50:12 UTC
Marking it fixed. Thanks!
Comment 9 Commit Notification 2014-02-16 16:22:09 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "libreoffice-4-2-1":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=fab796b08e85ce08d40103c237d038b43bd1c8b9&h=libreoffice-4-2-1

fdo#73800 fix incorrect separator in function description in Calc


It will be available already in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Michael Stahl (CIB) 2014-02-21 10:56:17 UTC
correcting target, since 4.2.1.1 is 4.2.1 release