Bug 73851 - UI: options dialog contents truncated
Summary: UI: options dialog contents truncated
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.2.0.2 rc
Hardware: Other Windows (All)
: medium normal
Assignee: Caolán McNamara
URL:
Whiteboard: target:4.3.0 target:4.2.3
Keywords: regression
Depends on:
Blocks:
 
Reported: 2014-01-20 22:24 UTC by John Smith
Modified: 2014-03-01 05:21 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
An ODT document, illustrating with a screenshot, the situation described. (114.37 KB, application/vnd.oasis.opendocument.text)
2014-01-20 22:24 UTC, John Smith
Details
same screenshot (115.35 KB, image/png)
2014-02-20 05:59 UTC, tommy27
Details
Screenshot of LibO Base - Connections panel (27.43 KB, image/png)
2014-02-20 19:34 UTC, John Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Smith 2014-01-20 22:24:26 UTC
Created attachment 92493 [details]
An ODT document, illustrating with a screenshot, the situation described.

Problem description: 
The dialogue which opens at Tools - Options - LibreOffice Writer - Changes truncates the content at the bottom of the page.



              
Operating System: Windows XP
Version: 4.2.0.2 rc
Last worked in: 4.1.4.2 release
Comment 1 Jacques Guilleron 2014-01-21 18:18:43 UTC
Hi John,

Is there something missing? 
This is simply another disposition for visual confort and a better space occupation.

Kind regards,

Jacques
Comment 2 John Smith 2014-01-21 21:30:16 UTC
(In reply to comment #1)
> Hi John,
> 
> Is there something missing? 
> This is simply another disposition for visual confort and a better space
> occupation.
> 
> Kind regards,
> 
> Jacques

Yes. The bottom edge of the elements is missing. Don't just look at the screenshot, but open it and see for yourself. IMHO it's not good enough to have it nearly or mostly, fit the space, it must be complete.
You can see from earlier versions the completeness of the elements.
Comment 3 Jacques Guilleron 2014-01-22 19:04:16 UTC
Sorry John,

I don't reproduce using LO 4.2.0.2 & Windows 7 Home Premium.
Is Changes the only windows Options where you note that?
It should be complete, sure, but only a Windows XP user can answer to you, if he see the same issue.

Kind regards,

Jacques
Comment 4 John Smith 2014-01-23 18:56:11 UTC
(In reply to comment #3)
> Sorry John,
> 
> I don't reproduce using LO 4.2.0.2 & Windows 7 Home Premium.
> Is Changes the only windows Options where you note that?
> It should be complete, sure, but only a Windows XP user can answer to you,
> if he see the same issue.
> 
> Kind regards,
> 
> Jacques

Hi Jacques,
I managed to borrow another laptop and can confirm that the problem is not evident in Win7 Home Premium.
Whether you wish to pass this report forward for it to be checked on other OSes I will leave to you.
The best I can do is report the problem and leave the volunteers who do triage to decide if it requires attention.
Thanks for looking at this,

John
Comment 5 tommy27 2014-02-19 20:13:31 UTC
same results as in screenshot using 4.2.0.4 under Win7x64 Pro
set status to NEW
Comment 6 tommy27 2014-02-20 05:59:05 UTC
Created attachment 94407 [details]
same screenshot

it work in 4.1.5.3 hence regression
Comment 7 tommy27 2014-02-20 06:02:54 UTC
@John Smith
see also Bug 75175
similar issues have been reported with other Options dialogs.
could you please list which panels do you see the cut off?
Comment 8 John Smith 2014-02-20 19:27:17 UTC
(In reply to comment #7)
> @John Smith
> see also Bug 75175
> similar issues have been reported with other Options dialogs.
> could you please list which panels do you see the cut off?

The only panels which I can see cut off on my Win XP system are; the one reported above and another in LibreOffice Base - Connections
Comment 9 John Smith 2014-02-20 19:34:07 UTC
Created attachment 94455 [details]
Screenshot of LibO Base - Connections panel
Comment 10 Adolfo Jayme 2014-02-24 09:32:56 UTC
Hi @Caolán: maybe it’s fine to drop the “Text display” heading (and promote “Insertions”, “Deletions” etc. to headings) to save some vertical space? What do you think?
Comment 11 Caolán McNamara 2014-02-28 13:30:37 UTC
That seems reasonable
Comment 12 Commit Notification 2014-02-28 16:52:05 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c8cd1c61ee3f491e170086f740ffde65a8a63f83

Related: fdo#73851 select driver list widget to shrink/expand



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 13 Commit Notification 2014-02-28 16:52:21 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=c923b15cd99672e5b93d1ab6314c66caa417c738

Resolves: fdo#73851 promote labels to headings



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 14 Caolán McNamara 2014-02-28 17:09:28 UTC
backport to 4-2 as https://gerrit.libreoffice.org/#/c/8397/
Comment 15 Commit Notification 2014-03-01 05:21:54 UTC
Caolan McNamara committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=90aad4ad6aa814710ce7553cb196392da949e9a8&h=libreoffice-4-2

Resolves: fdo#73851 promote labels to headings


It will be available in LibreOffice 4.2.3.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.