Bug Hunting Session
Bug 73927 - Sidebar fails to resize
Summary: Sidebar fails to resize
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Sidebar-UI-UX
  Show dependency treegraph
 
Reported: 2014-01-22 12:23 UTC by Armandos
Modified: 2016-10-24 14:41 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Armandos 2014-01-22 12:23:28 UTC
Related to: https://bugs.freedesktop.org/show_bug.cgi?id=73889

When using the sidebar and resizing the window, the sidebar retains its size and dead space between icons. Only the document is hidden, which makes multi-tasking and working between documents difficult.

Ideally, the sidebar should be the one to resize. Space between icons on sidebar deck should get smaller, and the sidebar deck could auto-hide when the window is being resized.

Another possible solution would be tabbed interface, where switching between documents open in the same instance would be done through tabs -just like all modern browsers and productivity suites.
Comment 1 Armandos 2014-01-22 12:38:55 UTC
The dead space does not refer to icons on the character tab but ones such as indent, before text indent and above paragraph spacing.
Comment 2 Maxim Monastirsky 2014-01-22 13:50:20 UTC
Hi,

(In reply to comment #0)
> When using the sidebar and resizing the window, the sidebar retains its size
> and dead space between icons.
AFAIK It has been fixed in 4.2. (Or I'm missing something?)
Comment 3 V Stuart Foote 2014-02-07 22:07:57 UTC
Working with 4.2.0.4 final release on Windows 7 sp1, 64-bit
Version: 4.3.0.0.alpha0+
Build ID: c8a089d7dfa2527ff25aa144e65d0c96ea90028d
TinderBox: Win-x86@39, Branch:master, Time: 2014-02-06_10:29:45

For a given component, the Sidebar has both a maximum and a minimum width. Depending on the panel controls it contains. It can be dynamically re-sized to any size between with the 'dead space' between controls adjusting, but then no further in either direction.

Additionally, there is a single click selector to hide, or un-hide the sidebar.

The behavior is by design and functions as expected.

If additional compression (shirnkage) of the sidebar controls is sought, that is an enhancement and would need to be worked out with the UX design folks.

Setting resolved invalid.
Comment 4 Carlos 2015-07-29 12:37:06 UTC
Sidebar fails to resize and freezes.
Comment 5 Maxim Monastirsky 2015-07-29 12:43:33 UTC
(In reply to Carlos from comment #4)
> Sidebar fails to resize and freezes.
And how is this related to this ancient report? Please open a new bug for your problem.

Reverting the version, and closing again (The correct status is RESOLVED FIXED, because it was fixed in the 4.2 cycle by converting the panels to the .ui format.)