Bug 73937 - FILEOPEN: Importing .doc file makes Writer freeze
Summary: FILEOPEN: Importing .doc file makes Writer freeze
Status: RESOLVED DUPLICATE of bug 73936
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
3.3.0 release
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-22 17:25 UTC by Mohamed-Ali BEN MANSOUR
Modified: 2014-01-23 15:41 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
A .doc file causing the freeze (414.50 KB, application/msword)
2014-01-22 17:25 UTC, Mohamed-Ali BEN MANSOUR
Details
Simplified version of the test document (29.50 KB, application/msword)
2014-01-22 20:52 UTC, Laurent BP
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Mohamed-Ali BEN MANSOUR 2014-01-22 17:25:06 UTC
Created attachment 92596 [details]
A .doc file causing the freeze

Problem description: 

When whe try to open the attached file, it seems that Writer loops on it and freezes.



              
Operating System: All
Version: 4.1.4.2 release
Comment 1 Mohamed-Ali BEN MANSOUR 2014-01-22 17:30:36 UTC
The same file can be opened with Apache OpenOffice 4.0.1
Comment 2 Laurent BP 2014-01-22 20:17:23 UTC
Hi,

Reproduced with:
- LibO 3.3.0.4 : les 2 fichiers gèlent
- LibO 3.5.7.2 : les 2 fichiers gèlent
- LibO 4.1.4.2 : les 2 fichiers gèlent
- LibO 4.2.0.2
- LibO Version: 4.3.0.0.alpha0+ Build ID: 99159a618fd1ea90a2bc8a72621c88a4cf26e6f5 TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-01-17_06:46:31

NOT reproduced with:
- OOo 3.3.0m20
- AOO 3.4.0
- AOO 4.0.1

The bug was introduced at the beginning of LibO.

May be duplicate of bug 73936
Comment 3 Laurent BP 2014-01-22 20:52:51 UTC
Created attachment 92618 [details]
Simplified version of the test document

The freeze occurs due to this small part: a non-breaking space is inserted just after a field, and LibO seems to have problem because it cannot cut the field.
Comment 4 Laurent BP 2014-01-22 21:01:39 UTC

*** This bug has been marked as a duplicate of bug 73936 ***
Comment 5 vulcain 2014-01-22 22:48:13 UTC
I confirm freeze with the first attachement on Ubuntu 12.04.4 x86_64 with LibreOffice  4.2.0.2 Build ID: 601a398b803303d1a40a3299729531824fe0db56
Comment 6 Mohamed-Ali BEN MANSOUR 2014-01-23 15:41:34 UTC
Thank you Laurent !It's really a matter of non breaking space after a field.

Allow me to add some details:
- The issue appears when we have a list field. (it works fine with a text field).
- The freeze occurs when the list field comes after a line break and followed by a non breaking space.
- Even if the we have a short list field, the bug is there with the above conditions.