Bug Hunting Session
Bug 73940 - Page header odd/even first page different problem
Summary: Page header odd/even first page different problem
Status: RESOLVED NOTABUG
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All Windows (All)
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-22 17:45 UTC by Phillip Ross
Modified: 2015-02-26 11:35 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
400 page book - not master document (687.02 KB, application/vnd.oasis.opendocument.text)
2014-01-22 17:45 UTC, Phillip Ross
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Phillip Ross 2014-01-22 17:45:57 UTC
Created attachment 92599 [details]
400 page book - not master document

On the following even-number pages, the page number and page header are in the odd-number format: 2, 16, 68, 130, 138, 148, 154, 170, 222, 232, 248, 260, 282, 304, 312, 346, 352, 358, 370, 394. There is a pattern here. The first page of all chapters are numbered at bottom-center. Whenever a chapter begins with an odd page number, the next page (an even number) has the wrong page header format.

Is this a bug? Or is it a setting issue? If it's a setting problem, what is the correct setting?
Comment 1 Dominique Boutry 2014-01-28 16:22:19 UTC
Firstly, we need to speak "specification".

I compared your book with other, and I found the following :
- OK for chapter titles forced in an odd (= right) page number,
- OK for a page number centered in the footer of such odd pages,
- OK for second and third pages of a chapter being mirrored (a left/even page followed by an right/odd page), and so on.

But here is the difference I noticed : it happens on the reminder of the book title :
- the books I checked have the whole book title on left/even page header ; generally a chapter title on the right/odd page header ;
- on your book, the book title is split between left and right headers ; how do you manage the case where the last non-empty page of a chapter is a left/even one? Will the title be cut by its middle (only "Ephesians—Recovering the Vision") because the mirrored page is the new chapter title?

Now A agree to speak "LibO technology" :
- This case remember me bug 69065; this one is marked as fixed for Lib0 4.2,
- when I load your doc under LibO 4.2.0.3, I see the errors you mentionned, but not at the same pages : something has effectively changed between 4.1 and 4.2,
- I have the error you mentionned, on pages 14, 22, 
- I found left/even first chapter pages (26, 46, 54
Comment 2 Dominique Boutry 2014-01-28 16:30:51 UTC
The following ... (bad <enter> hit... sorry)

My conclusion :
- you have some checks still to do in your document,
- you could jump to version 4.2 (however currently not in production...)
- and/or perhaps the bug 69065 (duplicate bug 71360) is not totally corrected
- and/or LibO is now (since 4.2) OK but it fails on a document saved with older buggy version.

Regards
Comment 3 Cor Nouws 2014-02-06 14:38:08 UTC
(should find time to digg into this ..)
Comment 4 Joel Madero 2014-07-10 01:40:12 UTC
Not a major bug - lowering to:

Normal: Can prevent high quality/professional work
Medium: Default seems appropriate here

For reference please see: 

https://wiki.documentfoundation.org/images/0/06/Prioritizing_Bugs_Flowchart.jpg

+ + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + + 
LibreOffice is powered by a team of volunteers, every bug is confirmed (triaged) by human beings who mostly give their time for free. We invite you to join our triaging by checking out this link:
https://wiki.documentfoundation.org/QA/BugTriage

There are also other ways to get involved including with marketing, UX, documentation, and of course developing -  http://www.libreoffice.org/get-help/mailing-lists/. 

Lastly, good bug reports help tremendously in making the process go smoother, please always provide reproducible steps (even if it seems easy) and attach any and all relevant material
Comment 5 Joel Madero 2015-02-26 04:00:11 UTC
I'm sorry but I'm really not understanding this bug. Can you please provide a bit more detail about what I should be seeing. 

Tested on:
Ubuntu 14.10 x64
LibreOffice 4.4.1.2 rc

From what I can see odd/even numbering each have their own styles that consistently apply unless it's the page after the first page of a chapter, in which case, it appears like there's another style in play.

Marking as NEEDINFO - sorry for the long delay but if you can provide additional input (including verifying that it's still an issue on 4.4) and set to UNCONFIRMED that would be fantastic. Thanks!
Comment 6 Cor Nouws 2015-02-26 11:35:45 UTC
as per comment 2 I would say: NotABug
User help is best place for details (if needed, with the given remarks in comment 2).
 See http://www.libreoffice.org/get-help/community-support/

If there turns out to be a real bug, pls provide clear sample & info & reopen.
Thanks a lot,
Cor