Bug 71360 - Page after header-less 'First page' style is always formatted as right-hand page
Summary: Page after header-less 'First page' style is always formatted as right-hand page
Status: RESOLVED DUPLICATE of bug 69065
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
unspecified
Hardware: x86-64 (AMD64) All
: medium normal
Assignee: Michael Stahl (allotropia)
URL:
Whiteboard:
Keywords: regression
Depends on:
Blocks:
 
Reported: 2013-11-07 21:58 UTC by Jonathan S
Modified: 2014-02-03 14:18 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Showing left-hand page 4 appearing as right-hand page (29.24 KB, application/vnd.oasis.opendocument.text)
2013-11-07 21:58 UTC, Jonathan S
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jonathan S 2013-11-07 21:58:49 UTC
Created attachment 88849 [details]
Showing left-hand page 4 appearing as right-hand page

When the document has a page with 'First Page' page-style and that page has no header, the following page is always formatted as a right-hand page - even when it is actually a left-hand page.
See, for example, page 4 in the attached file.

This is a regression - works correctly in 4.0.4.
Bug verified in 4.0.6, 4.1.2, 4.1.3.

I've noticed that the problem can be *temporarily* solved by editing the First-page style, header tab - tick the 'Header On' box (to gain access to the boxes under it), untick the 'Same content left/right' box, then untick again the 'Header On' box, and press OK. Incorrect formatting on following page is corrected - however, this 'fix' cannot be saved. Saving the document, closing and re-opening it shows again the original problem.
Comment 1 sophie 2014-01-08 15:58:03 UTC
I can not reproduce on 4.1.2 and 4.2. If I open the page style: Text page, the layout settings on the Page tab are Right and Left and not Left only or Right only. Where did you check for the formatting of the page? Sophie
Comment 2 Jonathan S 2014-01-08 23:13:06 UTC
Hi Sophie, Thanks for looking into this.

All the page layouts are indeed set 'Right and left', which is correct. However, the problem is page 4 - it's a LEFT-hand page but Writer is treating it as a RIGHT-hand page. Page 4 is headed 'Chapter One' - like pages 5 and 7 - when it should be headed 'Main Title for Left-hand Header' - like pages 6 and 8.

I've reported this problem before in 4.0.0 and it was fixed in 4.0.2 (Bug 60260 https://bugs.freedesktop.org/show_bug.cgi?id=60260). However, by 4.0.6, this bug was back and I see it still in 4.1.4. All the details of that bug are still relevant (see especially my comment dated 2013-02-10)

Since bug 60260 was closed as a duplicate (Miklos's last comment) of a similar bug, I thought it better to open a new bug since I'm not sure how this problem relates to the duplicate bug (Bug 61952).
Comment 3 sophie 2014-01-09 13:22:10 UTC
Hi Jonathan, so there is something strange in the document, but I'm not sure that it's the same as the previous bug. 
If you look at your document under File > Preview, and you set the book preview, you'll see that the third page of the document is a blank page. You can also see it if you set the book view on the status bar. 
Knowing that Writer considers that the first page of a document is always a right-hand page, page 4 is a right-hand page for Writer. So the comportment for Writer follow its logic.
What I don't understand is the blank page added before the First page style when it is applied. If I set the page style First page to the one containing "Main title for the left-hand header" (currently with Default page style), a blank page is added before and this blank page is the first page of the document. 
So I set the bug to New and and add bug#60260 in see also. - Sophie
Comment 4 Michael Stahl (allotropia) 2014-01-10 14:10:04 UTC
this regression was fixed by commit e936ecc92a7e362f57ce72a955697840920636b8

*** This bug has been marked as a duplicate of bug 69065 ***
Comment 5 sophie 2014-01-10 14:14:13 UTC
@Michael: I was on my way to test it again with RC2 too. So I confirm it's fixed with Version: 4.2.0.2
Build ID: 601a398b803303d1a40a3299729531824fe0db56 - Sophie
Comment 6 Jonathan S 2014-01-12 22:21:41 UTC
Yes, fixed in 4.2.0.2.
Thanks very much for fixing it.
Comment 7 Dominique Boutry 2014-02-03 14:18:13 UTC
*** Bug 74390 has been marked as a duplicate of this bug. ***