Download it now!
Bug 74025 - Other: Incorrect function display when write some functions in a cell
Summary: Other: Incorrect function display when write some functions in a cell
Status: RESOLVED DUPLICATE of bug 71077
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-01-24 18:29 UTC by f.rr
Modified: 2015-12-15 22:17 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description f.rr 2014-01-24 18:29:44 UTC
Problem description: the functions that in the 'Function Wizard' list are followed from an other function with the same name and UNDERSCORE or POINT (for exaple CONVERT is followed from CONVERT_ADD or CONFIDENCE from CONFIDENCE.NORM) shown wrongly the next function in the cell. I'm sorry for my bad english.

Steps to reproduce:
1. Open a new file
2. Type in a cell =CONVERT(

Current behavior: it show in preview the function CONVERT_ADD

Expected behavior: it must show the function CONVERT



              
Operating System: All
Version: 4.2.0.3 rc
Last worked in: 4.1.4.2 release
Comment 1 f.rr 2014-01-24 19:04:36 UTC
Last worked in: 3.x (not 4.1.4.2 release)
Comment 2 Julien Nabet 2014-01-24 21:19:18 UTC
On pc Debian x86-64 with master sources updated today, I can reproduce this.
Comment 3 Joel Madero 2014-01-24 22:42:01 UTC
73eaae9d1e97ec4b1f434cf01b5c1f97a5d8389e is the first bad commit
commit 73eaae9d1e97ec4b1f434cf01b5c1f97a5d8389e
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Oct 16 11:07:50 2013 +0000

    source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
    
    commit 5da10275a7475efdbfd9de14ea58cf8f4c6c1582
    Author:     Stephan Bergmann <sbergman@redhat.com>
    AuthorDate: Fri Mar 1 17:09:45 2013 +0100
    Commit:     Stephan Bergmann <sbergman@redhat.com>
    CommitDate: Fri Mar 1 17:18:29 2013 +0100
    
        Related rhbz#915743: Abort UCB call from SvtMatchContext_Impl::Stop
    
        ...as otherwise the SvtMatchContext_Impl thread can continue to run for
        arbitrarily long, and the other thread calling Stop() and join() will block.
    
        However, especially the WebDAV UCP does not properly support aborting commands,
        see 260afe56fd6b2f34de8290f3cdb7d1df5b88f8a8 " neon commands cannot be aborted",
        so this is not yet enough to actually fix rhbz#915743 "thread deadlock/slow
        join in insert->hyperlink in impress."
    
        Change-Id: I0da899f824763e1b3d19bb5b38d906feb690b623

:100644 100644 fd22aadcebcf1ca20b6c2fcdb9e135deeb9b5885 8a0f14e1bb71d7ecdf8086c62e9769bb7f2d09b8 M	autogen.log
:100644 100644 5af869ab53b50329a270e7d4e2587f802bf68afb 8519bf956c5e06a85818d380070eedc0ef846790 M	ccache.log
:100644 100644 63cd7351c9d6feb098661a5783d51bb172d8a306 33abac29aad7182260562465482b493d94b78a83 M	commitmsg
:100644 100644 e9ea867065a69fa4f0fbbb5c2abb40baeeabd307 21fc5294b2cb922862b78327b6b8a3cd953f38b5 M	dev-install.log
:100644 100644 4c087a5ff52a8cef08f31417ac650666b1d9d0af c1cc87465560a589137349c81641a62968242386 M	make.log
:040000 040000 ece742cbaf9101d015210ea8da6c00ad7a4457c7 9ff9cbceea1fe6b0ad1b17fe9068b2c8e32a6cbb M	opt


# bad: [25428b1e953636f74986622c5df614f04c150ed1] source-hash-cb4e009c4539c535108021934e545194b35cad9d
# good: [f0f6c65eb764f0303f59c58d320e9b0d5a894377] source-hash-4b9740b4ec3987e1d4d2ad6d20b4dcf996a4fa2e
git bisect start 'latest' 'oldest'
# bad: [a72833796a7e527d9efc9ca6d8fe9b579e469105] source-hash-1472b5f87314fe660ef1a7b254e51272669f12f6
git bisect bad a72833796a7e527d9efc9ca6d8fe9b579e469105
# bad: [4300c48268179afe8db66410fad04436183407cd] source-hash-753310b7db6a36aeaae36cef3bfca970e9310569
git bisect bad 4300c48268179afe8db66410fad04436183407cd
# good: [280c5141ea58e6b50f7d46546a9c52891225eeff] source-hash-ba446dd58a4ad324d242afcd5b28d3b4dff5a881
git bisect good 280c5141ea58e6b50f7d46546a9c52891225eeff
# bad: [8734d0269629a270d9e97cb5176bcc6b76338a54] source-hash-07352f07ce40ef40e9b73fd05aa4f9c5eac38290
git bisect bad 8734d0269629a270d9e97cb5176bcc6b76338a54
# bad: [b42797d9346abe9681bf36768258d309b83d17da] source-hash-ee53857e984fea54b7dc08b99079b38766f0b796
git bisect bad b42797d9346abe9681bf36768258d309b83d17da
# bad: [4384f6d33ec00ba3566675d505ee585a2af5be6d] source-hash-310fb291ccfb817a3503785af143828682c0c1f1
git bisect bad 4384f6d33ec00ba3566675d505ee585a2af5be6d
# bad: [817b9556dbb6406a10ff28416e98ff343df491e7] source-hash-b15f095293c6127ecaef2f0fa3a1683e72392835
git bisect bad 817b9556dbb6406a10ff28416e98ff343df491e7
# bad: [73eaae9d1e97ec4b1f434cf01b5c1f97a5d8389e] source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
git bisect bad 73eaae9d1e97ec4b1f434cf01b5c1f97a5d8389e
# first bad commit: [73eaae9d1e97ec4b1f434cf01b5c1f97a5d8389e] source-hash-5da10275a7475efdbfd9de14ea58cf8f4c6c1582
Comment 4 Jean-Baptiste Faure 2014-01-25 14:08:15 UTC
Known bug : duplicate of bug 71077

Best regards. JBF

*** This bug has been marked as a duplicate of bug 71077 ***
Comment 5 Robinson Tryon (qubit) 2015-12-15 22:17:17 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
Remove redundant 'ConfirmedRegression'
[NinjaEdit]