Bug 71077 - Wrong tips for functions in Calc that have a funcname_ADD or funcname.* variant too
Summary: Wrong tips for functions in Calc that have a funcname_ADD or funcname.* varia...
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.1.2 release
Hardware: Other All
: medium normal
Assignee: Winfried Donkers (retired)
URL:
Whiteboard: target:4.3.0
Keywords:
: 74025 (view as bug list)
Depends on:
Blocks:
 
Reported: 2013-10-31 07:30 UTC by
Modified: 2014-02-26 13:05 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
example screenshot for GDC function (6.09 KB, image/png)
2013-10-31 07:30 UTC,
Details
Function with incorrect help tip. (18.79 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-26 14:25 UTC, f.rr
Details

Note You need to log in before you can comment on or make changes to this bug.
Description 2013-10-31 07:30:41 UTC
Created attachment 88397 [details]
example screenshot for GDC function

When you enter a function in Calc you get a tip in a yellow box with help for the entered function. This help tip is incorrect for functions that have a *_ADD variant too. For this functions you see the help tip for the *_ADD function instead of the correct help tip for the function whithout *_ADD.

I added a screenshot with the wrong behavior of the GCD function.

This behavior is present in 4.1 as well as in 4.0 but not present in 3.6 release.
Comment 1 Dominique Boutry 2013-11-03 11:06:58 UTC
Reproduced with LibO 4.1.2.3 on Win7
Comment 2 Jean-Baptiste Faure 2013-11-03 16:57:25 UTC
Reproducible with LO 4.1.4.0.0+ and master under Ubuntu 13.10 x86-64

Best regards. JBF
Comment 3 Jean-Baptiste Faure 2014-01-25 14:08:15 UTC
*** Bug 74025 has been marked as a duplicate of this bug. ***
Comment 4 Jean-Baptiste Faure 2014-01-25 14:09:55 UTC
See bibisect in https://bugs.freedesktop.org/show_bug.cgi?id=74025#c3

Best regards. JBF
Comment 5 f.rr 2014-01-26 14:25:36 UTC
Created attachment 92813 [details]
Function with incorrect help tip.
Comment 6 f.rr 2014-01-26 14:33:45 UTC
I think this bug must have high importance. In italian language cause incorrect help tip in 56 functions, including the most-used like IF, SUM, DATA, MAX, YEAR etc. I atttached the list. Change in to italian language and you can test. New users with low knowledgecan can be discuraget to use LibreOffice. Thenk you.
Comment 7 Winfried Donkers (retired) 2014-02-18 16:51:13 UTC
I will take this bug.
Comment 8 Winfried Donkers (retired) 2014-02-19 14:16:31 UTC
Found the cause; think I fixed it too, but want to test some more.

(for ease of reading I use GCD() and GCD_ADD() as an example:)
Explanation: In the alphabetic functiondescription list, GCD_ADD(..) comes before GCD(..). The function description is found by searching for the function name ( where the description will be longer than the function name as it has the arguments added to it). And so GCD_ADD is found first...
Solution: search for "GCD(" instead of "GCD".


Also, I found that when typing in a cell ("=G", "=GC", "=GCD") a tip appears for the expected function, but this tip disappears as soon as you get to "=GCD_".
As this is related code, I want to have a look at that too, before I submit my patch.
Comment 9 Winfried Donkers (retired) 2014-02-20 15:56:00 UTC
I have created a separate bug report for the second problem as described in comment #8 : bug 75264.
Comment 10 Commit Notification 2014-02-21 12:45:40 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=00856ac90d4a230d6f219937f836ca0e9f3fe1e3

fdo#71077 wrong tips for some calc functions



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 11 f.rr 2014-02-22 18:31:44 UTC
I tested the 'master' vertion and the bug looks fixed.
I discovered an other bug and I think in the same code.
The functions that finish with a number are no showed.

To riproduce it...

Type   =DAYS360(   in a cell

it doesn't sho nothing.

I don't know if is better to create a new bug or not.
Comment 12 Winfried Donkers (retired) 2014-02-23 16:06:32 UTC
(In reply to comment #11)
> I discovered an other bug and I think in the same code.
> The functions that finish with a number are no showed.
> 
> To riproduce it...
> 
> Type   =DAYS360(   in a cell
> 
> it doesn't sho nothing.
> 
> I don't know if is better to create a new bug or not.

Bug 75264 is for this problem (although the bug title is not yet satisfactory).

I set this bug to closed as the fix has been pushed and confirmed.
Comment 13 f.rr 2014-02-26 12:59:28 UTC
(In reply to comment #12)
> (In reply to comment #11)
> > I discovered an other bug and I think in the same code.
> > The functions that finish with a number are no showed.
> > 
> > To riproduce it...
> > 
> > Type   =DAYS360(   in a cell
> > 
> > it doesn't sho nothing.
> > 
> > I don't know if is better to create a new bug or not.
> 
> Bug 75264 is for this problem (although the bug title is not yet
> satisfactory).
> 
> I set this bug to closed as the fix has been pushed and confirmed.

I'm sorry, I didn't understand, the problem is not the bug title but my bad english.
Then you for fixed the bug.
Comment 14 Winfried Donkers (retired) 2014-02-26 13:05:26 UTC
(In reply to comment #13)
 
> I'm sorry, I didn't understand, the problem is not the bug title but my bad
> english.

That's no problem, just as you I am not a native English speaker. I also have my difficulties in either being clear myself or understanding others ;)

It's because of everybody's feedback and help that LibreOffice keeps improving!