Download it now!
Bug 75264 - tips when entering function in cell wrong or missing
Summary: tips when entering function in cell wrong or missing
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.1.3.2 release
Hardware: Other All
: medium normal
Assignee: Winfried Donkers (retired)
URL:
Whiteboard: target:4.3.0
Keywords:
: 80202 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-02-20 15:53 UTC by Winfried Donkers (retired)
Modified: 2014-06-19 05:52 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Winfried Donkers (retired) 2014-02-20 15:53:40 UTC
(for ease of reading I use GCD() and GCD_ADD() as an example:)
When typing in a cell ("=G", "=GC", "=GCD") a tip appears for the expected function, but this tip disappears as soon as you get to "=GCD_".
Comment 1 Winfried Donkers (retired) 2014-02-23 16:12:06 UTC
Also, for functions that do not have 'extended' names (like GCD and GCD_ADD), the tip doesn't show as expected.
Comment 2 Winfried Donkers (retired) 2014-02-24 08:44:59 UTC
problem summary (AFAICS presently):

-the tip above the cell is supposed to show the first matching function name whilst typing a function name. It currently only shows the base function name for functions that have extended function names (like GCD/GCD_ADD and PERCENTRANK/PERCENTRANK.EXC).

-the tip below the cell shows when the function name has been entered fully and the ( added; it shows the arguments the function uses. Currently, it doesn't show for all functions (e.g. DAYS360).
Comment 3 Commit Notification 2014-05-12 16:45:14 UTC
Winfried Donkers committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=5b0b7553241bb5150b12bbf7625b4b0b36970272

fdo#75264 fix incorrect/missing function tips in Calc



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-05-12 21:28:35 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ead754112a1ecaa456d8b5d7231ed178bbcb3a0b

nitpick: avoid triple redirection inside loop, fdo#75264 related



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Commit Notification 2014-05-12 21:28:54 UTC
Eike Rathke committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=ad8a7bf570576186f37d5c30bb41bb119ded1626

include parentheses replacement in functions' formula data, fdo#75264



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 6 Kohei Yoshida 2014-05-15 02:21:11 UTC
Ok.  Now Calc freezes every time I type

="

or any formula that contains " e.g.

=IF(1,"

or anything like that.
Comment 7 Kohei Yoshida 2014-05-15 02:23:11 UTC
Filed Bug 78718.
Comment 8 Winfried Donkers (retired) 2014-06-19 05:52:36 UTC
*** Bug 80202 has been marked as a duplicate of this bug. ***