Bug 74037 - FILEOPEN: Calc-4.2+ freezed when opening file with mixed Chinese characters
Summary: FILEOPEN: Calc-4.2+ freezed when opening file with mixed Chinese characters
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: x86 (IA32) All
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-25 04:10 UTC by d00m3d.olw
Modified: 2014-02-17 05:40 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Problem case file, used to work in 4.1 but failed in 4.2+ (12.02 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-25 04:10 UTC, d00m3d.olw
Details

Note You need to log in before you can comment on or make changes to this bug.
Description d00m3d.olw 2014-01-25 04:10:59 UTC
Created attachment 92754 [details]
Problem case file, used to work in 4.1 but failed in 4.2+

I believe this is a regression as both files are working OK in 4.1.x but failed to work in 4.2+ including master.  Details are as below:

Versions work OK:
Platform: Linux
Version: 4.1.5.1
Build ID: e0a1805d063a472a7b281ae3977a26d42a48b20

Platform: Win7
Version: 4.1.4.2
Build ID: 0a0440ccc0227ad9829de5f46be37cfb6edcf72


Versions do not work:
Platform: Linux
Version: 4.3.0.0.alpha0+
Build ID: f013eab80638e732d9cc81af798b2e554c1666fa
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-01-24_00:29:49

Platform: Win7
Version: 4.2.0.3
Build ID: c63c03decdf780d8fb80823950665b782ec9ecd0

Problem case file is attached.

I notice there are some issues with Chinese or Korean characters during editing:
https://bugs.freedesktop.org/show_bug.cgi?id=72470
https://bugs.freedesktop.org/show_bug.cgi?id=72702

They freezed at editing but I freezed when opening.  I am not sure whether they are related.

I would be appreciated if this problem could be corrected ASAP, ideally before stable 4.2 release.

Thanks in advance.
Comment 1 tommy27 2014-01-25 08:31:34 UTC
it works under Win7 64bit using Version: 4.2.1.0.0+
Build ID: 88cd9632e081f5839cf9fddf60cbff0c099e2968
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-09_22:46:56
Comment 2 Kevin Suo 2014-02-06 09:43:35 UTC
Comment on attachment 92754 [details]
Problem case file, used to work in 4.1 but failed in 4.2+

Correcting mine type to application/vnd.oasis.opendocument.text
Comment 3 Kevin Suo 2014-02-06 09:46:57 UTC
Comment on attachment 92754 [details]
Problem case file, used to work in 4.1 but failed in 4.2+

Sorry, should be "application/vnd.oasis.opendocument.spreadsheet".
Comment 4 Kevin Suo 2014-02-06 10:04:20 UTC
No problem openning your file with 4.2.0.4, ubuntu 13.10 x86, 
but freezes as I expected when copying and paste the last value (三星 17") into cell F6, which is the same as Bug 72470.
Comment 5 d00m3d.olw 2014-02-06 11:34:29 UTC
Just resume works from Chinese New Year break.  I do not have 64-bit platforms for testing.  I tried again on Win7 32-bit platform, 4.2 and up are still failed to open.

Works OK
Platform: Win7 32-bit
Version: 4.1.5.2
Build ID: a02f36998a4af5e2f9fbec2b7e9f70a8b0bc934

Still not working
Platform: Win7 32-bit
Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71

Still not working
Platform: Win7 32-bit
Version: 4.2.1.0.0+
Build ID: a054c52a6fc556ddf1383b676e7be533aed69420
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-04_11:26:19

Still not working
Platform: Win7 32-bit
Version: 4.3.0.0.alpha0+
Build ID: bcfa89158e1ce8cecf9c078ef852225180472a55
TinderBox: Win-x86@47-TDF, Branch:MASTER, Time: 2014-01-30_14:53:08

Linux platform can only be tested when I returned to China in next week.
Comment 6 m.a.riosv 2014-02-07 21:59:21 UTC
No issue now with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Seems patches in 72470 has been solved the bug.

Changed the status: duplicate 72470, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***
Comment 7 d00m3d.olw 2014-02-09 02:34:25 UTC
Tried with a newer snapshot:
Version: 4.2.1.0.0+
Build ID: 0d8253bc17cb5476fb558c0e17f5422d76f3e3db
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_23:08:31

This version works OK
Platform: Win7 32-bit

Linux platform will be tested in next couple of days when I travel to China.
Comment 8 d00m3d.olw 2014-02-11 03:14:36 UTC
I just tried 4.1.5.3-pre-release from:

http://dev-builds.libreoffice.org/pre-releases/deb/x86/

Version: 4.1.5.3
Build ID: 1c1366bba2ba2b554cd2ca4d87c06da81c05d24
Platform: Linux 32-bit

This version works OK as expected.

There is no daily snapshot for 4.2 on Linux platform and the latest master is only a pre-patched version date back to Jan29,2014.

In other words, I am unable to confirm this bug whether it is resolved on Linux 32-bit platform for version 4.2+ until more recent snapshots are available.  :(
Comment 9 d00m3d.olw 2014-02-12 03:49:15 UTC
Just tested a newer snapshot from master today.  It also works OK.

Platform: Linux 32-bit
Version: 4.3.0.0.alpha0+
Build ID: 3ec8d33e46046b13abad2daf850e23f896ad05bc
TinderBox: Linux-rpm_deb-x86@45-TDF, Branch:master, Time: 2014-02-11_23:54:43

The remaining outstanding version would be 4.2.x, which still have no patched snapshot on Linux 32-bit platform available for testing.

Despite I should have no worries, I still wanna confirm it.
Comment 10 d00m3d.olw 2014-02-17 05:40:45 UTC
LibO-4.2.1-RC1 is recently released and tested.

Platform: Linux 32-bit
Version: 4.2.1.1
Build ID: d7dbbd7842e6a58b0f521599204e827654e1fb8b

No problems found.

Thanks again for everyone's efforts to trace and debug this issue.

I can confirm this bug is resolved.  :)