Bug 74044 - FILEOPEN can't open specific XLS file
Summary: FILEOPEN can't open specific XLS file
Status: RESOLVED DUPLICATE of bug 72470
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: Confirmed:4.2.0.3:OSX
Keywords:
Depends on: 72470
Blocks:
  Show dependency treegraph
 
Reported: 2014-01-25 09:11 UTC by walid
Modified: 2014-02-07 22:42 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Sample file that opens normally on 4.1 or earlier, but not on 4.2 (90 bytes, application/x-msexcel)
2014-01-25 09:11 UTC, walid
Details

Note You need to log in before you can comment on or make changes to this bug.
Description walid 2014-01-25 09:11:22 UTC
Created attachment 92762 [details]
Sample file that opens normally on 4.1 or earlier, but not on 4.2

if I open the sample file on calc 4.2.0.3, Calc will freeze.

However it will open normally on previous versions: 3.6, 4.0, 4.1

I think it happens only when the Same Cell contains Arabic and English letters at the same time.

The sample file is generated from Microsoft Visual Foxpro

I am using ubuntu 13.04 to open the file
Comment 1 tommy27 2014-01-25 11:18:06 UTC
tested under Win7 64bit

4.1.4.2 can open that file
4.2.1.0.0+ (*) can't open it

I add Calc expert to CC list

(*) Build ID: 88cd9632e081f5839cf9fddf60cbff0c099e2968
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-09_22:46:56
Comment 2 Jean-Baptiste Faure 2014-01-25 12:57:46 UTC
Comment on attachment 92762 [details]
Sample file that opens normally on 4.1 or earlier, but not on 4.2

Where is this attachment? I can't find it, seems to be a link, not the file itself. Please attach the file itself.

Best regards. JBF
Comment 3 tommy27 2014-01-25 17:31:06 UTC
@JBF
the attachment looks in the right place. I can download it with no issue.
Comment 4 retired 2014-01-27 10:28:26 UTC
JBF: right-click the test file when visiting this bugzilla page in your browser > save file as...

That way I retrieved the Test.xml fill, so that works. Confirmed:4.2.0.3:OSX
Comment 5 Kohei Yoshida 2014-02-07 18:22:55 UTC
This too sounds like another manifestation of Bug 72470, which has already been fixed in the 4.2 branch.

The file opens fine with my local build.

Please check this again when you get a more recent build that has the fix for Bug 72470.
Comment 6 m.a.riosv 2014-02-07 22:42:35 UTC
Retested, works for me with:
Win7x64Ultimate
Version: 4.2.1.0.0+ Build ID: 63950ec72806489b41c2109f5c3840dcf22f4c6c
        TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-07_00:47:07

Bug is still reproducible with 4.2.0.4, I can't open the sample file.

Changed status: duplicate 72470, please if you are not agree reopen it.

*** This bug has been marked as a duplicate of bug 72470 ***