Bug 74090 - Hyperlinks get scrambled when opening xlsx document
Summary: Hyperlinks get scrambled when opening xlsx document
Status: RESOLVED DUPLICATE of bug 74535
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.2.0.3 rc
Hardware: x86-64 (AMD64) Windows (All)
: medium major
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-26 18:07 UTC by Stuart Ree
Modified: 2014-02-19 15:38 UTC (History)
2 users (show)

See Also:
Crash report or crash signature:


Attachments
4.1.4 version (8.46 KB, application/vnd.openxmlformats-officedocument.spreadsheetml.sheet)
2014-01-26 18:07 UTC, Stuart Ree
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Stuart Ree 2014-01-26 18:07:17 UTC
Created attachment 92819 [details]
4.1.4 version

The attached file (for Realtor client) retains its format normally in 4.1.4 and is scrambled on opening/saving with 4.2.0.3.
First noticed it with 4.2.0.1 and assumed it would be seen and corrected.

Please save a copy of the "Good" file as it will be scrambled on opening with 4.2.0.X.

Should have mentioned this earlier.

Feel free to contact me via my reported E-Mail.
Comment 1 m.a.riosv 2014-01-26 19:42:25 UTC
Hi Stuart, thanks for reporting.

Reproducible
Win7x64Ultimate
Version: 4.2.0.3 Build ID: c63c03decdf780d8fb80823950665b782ec9ecd0
Version: 4.2.1.0.0+ Build ID: 23221e48495262d0384c9169a0d8a01db8a5dab5
         TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-21_13:02:45
Version: 4.3.0.0.alpha0+ Build ID: 77637324abc193d831bb4a0fa6f9a91ef3601960
         TinderBox: Win-x86@39, Branch:master, Time: 2014-01-22_16:19:04

Works as expected with:
Version: 4.1.6.0.0+ Build ID: 873be8f3ff28fd06b531b17d2c7cc41cbc1385e

After open in 4.0.2.3 only the link in A1 is editable, the other links have merged text between links and they aren't editable. But the links even work.
The issue is saving as xlsx not saving as ods.
Comment 2 Kohei Yoshida 2014-02-19 04:49:48 UTC
Can you test this again using a more recent 4.2.1 or the master branch build?  This works fine for me.
Comment 3 m.a.riosv 2014-02-19 10:05:16 UTC
Works fine for me now with:
Win7x64
Versión: 4.2.1.1
Id. de compilación: d7dbbd7842e6a58b0f521599204e827654e1fb8b
Version: 4.3.0.0.alpha0+ Build ID: ecf22894f522374cbdb8196d3bdef88e2fba7af9
   TinderBox: Win-x86@39, Branch:master, Time: 2014-02-15_01:01:17
Comment 4 Kohei Yoshida 2014-02-19 15:38:15 UTC
Thanks much.  I remember I had fixed this one.

*** This bug has been marked as a duplicate of bug 74535 ***