Download it now!
Bug 74132 - Other: Find dialogs interrupt
Summary: Other: Find dialogs interrupt
Status: RESOLVED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA target:4.3.0 target:5.1.0 target:...
Keywords:
: 77112 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-28 02:23 UTC by Tin Man
Modified: 2016-10-25 19:20 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tin Man 2014-01-28 02:23:18 UTC
When a search reaches the end of the document (or the beginning, in the case of reverse search), a dialog pops up asking whether the user wants to continue searching at the beginning (or end) of the document.

This is an unnecessary interruption and violates the "ux-interruption" principle. Rather than showing a modal dialog, the label "Reached the end of the document" should appear at the end of the Find bar, as in Firefox, or, better yet, there should be a persistent label showing the order of the result out of all the results (e.g. "13/24"), as in Chromium.
The label should have a much lighter color than active buttons, to be clearly differentiated as non-actionable.

Similarly, the "Search key not found." dialog is an unnecessary interruption and should be replaced with a label in the find bar as well.
Operating System: All
Version: 4.1.0.4 release
Comment 1 Cor Nouws 2014-01-28 07:09:31 UTC
Nice idea!
thanks - Cor
Comment 2 retired 2014-01-28 10:49:19 UTC
Absolutely useful suggestion. Chrome does this best, Firefox can also learn from that and copy some improvements. LO can also learn and improve search in a similar manner. Love that idea Mirek2.
Comment 3 Commit Notification 2014-02-05 18:10:07 UTC
Matuš Kukan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=f25cdaa78d5e7d200fbaf31cce9895bab7c5ee63

fdo#74132: Do not interrupt search in Writer.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 4 Commit Notification 2014-02-05 18:11:27 UTC
Matuš Kukan committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=d50e08b4e18ad6fa8b4078df6e23ffbaf47e708c

fdo#74132: Do not interrupt search in Calc.



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 5 Cor Nouws 2014-02-05 20:09:07 UTC
Ahum, Matúš, Mirek,

Does the provisioned solution foresee in the situation where a search does not start at the beginning of a document, and that then from the end the searching automatically continues at the beginning?

(That was in any case my understanding of the idea...)

Thanks,
Cor
Comment 6 Tin Man 2014-02-10 19:08:28 UTC
(In reply to comment #5)
> Ahum, Matúš, Mirek,
> 
> Does the provisioned solution foresee in the situation where a search does
> not start at the beginning of a document, and that then from the end the
> searching automatically continues at the beginning?
> 
> (That was in any case my understanding of the idea...)
> 
> Thanks,
> Cor

Hi Cor,
If I'm not mistaken, the feature works the same way as it used to, except instead of a modal dialog, you get a label. You can still search from the middle of the document.
Comment 7 Jorendc 2014-04-07 21:14:58 UTC
*** Bug 77112 has been marked as a duplicate of this bug. ***
Comment 8 Commit Notification 2015-05-28 16:27:27 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=bc37514ed6b8694872d0e958428a940ca9835619

fdo#74132: Do not interrupt search in Impress and Draw.

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 9 Commit Notification 2015-06-02 05:34:30 UTC
Jan Holesovsky committed a patch related to this issue.
It has been pushed to "libreoffice-5-0":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=948d606b0260a33a5db77061f560afebde3fcdb7&h=libreoffice-5-0

fdo#74132: Do not interrupt search in Impress and Draw.

It will be available in 5.0.0.0.beta2.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 10 Commit Notification 2015-10-12 09:53:40 UTC
Miklos Vajna committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=8d1d280741f62d60fe56cd86da995b08228a1594

Related: tdf#74132 CppunitTest_sd_export_tests: clean up testSearch()

It will be available in 5.1.0.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds

Affected users are encouraged to test the fix and report feedback.