Bug 74156 - Sidebar adds complexity to UI
Summary: Sidebar adds complexity to UI
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: UI (show other bugs)
Version:
(earliest affected)
4.2.0.0.alpha0+ Master
Hardware: Other All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-01-28 16:23 UTC by Tin Man
Modified: 2015-06-21 08:47 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tin Man 2014-01-28 16:23:21 UTC
The sidebar brings yet another UI element to look through for commands, which adds unnecessary complexity to the UI. Please read through the usability problems Microsoft found with its Office task pane at http://blogs.msdn.com/b/jensenh/archive/2006/04/03/567261.aspx and how having a single UI element as a starting point fixed it at http://blogs.msdn.com/b/jensenh/archive/2005/10/11/479586.aspx. In our case, that starting point is the toolbar.

The sidebar should be split into individual panels (e.g. Properties, Formulas, Custom Animation, Slide Transition, etc.), with buttons for launching them added to the relevant toolbars if they are not already there as follows:
* Buttons for Properties should replace the buttons for the relevant formatting dialogs in contextual toolbars.
* Buttons for "Master Pages", "Custom Animation", and "Slide Transition" should be added to the Presentation toolbar.
* The Function Wizard button in Calc's Formula Bar should be linked to the "Functions" pane.
* Buttons for the Gallery, Styles, and the Navigator are already in toolbars [1].

[1] https://bugs.freedesktop.org/show_bug.cgi?id=73151
Comment 1 Cor Nouws 2014-01-28 21:54:43 UTC
a good one for the UX-Hackfest too - thanks!
Comment 2 Joel Madero 2015-05-02 15:41:06 UTC
** Please read this message in its entirety before responding **

To make sure we're focusing on the bugs that affect our users today, LibreOffice QA is asking bug reporters and confirmers to retest open, confirmed bugs which have not been touched for over a year.

There have been thousands of bug fixes and commits since anyone checked on this bug report. During that time, it's possible that the bug has been fixed, or the details of the problem have changed. We'd really appreciate your help in getting confirmation that the bug is still present.

If you have time, please do the following:

   Test to see if the bug is still present on a currently supported version of LibreOffice (4.4.2 or later)
   https://www.libreoffice.org/download/

   If the bug is present, please leave a comment that includes the version of LibreOffice and your operating system, and any changes you see in the bug behavior
 
 If the bug is NOT present, please set the bug's Status field to RESOLVED-WORKSFORME and leave a short comment that includes your version of LibreOffice and Operating System

Please DO NOT

   Update the version field
   Reply via email (please reply directly on the bug tracker)
   Set the bug's Status field to RESOLVED - FIXED (this status has a particular meaning that is not appropriate in this case)


If you want to do more to help you can test to see if your issue is a REGRESSION. To do so: 1. Download and install oldest version of LibreOffice (usually 3.3 unless your bug pertains to a feature added after 3.3)

http://downloadarchive.documentfoundation.org/libreoffice/old/

2. Test your bug 3. Leave a comment with your results. 4a. If the bug was present with 3.3 - set version to "inherited from OOo"; 4b. If the bug was not present in 3.3 - add "regression" to keyword


Feel free to come ask questions or to say hello in our QA chat: http://webchat.freenode.net/?channels=libreoffice-qa

Thank you for your help!

-- The LibreOffice QA Team This NEW Message was generated on: 2015-05-02
Comment 3 Buovjaga 2015-06-20 11:24:24 UTC
I think this can be closed now.
Comment 4 Adolfo Jayme 2015-06-20 18:42:03 UTC
?
Comment 5 Yousuf Philips (jay) (retired) 2015-06-21 00:54:02 UTC
(In reply to Mirek2 from comment #0)
> The sidebar brings yet another UI element to look through for commands,
> which adds unnecessary complexity to the UI. Please read through the
> usability problems Microsoft found with its Office task pane at
> http://blogs.msdn.com/b/jensenh/archive/2006/04/03/567261.aspx and how
> having a single UI element as a starting point fixed it at
> http://blogs.msdn.com/b/jensenh/archive/2005/10/11/479586.aspx. In our case,
> that starting point is the toolbar.

As the sidebar was hidden by default in all apps except for impress, most user wouldnt have encountered it unless they explicitly enabled it. In 4.4, the sidebar was enabled by default in non-impress apps but in its non-expanded state, so many users would still not utilize the sidebar unless they needed access to styles & formatting, navigator, or gallery. So users who would utilize the sidebar for the properties tab are users who would likely disable the formatting contextual toolbars and would prefer to have a UI layout similar to iWorks, Calligra and IBM Symphony.

> The sidebar should be split into individual panels (e.g. Properties,
> Formulas, Custom Animation, Slide Transition, etc.), with buttons for
> launching them added to the relevant toolbars if they are not already there
> as follows:

Putting buttons in relevant toolbars to open sidebar panels isnt necessary as the sidebar already has a tab bar of buttons.

> * Buttons for Properties should replace the buttons for the relevant
> formatting dialogs in contextual toolbars.

In Impress, contextual toolbars have been hidden by default in favour of the properties tab in LO 5.0.

> * Buttons for "Master Pages", "Custom Animation", and "Slide Transition"
> should be added to the Presentation toolbar.

Not needed as they are already in the sidebar's tab bar.

> * The Function Wizard button in Calc's Formula Bar should be linked to the
> "Functions" pane.

Totally agree (bug 92219).

> * Buttons for the Gallery, Styles, and the Navigator are already in toolbars
> [1] https://bugs.freedesktop.org/show_bug.cgi?id=73151

The Gallery and Styles are now exclusive to the sidebar.

I believe this bug can be closed.
Comment 6 Heiko Tietze 2015-06-21 08:47:02 UTC
Agreed to close