Bug 74264 - Editing Calc - Cut then Undo looses hyperlinks
Summary: Editing Calc - Cut then Undo looses hyperlinks
Status: RESOLVED DUPLICATE of bug 74414
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
4.0.6.2 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords: bibisected, regression
Depends on:
Blocks:
 
Reported: 2014-01-31 08:53 UTC by Daveo
Modified: 2015-12-17 07:35 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:
Regression By:


Attachments
Cut & Undo Example (14.68 KB, application/vnd.oasis.opendocument.spreadsheet)
2014-01-31 08:53 UTC, Daveo
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daveo 2014-01-31 08:53:22 UTC
Created attachment 93103 [details]
Cut & Undo Example

Version: 4.2.0.4
Build ID: 05dceb5d363845f2cf968344d7adab8dcfb2ba71
To reproduce:
  1. Select a cell or a range of cells with hyperlink(s) and cut.
  2. Click undo and hyperlink(s) disappear.
In the attached example file select cells A1 to A3 click cut then undo.
Comment 1 Cor Nouws 2014-01-31 10:39:16 UTC
Hi Dave,

I would expect this is one of the examples of the problem fixed in bug 74014 ..
Could you pls have a look, and maybe test a daily build?

thanks for reporting & your help!

Cor
Comment 2 Daveo 2014-01-31 21:18:21 UTC
Hi Cor,

Tested with Version: 4.2.1.0.0+
Build ID: 92346fb7714ca7c6a467771d8a8b01305c1b17d1
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-01-31_00:15:33

Hyperlinks still disappear after cut and undo.

Regards
Dave
Comment 3 ign_christian 2014-06-21 06:54:28 UTC
I must modify the procedure a bit to get more consistent result:

(In reply to comment #0)
> To reproduce:
>   1. Select a cell or a range of cells with hyperlink(s) and cut.
1b. Select another empty cell
>   2. Click undo and hyperlink(s) disappear.

Btw it's not really dissapear. If we select the cell, we can see the value in input line.

Reproduced under Ubuntu 12.04 x86 with:
LO 4.0.6.2, 4.2.5.2

Not reproduced with:
LO 3.5.7.2, 3.6.7.2
Comment 4 raal 2014-10-16 19:22:52 UTC
 d4eeea10e38fec832f258f1d4612f3cbaab2eacd is the first bad commit
commit d4eeea10e38fec832f258f1d4612f3cbaab2eacd
Author: Bjoern Michaelsen <bjoern.michaelsen@canonical.com>
Date:   Wed Nov 27 07:05:06 2013 +0000

    source-hash-3347f41a9b13c317c1d001e7ff501a4b0ee8f896
    
    commit 3347f41a9b13c317c1d001e7ff501a4b0ee8f896
    Author:     Kohei Yoshida <kohei.yoshida@collabora.com>
    AuthorDate: Wed Oct 23 13:17:00 2013 -0400
    Commit:     Kohei Yoshida <kohei.yoshida@collabora.com>
    CommitDate: Wed Oct 23 15:44:12 2013 -0400
    
        Avoid exposing the internal cell note storage outside ScDocument.
    
        Let's try to avoid including mtvelements.hxx in document.hxx...
    
        mtvelements.hxx is very parser-heavy, and document.hxx is included
        everywhere...
    
        Change-Id: I2768ba6e25f8ff10f61f9cfd4a7cbc4844230630

:100644 100644 7f9428c851b64605d78ff041a8ef2390db6ed7d7 d466ded23406425d7d460a296e3ffa43ccad7986 M	ccache.log
:100644 100644 b08ddbbe6b4c1a704226c9591da17245286a6ab0 449bd7891d4bc48ae1bfb394bd7a3b37a804dda9 M	commitmsg
:100644 100644 f202cdf6fb8d17505a2694eed4867bb6deb9ae9d a98e593e485d4dda43b7ddb9a77732d3e82ffe53 M	make.log
:040000 040000 543ce334ef95614317a778006afc160215a144e3 5a04653424cd190c25b54d9394a24451087d47d7 M	opt

git bisect log
# bad: [423a84c4f7068853974887d98442bc2a2d0cc91b] source-hash-c15927f20d4727c3b8de68497b6949e72f9e6e9e
# good: [65fd30f5cb4cdd37995a33420ed8273c0a29bf00] source-hash-d6cde02dbce8c28c6af836e2dc1120f8a6ef9932
git bisect start 'latest' 'oldest'
# good: [e02439a3d6297a1f5334fa558ddec5ef4212c574] source-hash-6b8393474974d2af7a2cb3c47b3d5c081b550bdb
git bisect good e02439a3d6297a1f5334fa558ddec5ef4212c574
# bad: [4850941efe43ae800be5c76e1102ab80ac2c085d] source-hash-980a6e552502f02f12c15bfb1c9f8e6269499f4b
git bisect bad 4850941efe43ae800be5c76e1102ab80ac2c085d
# skip: [a043626b542eb8314218d7439534dce2fc325304] source-hash-9379a922c07df3cdb7d567cc88dfaaa39ead3681
git bisect skip a043626b542eb8314218d7439534dce2fc325304
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# skip: [aba65c3e4c0df07e4909aeefb758cdb688242bf6] source-hash-827524abfb4b577d08276fde40929a9adfb7ff1a
git bisect skip aba65c3e4c0df07e4909aeefb758cdb688242bf6
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# bad: [c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31] source-hash-c69ed33628ec0b7abf6296539cf280d6c4265930
git bisect bad c81a8a0dcfc1ed095a80e4485c89dd0fcaf73f31
# good: [1d4980621741d3050a5fe61b247c157d769988f2] source-hash-89d01a7d8028ddb765e02c116d202a2435894217
git bisect good 1d4980621741d3050a5fe61b247c157d769988f2
# skip: [89110ca258fa7a15dfc546acfb39e76fc3eb2a44] source-hash-e450a2c506ac7cd4433b0f93fc750a89919bc03c
git bisect skip 89110ca258fa7a15dfc546acfb39e76fc3eb2a44
# good: [1cca92a409385d9288c28a54d5e3008e56728bc0] source-hash-7be7824bbbdeee6fa998b950e6046ab37fe690cb
git bisect good 1cca92a409385d9288c28a54d5e3008e56728bc0
# skip: [5fa28ce2931a35ae64ae08d3904cfb76d24459d8] source-hash-2304beaca33c63b94df99cb827716f00ce259f9a
git bisect skip 5fa28ce2931a35ae64ae08d3904cfb76d24459d8
# good: [2a9ff869c5638dc5c3aa387d0fe55c3291c86288] source-hash-01b7e04172889cbc9e4ac404b105e18ddc062d6f
git bisect good 2a9ff869c5638dc5c3aa387d0fe55c3291c86288
# bad: [387dd1052972d27a3065a249b357e50e0a29829b] source-hash-35836f350861b33a0c28307a413eff76d0433d1e
git bisect bad 387dd1052972d27a3065a249b357e50e0a29829b
# good: [5b0bc0b6253d7572470c6a3058d5fff68c93897f] source-hash-bdf2b506c38b38af531d8c8aa14dd51d89386899
git bisect good 5b0bc0b6253d7572470c6a3058d5fff68c93897f
# bad: [288796dca516e779d45513775be7c7bc3ff291f7] source-hash-5d0051efb99c6cbd0dc4dd655a71e7435159f6bc
git bisect bad 288796dca516e779d45513775be7c7bc3ff291f7
# good: [1b204196f0fbb248722573341fab666b41038431] source-hash-03e9845525037a02dac320ad09fb6eed34e9f0da
git bisect good 1b204196f0fbb248722573341fab666b41038431
# bad: [d4eeea10e38fec832f258f1d4612f3cbaab2eacd] source-hash-3347f41a9b13c317c1d001e7ff501a4b0ee8f896
git bisect bad d4eeea10e38fec832f258f1d4612f3cbaab2eacd
# first bad commit: [d4eeea10e38fec832f258f1d4612f3cbaab2eacd] source-hash-3347f41a9b13c317c1d001e7ff501a4b0ee8f896
Comment 5 Matthew Francis 2015-01-08 11:07:21 UTC
The symptom isn't identical, but the root cause is the same, and the cure was the below commit.

-> RESOLVED DUPLICATE

commit 1e3ef350d730bc54a3e9c393c2df6fd1f839a3a8
Author: Kohei Yoshida <kohei.yoshida@collabora.com>
Date:   Sat Feb 8 09:42:46 2014 -0500

    fdo#74414: No need to incremenet nRow here... It's just plain wrong.
    
    Change-Id: Iecdbb3eba46ddf2f2bc4f2334c7d45a4e2d801c8

*** This bug has been marked as a duplicate of bug 74414 ***
Comment 6 Robinson Tryon (qubit) 2015-12-17 07:35:25 UTC
Migrating Whiteboard tags to Keywords: (bibisected)
[NinjaEdit]