Download it now!
Bug 74291 - [Template Manager]: Deleting a template doesn't work anymore
Summary: [Template Manager]: Deleting a template doesn't work anymore
Status: VERIFIED FIXED
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: LibreOffice (show other bugs)
Version:
(earliest affected)
4.2.0.4 release
Hardware: All All
: medium normal
Assignee: Jorendc
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords: regression
: 77942 (view as bug list)
Depends on:
Blocks:
 
Reported: 2014-01-31 18:44 UTC by manj_k
Modified: 2014-04-25 19:21 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description manj_k 2014-01-31 18:44:26 UTC
Open the Template Manager via Start Center → Templates
Select a template
Click on the "Delete" button
Pop up: "Do you want to delete the selected template?" → Click on "Yes"

Expected: The template will be removed

Not expected: The template remains

LO 4.2.0.4 on Windows 7 64b
(works well for me with LO 4.1.4.2 / LO 4.1.5.1 → regression)


See also: http://ask.libreoffice.org/en/question/29140/libreoffice-42-osx-does-not-allow-me-to-deleteedit-anything-in-template-manager/
Comment 1 Jean-Baptiste Faure 2014-02-02 08:28:32 UTC
Reproducible with LO 4.2.1.0.0+ on Ubuntu 13.10 x86-64.

The deleted model is still there if I click on the action "update" (not sure of the English word, FR localization).

Best regards. JBF
Comment 2 Jorendc 2014-02-06 18:10:46 UTC
Fixed with this commit: https://gerrit.libreoffice.org/#/c/7902/
Currently under review
Comment 3 Jorendc 2014-02-07 15:51:39 UTC
Fix is merged.
Comment 4 Jorendc 2014-02-10 17:00:52 UTC
Also merged in 4.2.1 -> RESOLVED FIXED
Comment 5 manj_k 2014-02-10 17:54:32 UTC
Thanks a lot @Jorendc.

Verified (on Windows 7 64-bit) with:
LibreOfficeDev v4.2.1.0.0+
Build ID: 6a27efa43b2181599fb92ed99061e5b491dfd4a2
TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-10_09:42:34
Comment 6 Jorendc 2014-04-25 19:21:14 UTC
*** Bug 77942 has been marked as a duplicate of this bug. ***