Bug 74353 - EDITING: Drawing object Shift-resize to preserve aspect ratio isn't honored
Summary: EDITING: Drawing object Shift-resize to preserve aspect ratio isn't honored
Status: NEW
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.1.4.2 release
Hardware: All All
: medium minor
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Shapes
  Show dependency treegraph
 
Reported: 2014-02-02 09:02 UTC by dg1727
Modified: 2019-08-29 22:35 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dg1727 2014-02-02 09:02:19 UTC
1.  Create a new document in Writer.  
2.  On the Drawing toolbar, click the Basic Shapes menu-button and select an Isosceles Triangle.  
3.  Draw the triangle in the document.  When doing so, make the width and height to be roughly square.  
3.  Start dragging the lower-right selection handle.  
4.  Hold down the Shift key to preserve the aspect ratio.  
5.  Move the mouse to a position that is far to the right of the upper-left corner of the shape, but not very far down.  Without the Shift key, this would alter the aspect ratio of the drawing object.  But the transparent preview of the resize will correctly keep the aspect ratio drawn in step 3.  
6.  Release the mouse button (then release the Shift key).  

Issue:  The resized shape gets its aspect ratio from where the mouse was when the mouse button was released, ignoring the Shift key.  

LibreOffice 4.1.4.2 on Ubuntu 13.04.
Comment 1 dg1727 2014-02-02 09:08:40 UTC
With corrected step numbering :) 

1.  Create a new document in Writer.  
2.  On the Drawing toolbar, click the Basic Shapes menu-button and select an Isosceles Triangle.  
3.  Draw the triangle in the document.  When doing so, make the width and height to be roughly square.  
4.  Start dragging the lower-right selection handle.  
5.  Hold down the Shift key to preserve the aspect ratio.  
6.  Move the mouse to a position that is far to the right of the upper-left corner of the shape, but not very far down.  Without the Shift key, this would alter the aspect ratio of the drawing object.  But the transparent preview of the resize will correctly keep the aspect ratio drawn in step 3.  
7.  Release the mouse button (then release the Shift key).  

Issue:  The resized shape gets its aspect ratio from where the mouse was when the mouse button was released, ignoring the Shift key.
Comment 2 Dominique Boutry 2014-02-03 16:18:13 UTC
Reproduced (very slowly... not a problem of internal desynchronisation!) with LibO 4.2.0.4 on Win7.
Comment 3 Joel Madero 2015-05-02 15:42:53 UTC Comment hidden (obsolete)
Comment 4 Buovjaga 2015-06-20 19:15:22 UTC
Still repro.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 5 Stephane Messerli 2016-04-24 22:02:45 UTC
Bug still exists in 5.1.2.2 on Linux x86_64.
Comment 6 QA Administrators 2017-05-22 13:25:18 UTC Comment hidden (obsolete)
Comment 7 Thomas Lendo 2019-08-29 22:35:41 UTC
I can't reproduce the issue with Version: 6.3.0.4
Build ID: 057fc023c990d676a43019934386b85b21a9ee99
CPU threads: 4; OS: Linux 4.15; UI render: default; VCL: gtk3; 
Locale: de-AT (de_AT.UTF-8); UI-Language: en-US

Hopefully one of the original reproducing people can test it again and if it works now in a recent version of LibreOffice please change the status of this bug to RESOLVED WORKSFORME.