Download it now!
Bug 74356 - FILEOPEN: [DOC filter] Content piece of the table’s large cell is lost
Summary: FILEOPEN: [DOC filter] Content piece of the table’s large cell is lost
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: filters and storage (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: high critical
Assignee: Not Assigned
URL:
Whiteboard:
Keywords: filter:doc
Depends on:
Blocks: DOC-Opening
  Show dependency treegraph
 
Reported: 2014-02-02 09:43 UTC by ape
Modified: 2018-12-09 18:29 UTC (History)
6 users (show)

See Also:
Crash report or crash signature:


Attachments
MHT to DOC by WinWord-2007 (2.92 MB, application/msword)
2014-02-02 09:43 UTC, ape
Details
ODT file (fdo#74359) saved as DOC format by LibO_Dev-4.2.3.0.0+ (2.86 MB, application/msword)
2014-02-24 09:21 UTC, ape
Details

Note You need to log in before you can comment on or make changes to this bug.
Description ape 2014-02-02 09:43:12 UTC
Created attachment 93207 [details]
MHT to DOC by WinWord-2007

I saved the Web page as an MHT archive. I converted the MHT file to the DOC file using WinWord-2007 (see an attachment). I opened the DOC file using LibreOffice-4.2.0; 4.1.5 and saw the bug:
  A large peace of the table cell’s content is lost. Table cell, located on the tenth page of the document, contains an image whose size is equal to the page size. All information of the cell, located after this big image, is lost.
  I checked the operation of such programs: OOo-3.1.1; LibO-3.5.7, 3.6.7, 4.0.6; AOO-4.0.1. All of these programs are making the same mistake.
  This is a loss of information, so the status is critical.
Comment 1 Roman Kuznetsov 2014-02-02 11:47:37 UTC
confirm bug
Comment 2 Joel Madero 2014-02-02 17:04:43 UTC Comment hidden (obsolete)
Comment 3 ape 2014-02-24 07:25:10 UTC
  Miklos, 
I added you to the mailing list. Your patch solved the problem DOCX-files (bug 74357) very well. Please decide a similar issue with files of DOC format, if you have the time and opportunity.
--
ape
Comment 4 ape 2014-02-24 09:21:18 UTC
Created attachment 94636 [details]
ODT file (fdo#74359) saved as DOC format by LibO_Dev-4.2.3.0.0+

I have been using this version of the program:
LibreOfficeDev 4.2.3.0.0+ (Build ID: 5ba682c48e449f30e3cc1ec4acac75a6122ee6d7, TinderBox: Win-x86@42, Branch:libreoffice-4-2, Time: 2014-02-22_23:03:29)
--
The DOCX file (attachment 93208 [details]) was opened and then was saved as ODT format (attachment 94633 [details]).
The ODT file was saved as DOC format (see an attachment).
Writer (e.g. Writer-4.2.1.1) opens the DOC file is fine and shows all contents of all pages.
Comment 5 Joel Madero 2015-05-02 15:43:07 UTC Comment hidden (obsolete)
Comment 6 Buovjaga 2015-06-21 10:46:41 UTC
Confirmed.

Win 7 Pro 64-bit Version: 5.1.0.0.alpha1+
Build ID: 3ecef8cedb215e49237a11607197edc91639bfcd
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2015-06-19_23:16:58
Locale: fi-FI (fi_FI)
Comment 7 ape 2016-04-25 11:48:47 UTC
I confirm this bug:
LibO version: 5.2.0.0.alpha1; Build ID: 902b28a39528b6c92602e9b521a1d0861be1caf9
OS Version: Windows 5.2 x64
Comment 8 ape 2017-02-18 19:02:49 UTC
I confirm this bug:

Version: 5.4.0.0.alpha0+
Build ID: 0cd819b68ced2a95a127a246c0558153fbdbcae2
CPU Threads: 8; OS Version: Windows 5.2; UI Render: default; 
TinderBox: Win-x86@62-merge-TDF, Branch:MASTER, Time: 2017-01-31_12:28:03
Locale: ru-RU (ru_RU); Calc: group
Comment 9 Xisco Faulí 2018-02-13 17:58:30 UTC
Still reproducible in

Version: 6.1.0.0.alpha0+
Build ID: 37a2830387f437cf57104f7f509ec59944004e4d
CPU threads: 4; OS: Linux 4.13; UI render: default; VCL: gtk3; 
Locale: ca-ES (ca_ES.UTF-8); Calc: group

@Mike, I thought you might be interested in this one...
Comment 10 Mike Kaganski 2018-02-13 19:09:08 UTC
Hehe. It's not a loss of information. The data is there. Decreasing the last image so that is would be less than page height will return everything back (at least after print preview that causes layout recalculation).
Comment 11 eisa01 2018-12-09 18:29:15 UTC
This works for me in

Version: 6.3.0.0.alpha0+
Build ID: beae6c7a7f163daad0d4dea63a3d403af2745fd1
CPU threads: 2; OS: Mac OS X 10.13.6; UI render: default; VCL: osx; 
TinderBox: MacOSX-x86_64@49-TDF, Branch:master, Time: 2018-12-06_23:52:29
Locale: en-US (en_US.UTF-8); UI-Language: en-US
Calc: threaded