Bug Hunting Session
Bug 74362 - FILEOPEN: pptx in-slide transitions not working properly
Summary: FILEOPEN: pptx in-slide transitions not working properly
Status: RESOLVED WORKSFORME
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Impress (show other bugs)
Version:
(earliest affected)
3.5.0 release
Hardware: All All
: medium normal
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: Slide-Transitions
  Show dependency treegraph
 
Reported: 2014-02-02 11:07 UTC by Daniil Bratashov
Modified: 2019-02-16 03:09 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments
single-slide presentation working right (192.50 KB, application/vnd.openxmlformats-officedocument.presentation)
2014-02-02 11:07 UTC, Daniil Bratashov
Details
MSO screenshot of irreproducible slide state (52.06 KB, image/png)
2014-02-02 11:09 UTC, Daniil Bratashov
Details
example of animation that don't work (361.62 KB, application/vnd.openxmlformats-officedocument.presentation)
2014-02-02 20:28 UTC, Daniil Bratashov
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Daniil Bratashov 2014-02-02 11:07:11 UTC
Created attachment 93211 [details]
single-slide presentation working right

animations with moving elements inside a single slide do not correctly imported from pptx, making this slides unusable

How it should work: different parts of a slide should appear with mouse click or forward button

How it works: all content drawn at once, activation of underlying elements with mouse doesn't work.

can be related to bugs #61370 and #50440
Comment 1 Daniil Bratashov 2014-02-02 11:09:37 UTC
Created attachment 93212 [details]
MSO screenshot of irreproducible slide state
Comment 2 Daniil Bratashov 2014-02-02 18:06:32 UTC
It is either fixed, or appears conditionally, I'll reopen if it appears again.
Comment 3 Daniil Bratashov 2014-02-02 18:16:57 UTC
It is not fixed, but it appears only in large presentation made with MSO 2010/13 (don't know), single slide extracted with MSO 2007 works as it should.
Comment 4 Daniil Bratashov 2014-02-02 20:28:47 UTC
Created attachment 93252 [details]
example of animation that don't work
Comment 5 Buovjaga 2014-10-08 11:19:28 UTC
(In reply to Daniil Bratashov from comment #4)
> Created attachment 93252 [details]
> example of animation that don't work

I repro on Win 7 64-bit 4.3.2.2 and dev build Version: 4.4.0.0.alpha0+
Build ID: 276a046d5256b14478ab283f420654df6ae76b55
TinderBox: Win-x86@42, Branch:master, Time: 2014-10-08_00:21:52.
The animation goes on under the already visible elements.

slide-effects.pptx works OK.
Comment 6 Buovjaga 2015-01-07 17:37:29 UTC
Lowered version number after reproducing with:

Ubuntu 14.10 64-bit
LibreOffice 3.5.0rc3 
Build ID: 7e68ba2-a744ebf-1f241b7-c506db1-7d53735
Comment 7 QA Administrators 2016-01-17 20:03:35 UTC Comment hidden (obsolete)
Comment 8 MM 2016-03-06 22:38:03 UTC
Confirmed with v5.1.1.3 under ubuntu 14.04 x64.
Comment 9 QA Administrators 2017-05-22 13:20:22 UTC Comment hidden (obsolete)
Comment 10 cowbman 2018-08-21 00:00:07 UTC
Transitions on slides are not displaying.

For example some slides are set-up to display certain boxes when you click on a button in pptx. However, when viewed in Impress, it merely goes to the next slide entirely.
Comment 11 Mark Hung 2019-02-16 03:09:31 UTC
I saw
1. The first figure enters from the bottom with green title after the first mouse click.
2. The second figure enters from the left and the title enter from the right after the second mouse click.
3. The third figure enters from the right and the title enter from the left after the third mouse click. The text appears afterwards.

Though timing of letter-by-letter animation seems to be wrong, the sequence of the whole animation is almost the same as in PowerPoint 2010.

Verified With 6.2.0.2
版本:6.2.0.2 (x64)
組建 ID:2ce5217b30a543f7666022df50f0562f82be0cff
CPU 執行緒:8; OS:Windows 10.0; UI 算繪:預設; VCL: win; 
語言地區:zh-TW (zh_TW); UI語言:zh-TW
Calc: threaded