Download it now!
Bug 74394 - EDITING: Clicking the cell cursor should select the cell
Summary: EDITING: Clicking the cell cursor should select the cell
Status: RESOLVED DUPLICATE of bug 38994
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Calc (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: All All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 17:01 UTC by dg1727
Modified: 2014-12-01 12:38 UTC (History)
3 users (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description dg1727 2014-02-02 17:01:50 UTC
In a spreadsheet, to select only one cell (say A1), the user currently has to do the following:  

1.  Begin a drag on the cell of interest.  
2.  Continue the drag to an adjacent cell (say B1).  
3.  Continue the drag back to the cell of interest, deselecting B1.  
4.  Release the mouse button, leaving only A1 selected.  

A widely used commercial spreadsheet program allows the user to select A1 by just clicking the cell cursor (thick black rectangle), once the cell cursor has been placed on A1.  

Currently, clicking the cell cursor (except for the autofill handle) doesn't do anything in Calc.  

People who are used to the other spreadsheet program's way of selecting a single cell can be unaware for a long time that the above 4-step procedure is the LO equivalent.  These users can easily assume that selecting just a single cell isn't possible in Calc.  

Please consider adding the described single-cell selection method.  

I'm using LibreOffice 4.1.4.2 on Ubuntu 13.04.
Comment 1 dg1727 2014-02-02 19:06:23 UTC
As I now recall, the UI of that other spreadsheet program is a little different than I remembered when I first submitted this feature request.  

The following may be easy enough for existing LO users and for users of that other spreadsheet software to get used to:  

A.  When the cell is _not_ selected, drag from the cell contents (the area enclosed by the cell cursor) to select a range of cells.  This is unchanged from current LO.  

B.  When the cell _is_ selected, drag from the cell contents (the area enclosed by the cell cursor) to move the cell.  This is unchanged from current LO.  

C.  Single-click the cell cursor (except an autofill handle) to select the cell.  This is the same feature I requested in comment 0.  

D.  Drag from the cell cursor (except the autofill handles) to move the cell.  This is a new feature to LO.  I think this is what I was really thinking of when I first submitted this RFE.  The 4-step procedure that I listed is really only the first 4 steps of a 5-step procedure, step 5 being the same as item B.  That other spreadsheet program allows item D as a single step to replace LO's 5-step procedure.
Comment 2 Cor Nouws 2014-02-03 09:56:34 UTC
You can click and then Shift+CLick or Cltr+click to select one cell...

LibreOffice is not x-office.
Maybe introducing the behaviour you suggest would have a lot of consequences for other editing/behaviour...
Comment 3 dg1727 2014-02-04 03:52:08 UTC
Changing severity to "enhancement" per standard convention.
Comment 4 Joel Madero 2014-07-16 21:11:37 UTC
asking for expert calc advice here to see if we'd ever implement this kind of change.
Comment 5 Markus Mohrhard 2014-07-17 02:58:27 UTC
It is an old and valid enhancement request. There are surely a few duplicates of this one around.
Comment 6 dg1727 2014-12-01 12:32:53 UTC
(In reply to Markus Mohrhard from comment #5)
> It is an old and valid enhancement request. There are surely a few
> duplicates of this one around.

I happened to find bug 45059, for example, in which I think the submitter wanted what I've requested here.
Comment 7 dg1727 2014-12-01 12:38:39 UTC

*** This bug has been marked as a duplicate of bug 38994 ***