Download it now!
Bug 74408 - VIEWING: Modified line styles are ignored
Summary: VIEWING: Modified line styles are ignored
Status: RESOLVED DUPLICATE of bug 62925
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Chart (show other bugs)
Version:
(earliest affected)
Inherited From OOo
Hardware: Other All
: medium enhancement
Assignee: Not Assigned
URL:
Whiteboard: BSA
Keywords:
Depends on:
Blocks:
 
Reported: 2014-02-02 19:30 UTC by Tom
Modified: 2014-02-03 11:26 UTC (History)
1 user (show)

See Also:
Crash report or crash signature:


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Tom 2014-02-02 19:30:48 UTC
Problem description:

When a line style that is used by a chart is modified afterwards e.g. in calc, the modified line style is not automatically adopted by the chart and can even not be manually applied by editing the chart. 

Steps to reproduce:
1. Calc: Draw a line and define its line style to be a new "line style X"
2. Calc: Create a chart, enter the chart and format its major grid to use "line style X" (BTW: When a bar chart is created based on no data at all, the resulting empty bar chart is spoiled after returing back to calc)
3. Exit the chart, return to calc and redefine "line style X"

Current behavior:

The line style of the major grid of that chart remains unchanged. Even when editing the existing chart, the new "line style X" cannot be applied.

Expected behavior:

The "line style X" in the chart should automatically adjust to the changed settings of that line style. At least, when editing the chart manually and redefining the line style, the modified "line style X" should be taken into account.
Operating System: openSUSE
Version: 4.1.4.2 release
Comment 1 Cor Nouws 2014-02-03 09:32:25 UTC
Hi Tom,

Thanks for reporting.
I think more in general, chart makes no use of any style.
Which indeed would be rather convenient.

So you could change the subject of the issue to "styles do not work for charts" or something?

regards,
Cor
Comment 2 Cor Nouws 2014-02-03 11:26:37 UTC
(Couldn't immagine that there wasn't a report for this already ...)

*** This bug has been marked as a duplicate of bug 62925 ***