Bug Hunting Session
Bug 74435 - almost all images in document erroneously determined as visible by ViewObjectContactOfPageHierarchy when scrolling
Summary: almost all images in document erroneously determined as visible by ViewObjec...
Status: RESOLVED DUPLICATE of bug 63433
Alias: None
Product: LibreOffice
Classification: Unclassified
Component: Writer (show other bugs)
Version:
(earliest affected)
4.0.0.3 release
Hardware: Other All
: medium normal
Assignee: Michael Stahl (CIB)
URL:
Whiteboard: target:4.3.0 target:4.2.1
Keywords: perf, regression
Depends on:
Blocks: Image-Caching 73300
  Show dependency treegraph
 
Reported: 2014-02-03 11:26 UTC by Michael Stahl (CIB)
Modified: 2015-12-15 11:39 UTC (History)
4 users (show)

See Also:
Crash report or crash signature:


Attachments
some debugging output and assert for the bug (2.20 KB, text/plain)
2014-02-03 11:45 UTC, Michael Stahl (CIB)
Details
anonymized test file for bnc#777699 (49.64 KB, application/vnd.openxmlformats-officedocument.wordprocessingml.document)
2014-02-03 12:31 UTC, Cédric Bosdonnat
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Michael Stahl (CIB) 2014-02-03 11:26:22 UTC
with the TestBook2.odt document while scrolling down at some points
it is erroneously determined that > 200 images are visible;
loading all of them blocks the UI for 20 seconds
(and with additional regressions in bug 73300 eats > 2G of RAM).

regression from:

commit 8af09bf33291df2fb2bfbbd6e42f9bf074fcc4fc
Author:     Cédric Bosdonnat <cedric.bosdonnat.ooo@free.fr>
AuthorDate: Mon Sep 3 16:52:47 2012 +0200

    n#777699: Clip the objects to the pagewe are painting
Comment 1 Michael Stahl (CIB) 2014-02-03 11:37:06 UTC
fixed on master
Comment 2 Commit Notification 2014-02-03 11:38:09 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "master":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=66f8b54931f193bdc844c6bca388d9bde98779cd

fdo#74435: SdrPageView::DrawLayer(): hack to avoid spuriously visible images



The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 3 Michael Stahl (CIB) 2014-02-03 11:45:30 UTC
Created attachment 93277 [details]
some debugging output and assert for the bug
Comment 4 Cédric Bosdonnat 2014-02-03 12:31:32 UTC
Created attachment 93280 [details]
anonymized test file for bnc#777699
Comment 5 Michael Stahl (CIB) 2014-02-03 13:01:04 UTC
just noticed that this is actually already filed as bug 63433,
resolving duplicate since that is a MAB

*** This bug has been marked as a duplicate of bug 63433 ***
Comment 6 Commit Notification 2014-02-04 12:36:48 UTC
Michael Stahl committed a patch related to this issue.
It has been pushed to "libreoffice-4-2":

http://cgit.freedesktop.org/libreoffice/core/commit/?id=9c2c06e3fbe990316577c6f001683d7ce130ad40&h=libreoffice-4-2

fdo#74435: SdrPageView::DrawLayer(): hack to avoid spuriously visible images


It will be available in LibreOffice 4.2.1.

The patch should be included in the daily builds available at
http://dev-builds.libreoffice.org/daily/ in the next 24-48 hours. More
information about daily builds can be found at:
http://wiki.documentfoundation.org/Testing_Daily_Builds
Affected users are encouraged to test the fix and report feedback.
Comment 7 Robinson Tryon (qubit) 2015-12-15 11:39:19 UTC
Migrating Whiteboard tags to Keywords: (perf)
[NinjaEdit]